Jump to content
IGNORED

Riddle Me This...


Recommended Posts

Here's a puzzle for those experts at Nifscope...

 

Item 1 - Correct Skin Textures

Item 2 - Incorrect Skin Textures

 

Only difference I can find in Nifscope is the names of the parts of the armor very just slightly. (Item 1 Body 00 = Item 2 Body 01)

 

All textures for those parts are the exact same setup. (texture/character/imperial/f/footfemale.dds)

 

But for what ever *#*#$ reason Item 2 ALWAYS shows Tanned Skin while Item 1 shows the skin texture of Race "X" (Breton, Khajiit, DarkElf, Demora, etc...) I've purposely tried to fuck it up and choose a different skin texture... no effect.

 

I see no reason for this Enigma.

 

"What do you call a Bat that thinks it's a Cat?" - Riddler, Gotham City

Link to comment

Here's a puzzle for those experts at Nifscope...

 

Item 1 - Correct Skin Textures

Item 2 - Incorrect Skin Textures

 

Only difference I can find in Nifscope is the names of the parts of the armor very just slightly. (Item 1 Body 00 = Item 2 Body 01)

 

All textures for those parts are the exact same setup. (texture/character/imperial/f/footfemale.dds)

 

But for what ever *#*#$ reason Item 2 ALWAYS shows Tanned Skin while Item 1 shows the skin texture of Race "X" (Breton' date=' Khajiit, DarkElf, Demora, etc...) I've purposely tried to fuck it up and choose a different skin texture... no effect.

 

I see no reason for this Enigma.

 

"What do you call a Bat that thinks it's a Cat?" - Riddler, Gotham City

[/quote']

 

If this is what I think it is, it's not a nifskope problem, it's a short-coming of the oblivion engine. If you want a mesh to be treated like skin by the engine, meaning that the texture is automatically varied according to race, then that mesh's NiMaterialProperty must be named "skin". Double-click to change it.

Link to comment

LMFAO! Nice Uriel...

Brewmasterhal... I'll try it, however, that doesn't explain why 4 out of 10 Altered version show this issue(Mod Alpha and Mod AlphaV2 so you get the idea, Alpha works fine but I've got a few issues with V2). Technically 5 but Dwarven armor started working when I put the meshe into the Male slot instead of the female. And not one of the NiMaterialProperty's say Skin for the Dwarven.

 

 

AHAHAHAHAH!!!!!!!!!!! Ok... well. Worked... but now the entire armor is also the race skin color... >.<

OMG...

Link to comment

Ah ok... I see the issue... finally. who ever made the altered version put the same 6 NiMaterialProperty under all aspects of the armor/body... so I need to create a new one... but how?

 

NVM... think I just accidently figured it out. One test... oops... ok that didn't work... deleted out all of the NiMaterialProperty. So how do I remove just one???

Link to comment

Common misconception. Renaming the materialproperty to skin is only part of the solution. The node should also have a name that links it to the correct bodypart. Since HGEC uses the foot texture for all of the body except the hand, the body node should be named Foot, which can be followed by anything you want (Foot:Upperbody, Foot_001 or anything like that should work). Otherwise it will seem to work fine for imperial skins, but won't work for any other race.

 

As for the second problem, your mesh is optimised. All nodes link to the same materialproperty. In nifskope, under the spells menu there is an option Optimize -> Split properties. This will in most cases unlink the materials, so you can change them individually. Sometimes they will still be linked after splitting, if thats the case, you can force it to split by copying the (NiTriShape/Strips) branch, deleting it and then pasting it back in on the sceneroot.

 

Be sure to use the Optimize -> Combine properties spell when you're done with the mesh, this will make it easier for the game to render.

Link to comment

I figured out the Copy, Remove, Paste correction... now I just got to go through my 5 items with issues and correct them... and make sure I'm using the right meshe... I accidently saved the Dwarven armor as Mithril :P so I have Dwarven Cuirass when you equip Mithril Cuirass... oops.

Link to comment

1 out of 4 problems down towards my Futa and Female concept mod. My next problem goes right back to whoever designed the mod that gave me my first problem. Apparently, he/she doesn't understand the difference between a shemale and a futa (meshe is a shemale not a futa as mod name suggest, in other words they have balls).

Link to comment

Common misconception. Renaming the materialproperty to skin is only part of the solution. The node should also have a name that links it to the correct bodypart. Since HGEC uses the foot texture for all of the body except the hand' date=' the body node should be named Foot, which can be followed by anything you want (Foot:Upperbody, Foot_001 or anything like that should work). Otherwise it will seem to work fine for imperial skins, but won't work for any other race.

[/quote']

I wasn't sure about pointing that part out, since I've occasionally run across working .nif files that do not conform to the Foot:Body thing, but you're right. Make sure everything is named Foot:something to be on the safe side.

 

As for the second problem' date=' your mesh is optimised. All nodes link to the same materialproperty. In nifskope, under the spells menu there is an option Optimize -> Split properties. This will in most cases unlink the materials, so you can change them individually. Sometimes they will still be linked after splitting, if thats the case, you can force it to split by copying the (NiTriShape/Strips) branch, deleting it and then pasting it back in on the sceneroot.

[/quote']

 

My favorite solution to this problem is to copy the NiMaterialProperty and paste it into NiTriShape you want, then update the Properties dropdown in the NiTriShape to reflect that one material property should be excluded and the other kept.

 

Ok my guess right now is this is not a Nifscope problem... it's a blender one instead. Am I correct in this idea?

 

Would it help if you posted the .nif to mediafire or something so we can all see what you've got and what's going on? I'm sure any of us would be happy to dig in and tell you exactly what's up, but I for one am not entirely clear on the situation.

Link to comment

1. Incorrect Textures on 4 pieces... Corrected

2. Shemale instead of Futanari... working

3. No robes were modded for Futanari... not started

4. Making Alts. of all stock items for Futanari... not started

5. Male NPCs transformed to female. Problem, face shows beard unless I transform them into Tabaxi, Wild Tabaxi, or Frost Tiger... not started

 

 

So found a plugin for blender to be able to import/export Nif files... but it's for v2.5.8... I picked up v2.60a will it still work? or someone know where to get one for that version?

Link to comment

My once simple idea has now become a colossal pain in the ass. While I've got Blender (v2.60a) I can't export them into anything NifSkope will use. I've downloaded the scripts for Nif, requires python, downloaded that one, requires some other python plug... OMG!! I'm so tired of programs needing other programs to work... just fucking include them or put them in the same page and say download this first, second, third, done.

 

A version of Python which can run qskope/niftoaster was not found: shortcuts will not be created and batc files will not run.

Link to comment

I've got Blender (v2.60a)

 

this is your problem

 

you are trying to use a version of blender that the other required programs were never updated to work with.

 

go here and get 2.49b this version will work for modding oblivion and a great deal of other games as well.

 

http://www.tesnexus.com/downloads/file.php?id=12248

 

also be sure to read the description for additional info

 

 

Link to comment

LOL... ok... so thanks to GSModders I'm kind of on track... 1st test item complete... modding clothing on the other hand... that's going to take ALOT of finesse that I just don't have yet. Moved around the nods so there wasn't any clipping on my altered Futa Undies... took a quick side view look... it looks like the (Name) Mountains. LoL... well can't say I'm not learning... pull up some other version and see how they went about modding clothing to adjust for *cough* an extra package.

 

 

Or just a better Idea on how I need to go about it... muhahahahahah

Link to comment

Grrrr... So I altered my clothing in Blender (doesn't look great but hey it works, no clipping) but it only saved the clothing... not the *cough* extra package with the clothing. Looking at my altered clothing in Nifskope to get textures and... they have no panties or >.> extra... stuff. Tried copy paste, no workie. So I'm guessing I need to go back into blender and "re-save" them so that my mistake is part of the package... just gotta figure out how to combine them to one Nif.

 

>.> Copy Branch... durtadur

Link to comment

Recap... fixed my texture issue on 4 armors... created futa robes seeing as none exist... my robes leave the character with only a head, hands, and feet. Comparing my versions to the original ones shows no reason for this... somewhere in Blender or Nifskope I fucked up... but where.

Link to comment

I might have figured out why my robes are invisible... but I need someone to answer a simple question.

 

When using Nifskope the flow should look like...

0 NiNode Scene root

(1) NiTriStrips (Body part: name, Tri uperbody:01)

(2) NiTriStrips (Body part: name, Foot:bodyE 0)

Etc...

 

What I've got somehow is...

 

0 NiNode Scene root

(1) NiNode Scene Root:00 <-- this needs to disappear correct??

(2) NiTriStrips Tri upperbody:01

Etc...

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...