Jump to content

Weird shadows from/on armor.

Recommended Posts

I did some minor editing to an armor in outfit studio. All I did was apply the bone weights of the body I use to the armor (which i have done in the past) to enable HDT physics. The armor was otherwise the same bodytype, same bodyslide files, etc. as the body I normally use. (Everything CBBE HDT).


As I saved, it mentioned something about unweighted verticles and masking them. I clicked okay.


For the most part the armor works. Like 99% is exactly what I wanted. However, when wearing the armor shadows can get all weird and appear on the armor, my charachters face, and stretched across the ground. Remove armor, and the shadows vanish. I also noticed two spikes that are supposed to be on the pauldrons are not there (the parts masked by outfit studio when it mentioned unweighted verticles.)


Now the easiest fix is probably to just reinstall the armor, but it is part of a large set (several of which were more successfully modified). How to I fix the shadows for this armor (whether it is related to the verticals or not). And part of me suspects it is not because I have an unmodified armor from a different mod with a near identical glitch (shadows always appearing on hands or in weird places when equipped). I'd like to know how to fix that one too.


And if deleting shadows entirely from a particular armor set is possible, I am also 100% okay with that as a solution.

Link to comment

when it gives that warning about masking unweighted vertices, you really need to stop there. since the vertices are under a mask, they will not be saved, and your mesh will behave . . . incorrectly. that is if it doesnt just cause a CTD when equipped. as said above, you gotta paint those weights.

Link to comment

Ok I painted the bone weights on the pieces that it said were missing bone weights. I inverted the mask and it still tells me those pieces are missing verticals. In addition, for one of the pieces, when I inverted the mask to see what spots had missing weights, the new mask covered the entire thing (suggesting to me that the entire thing has bone weights). I don't understand why it's still giving me the error message.

Edited by Aki K
Link to comment
19 hours ago, T-lam said:

Load again in OS and invert mask.

Than manually paint bone weights


So no matter how much I paint the bones, it doesn't seem to save. I still get alerts of missing verticals, I still get weird shadows, and the parts I need to paint are still missing.


And for one of the pieces with alleged missing weights, when i mask the "missing parts" nothing is missing. Not the slightest part.  I'm going to attempt a reinstall, but I want to send the files (if I can find which folder they're in) and maybe you can tell me what's wrong with them. 


EDIT: I can't seem to save the data or copy it for some reason. The file location is weird due to how MO2 works, and it only exists while MO2 is using it. Otherwise the file location isn't actually where the address says it is, and I'm not sure how to copy it. I tried to use outfit studio to save a copy to the desktop, but it doesn't appear to be visible despite me having the setting set to show hidden files. God this setup is so broken lol.


EDIT 2: Disregard EDIT one, I am just bad at tech. .nif attached. I'm going to attempt a partial reinstall/fix now. Wish me luck.

Broken Falmer nif.zip

Edited by Aki K
Link to comment
On 7/29/2021 at 12:32 PM, T-lam said:

Just a hint, look inside the clothing.

I had a case where lines inside crossed the body from rear to front.



On 7/29/2021 at 2:27 PM, Swe-DivX said:

I attempted to look inside the clothing but to no avail on my end. Had to do a full reinstall.


Also for some reason my mod organizer setup is causing a weird issue with file locations. The file locations for the bodyslide files outfit studio access seems to only exist to outfit studio and when running the game. I can copy the files from the location nor copy files into it. It doesn't even show up when I search my computer. Not sure if that's a mod organizer oddity or something else. It's weird. It tells me the files are in ElderScrolls/Data/calientetools/etc.  But elderscrolls/data doesn't have a calientetools folder like the address says. It's weird. So until I find where mod organizer is putting the actual files, I'm not sure how to test this.


However, I do have that other armor I wouldn't kind advice on. This is one I haven't done any modification to, I'll post the link to the mod. For some reason there are odd shadows on the character, usually the hands. The original version of the mod doesn't have that, but I'd like to get this version working since it has zap options. Efforts to edit things that have zaps in the past though removes the zap options (probably because I don't fully know what I'm doing). (https://www.loverslab.com/files/file/12171-dwarven-devious-cuirass-variations-cbbe/)


If possible I want to learn how to fix the shadows for this armor and keep the zaps.  If I can do that, all my armors will be fully functional again (hopefully).


EDIT: and I am aware the mod page says the shadows have been fixed, but I'm still seeing weird lighting and shadows on my end.


Edited by Aki K
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...