Jump to content

Male body texture issues in TK17VXF_Update1.00p

Recommended Posts

Hi all,


I have mentioned this problem in the discord channel as well, posting here since I didn't get anyone's help yet.


I recently updated my VX version from Patch G (TK17VXF_Update1.00g) to Patch P.( TK17VXF_Update1.00p). After that, when I try to change my male models skin texture in the customizer,  body texture are is not getting changed, only head, hand, genitals and foot textures are changed according to the skin. PFB screenshot that shows the problem.


The body texture is just keeping the original texture that it is having with the model. Even this happens to new models that I created from base models such as Sunny, Rex, etc However, this issue can be resolved when I switch to Patch G again using my backups done before upgrading. (Luckily I have backed up Binaries, config, temp, texture, vx-mod, vx-patches folders before updating and I have restored them after removing these folders) I’m using paid Hook5, But I tried this with Patch P without Hook5 and the result was the same issue, body texture is not updating. Even I tried removing all of my Addons in the Addon folder whether to see this is caused by any new addon, but that also leads to the same issue.


This issue is happening to Male Models only in Patch P, that is for all the skins, doesn't matter the skin is a Hook5 one or not. but this issue is not happening with my Female models and I can change their skins without any problem in Patch P also. I have no idea how to resolve this. ?


I have attached the Klub-10.log file from Patch P, hope it'll help to identify the issue.


If anyone can help me, I really appreciate... 


Thanks in advance... ☺️



Link to comment

Thank you Marburg for helping me on this problem.

I have attached the Log folder. I just loaded the game after applying patch P, created few new Models from base models, loaded a room, in customizer tried changing the skins, and the problem as occurred same as before. Exited the game. Hope the error is correctly captured there in the log files.


Also a side question, I have noted that my Model folder is having now 1600th Model and not able to create a new Model(Model1601), unless I delete some of models(like 1595-1600) and free the count.

Is this the current limitation of model count to have Model1600 as the max number?


Link to comment

Is this the current limitation of model count to have Model1600 as the max number?

 i dont think so. On the other hand: 1600 models is a lot by any standard. Everything needs to be loaded, parsed, collected in lists and selection boxes and at some point there's no more memory. 


Question: do you use a re-pack or some Mega addons? A lot of your addons get ignored, probably because they are outdated and try to change files they're no longer allowed to change. The addon Custom.Body generates a lot of warning signs. Please try to Disable it (simply add ".disabled" to the folder/zip name) and see if that helps.

There's a numnber of Persons*.bs file that throw up errors and i suspect they could be loaded from there.










Link to comment

Thanks for your reply. ?

I use the standard game not any repack, but as you said I have a lot of addon mods.

Custom.Body is just a collection of bodies that zipped in to a single .zip file, which I did in V7.5 to improve the game performances.

As I mentioned in my initial post, I tried moving all the addons to a different location and running the game without any addons, just with an empty addon folder. that also caused this texture problem. so can't be that is the case.


Interesting thing is, this is totally working fine in Patch G, So I guess something in between Patch G an P is causing some interference to load the textures properly in my installation.

I'm not interested in doing a re-installation at the moment, just to install patch P and hope I'll live with Patch G until I find a solution for this, like I did for CollaTKane ?

May be I need to try with empty Models folder to see whether that helps...

Link to comment

Ok.. Finally... some good news, I managed to load the male textures on Patch P, after removing all of my addons in addon folder and removing all the ActiveMod folders, except 5 Male skins. This time the body texture loaded properly.

So I guess some of my addons and textures causing this issue. So I have to put few addons/textures at a time and see which mod/texture causing this.


Thanks @Marburg for your advice on this. ?


But my question is, All of my addons and textures works fine in Patch G.

Why it is an issue in Patch P?


Link to comment

G to P is quite a big jump in versions. A lot of changes take place with every release, both visible and under the hood.

If i recall correctly (im old, my memory chips are rusty) the rules for addons became more restrictive somewhere along the route from G to P.

Older body mods in particular have a tendency to mess with files that are now "protected" like the Customizer menu script.



Custom.Body is just a collection of bodies that zipped in to a single .zip file, which I did in V7.5

just as i feared... 7.5 bodies.  I bet most of them are not functioning correctly (if at all).


My advice in this and similar cases: start a new, fresh VX install and gradually add your old content, step by step, to see what works and what doesnt


Edited by Marburg
Link to comment
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use