Jump to content

Recommended Posts

 

I'm having trouble with the WW mod. I start the game!!!!! Its says WARNING your game isn't the legacy version (which it is) and the mod is a legacy version. I need help please!!!!

 

This is what's in the corrupted file that comes up each time

 

Game Version: 1.73.57.1030, LegacyWickedWhims Version: v3
05/06/21 02:55:45 Traceback (most recent call last):
  File ".\LegacyWickedWhims_v3\turbolib2\events\utils\events_handler.py", line 66, in execute_event_methods
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 86, in _wickedwhims_update_lot_structure_data_on_zone_load
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 96, in _update_lot_structure_data
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 116, in _get_lot_structure_signature
  File ".\LegacyWickedWhims_v3\turbolib2\services\world_service.py", line 230, in get_all_blocks_polygons
TypeError: get_all_block_polygons() takes 1 positional argument but 2 were given
TurboLib: [TurboLib] Failed to run '_wickedwhims_update_lot_structure_data_on_zone_load' method from 'WickedWhims' -> TypeError: get_all_block_polygons() takes 1 positional argument but 2 were given

Game Version: 1.73.57.1030, LegacyWickedWhims Version: v3
05/06/21 02:55:46 Traceback (most recent call last):
  File ".\LegacyWickedWhims_v3\turbolib2\events\utils\events_handler.py", line 66, in execute_event_methods
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\autonomy\trigger_random.py", line 63, in _wickedwhims_reset_random_sex_autonomy_game_update
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\autonomy\trigger_random.py", line 120, in _get_random_sex_interval_from_frequency
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\autonomy\trigger_random.py", line 112, in _get_random_sex_frequency
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\autonomy\utils\sims_pairs.py", line 70, in get_sims_relationship_sex_pairs
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\autonomy\utils\sims_pairs.py", line 189, in _get_extra_sex_pair_score
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 126, in get_lot_structure_data
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 96, in _update_lot_structure_data
  File ".\LegacyWickedWhims_v3\wickedwhims\main\buildbuy\lot_structure.py", line 116, in _get_lot_structure_signature
  File ".\LegacyWickedWhims_v3\turbolib2\services\world_service.py", line 230, in get_all_blocks_polygons
TypeError: get_all_block_polygons() takes 1 positional argument but 2 were given
TurboLib: [TurboLib] Failed to run '_wickedwhims_reset_random_sex_autonomy_game_update' method from 'WickedWhims' -> TypeError: get_all_block_polygons() takes 1 positional argument but 2 were given

Game Version: 1.73.57.1030, LegacyWickedWhims Version: v3
05/06/21 02:56:11 Traceback (most recent call last):
  File "T:\InGame\Gameplay\Scripts\Server\sims\masked\v3\exception_watcher_wrapper.py", line 25, in wrapper
  File ".\LegacyWickedWhims_v3\turbolib2\services\dialog_service.py", line 429, in _exception_wrapper
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\integral\dialogs\sex_init_player.py", line 65, in _sims_picker_callback
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\integral\dialogs\sex_init_player.py", line 271, in open_start_sex_animations_picker_dialog
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\animations\animations_operator.py", line 42, in __init__
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\animations\animations_operator.py", line 50, in _get_random_animation
  File ".\LegacyWickedWhims_v3\wickedwhims\sex\animations\animations_operator.py", line 286, in get_animation_generic_additional_query_tags
  File ".\LegacyWickedWhims_v3\turbolib2\services\world_service.py", line 77, in is_location_outside
TypeError: is_location_outside() takes 2 positional arguments but 3 were given

 

 

 

Please help!!!!!!!!!!!!!!!

Link to comment

The file says you're not using legacy though.

Are you sure you actually are a legacy user?

Cuz downloading the regular version of WW should fix your issue.

 

Also, don't send in the contents of the file next time, attach the file itself!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use