Jump to content

3DS Max/Oblivion animation Bip01 issues


Teechan

Recommended Posts

Hi folks.

My goal is to get some advice on moving animations in Oblivion using 3DSMax (2010) - because honestly? I'm a stumped newbie, and having a hard time finding info on this. I'm using Figment's version of the Niftools exporter fromt the Nexus.

My goal is to have more control recording npc actor fight scenes for videos. I fgured it would be easier to play short sequences as idles rather then slow down time/take multiple shots of npcs in combat.  Importing .kf's one at a time gets buggy if you're not careful (as bones/meshes tends to glitch on import, resulting with feet coming out of your model's head.) So, still pretty much teaching myself this stuff from the ground up, I turned to saving each movement animation (walkforward, walkfastforward, ect) as .xaf's. I'm also learning more about NifSkope, and bla bla bla. :P


This is my sample animation - imported a walkforward kf, loaded a walkforward xaf after that, added a walkfastforward xaf, and a forward dodge xaf (which came in rotated) as a test.



The export comes out well in game, but they "run in place".

Following the "How to Fix Your Animation" article on the Nexus Wiki,  I understand that to make movement animations one needs to animate the Bip01 bone.

 

 

 

It's walking in y axis, the same way the armature was facing. I even tried rotating and exporting 90 degrees, resulted in the character turning and running in place. ;D I changed text keys to read "forward", but nothing really changed.

So..anyone have any pointers that I may have missed?

post-16569-0-90378100-1365899604_thumb.jpg

Link to comment

For normal looping animations you would have a start at frame one (1/start) and then an end at the last frame of the animation, lets say sixty in this case (60/end). 

However in the case of walking animations you do something a bit strange.  You need to change the end frame number to be 25001 (or something like that) and then you won't walk in place anymore.  Found that out by looking at other walking animations like the sexy walk ones.

 

Cheers,

Greg

Link to comment

Wow, it fracking worked. :D Thank you!

 

(now that I got them walking as an idle, I found an unfortunate side effect of the npc "snapping back" to where they started after the animation plays. But for now, I'm happy they're no longer running in place.

 

I love this forum. ;D

Link to comment

Ok, I think I see part of the problem but I need a bit more explanation from you to be certain. 

The walk forward is a loop animation but the forward dodge is a clamp animation.  A clamp animation is one that plays only once.  If you are mixing them both into one kf file you may have issues and that may be the cause of the "snapping back".

 

Now for the questions: 

1. Did you combine the kf files into one?

2. If you did, is the forward dodge the last in the chain?

3. Are you wanting the combined animation to loop continuously or just play once?

Link to comment

1. Not exactly. First I imported a walkforward.kf, then extended the time and loaded a walkforward.xaf (I imported each .kf into a different scene and saved each animation as .xaf beforehand). After that, I loaded walkfastforward.xaf and dodgeforward.xaf, and after adding text notes, exported everything as one single .kf. (I found I have to load a vanilla .kf before loading any .xaf, otherwise the animations won't work correctly just by loading .xaf's by themselves.)

 

2. Dodge Forward would be last in the chain.

 

3. I wanted this to play only once, so I used cycle_clamp.

 

Perhaps I should try deleting the .xaf's I made.  I'll change the looping .kf's to cycle_clamp in NifSkope, then save as .xaf  and see if this fixes anything.

Link to comment

Haha, changing the kfs to cycle_clamp before saving as .xaf didn't do crap. The npc would still snap back. But what I did was take note of the movement text keys (IE: m:L, m:R) for each .kf, and modified the merged scene file's dope sheet note track to add those. Without them, I can see in the debug (sdt 33) in game that Bip01 wasn't really moving anywhere; the character would play the animation, just like a ghost, before looping back.

 

So, good news is now the animation no longer snaps back, and I can see in debug mode that Bip01 is moving. What it DOES do now is walk sideways, which made me think "OH, is THAT the #$%@! 90 degree bug everyone's complaining about!!"

 

I just installed Blender and the exported .kf walks sideways in the same direction as in game. So now I'm on the case again, as I think there's a answer for a fix somewheres. ;D

Link to comment

So far we never have been able to resolve the 3dsmax 90 degree bug.  A bunch of different folks have worked on it but so far nothing has been figured out.  If you do manage to figure it out please do holler as there are tons of folks who would be interested.

Link to comment

I think I just did. You have to fix it in Nifskope.

 

http://wiki.tesnexus.com/index.php/Avoiding_Blender_animation_pitfalls

 

Check the part under "Post-Export tweaking in Nifskope." I was able to fix it the "easy" way. You have to find the corresponding number for Bip01 and Bip01 NonAccum, then look it up in the Block List to change the value from 90 to 0.

 

 


post-16569-0-32287200-1366143082_thumb.jpg

 

EDIT: Find the NiTransformInterpolator value for both Bip01 and Bip01 Non Accum.

 

post-16569-0-65020100-1366143092_thumb.jpg

 

post-16569-0-79145500-1366143112_thumb.jpg

 

post-16569-0-11307800-1366143130_thumb.jpg

 

post-16569-0-81758000-1366143147_thumb.jpg

 

I hope this helps other folks. It seems to work for me in this case. :)

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use