Jump to content

3ds - Painting a texture applies it to the wrong side


dashipper

Recommended Posts

So I made a model in 3ds max as I tend to do.  I went to paint the model with the viewport canvas and it seems to be giving me trouble.  I'm working on a helmet and when I go to paint the front of the helmet, the paint gets applied to the back of the helmet instead.  No matter where I paint, the brush seems to ignore the layer that is facing me and instead paints on the far side of the mesh.  Does anybody have any suggestions?  Help would be greatly appreciated.

Link to comment

Are your poly faces flipped?

It doesn't look like it.   I just double checked the normals and they are pointed in the right direction.  The viewport canvas isn't painting the inside of my model, just the opposite side of the armor.  Painting the face ends up painting the back of the head.

 

You need to do a UV unwrap and make a layout. If you haven't made one the seams will be all over the place and usually canvas will paint on the faces as if they were stacked up.

I unwrapped my UV before I started painting.  I checked my seams again and everything looks good on that front.

Link to comment

I should also add that with every other model I've made or edited, I could see both sides of a polygon.  Now I can only see the top side of the polygon.  Checking and unchecking backface culling has no effect.  Is there an option somewhere else I may have ticked on accident? >.>

Link to comment

You wouldn't happen to be using an ATI card by chance would you? I ditched vc because it was so touchy. You could try reverting between dx drivers or settings to see if that has any effect, but its a given that vc is really buggy and even the autodesk forums aren't much help.

Link to comment

Nope, I have a Nvidia card.  This problem is perplexing the hell out of me.  Normally I don't use the viewport canvas other than to apply a material and a bogus texture just for exporting, which I suppose I don't even need to do since I end up replacing the BSLightingShaderProperty in nifskope anyway... but when I do use the vc it usually works fine (at least since upgrading from the student version).

 

I'll try making it remake the ini file later and see if it reverts any settings I may have screwed up when I import the mesh again (since I feel like the .max file saves the settings for the scene?  Maybe?) and if that doesn't work I'll try swapping dx drivers this weekend.

 

If that doesn't work, is there something else I can use to paint on the actual model and not on the 2d uv layout?  There's one portion in particular that would be hard to paint in 2d as the seams get a little bit wonky and don't quite look right.

Link to comment

All that autodesk learning software might have something you can use. Mudbox is in there if your willing to try it out but I can't remember if it supports painting textures. I tried bodypaint once its nice but I like painting on layouts more than in a viewport.

Link to comment

This could be happening because of how you imported the model, some models need to be flipped in order for the textures to be properly applied. I usually only run into this with poser and xna models but it will sometimes happen with tes nifs as well. selecting the entire scene and flipping it along the x, y, z axis as needed will sometimes fix things. If you are working with a custom model of your own, you still may need to flip it accordingly. if you are importing a model looking up import instructions for the models format should eliminate the need to flip it.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use