Jump to content

screwed up vertices after exporting from Blender


turbosundance

Recommended Posts

i'm trying to get the hang of importing and exporting meshes with Blender.  I have sucessfuly imported and exported various meshes and and a lot fo them have worked but a lot of them end up screwed up. When I compare the screwed up ones to the original ones, the file size is uaually three times the size of the original and the vertex counts end up exponantially bigger then the original mesh. 

 

The example I have been working on has been adding weighting for the TBBP skeleton to the Lady Body mesh.  I can produce a working _0 and _1 mesh but the slider never works after I add the weighting and skeleton to the files and the files end of around 3mb each when they should be around 1mb.

 

Anyone have any suggestions on what I should look at?  I'm getting a bit frustrated.  3ds Max creates terrible mesh gaps for me and now I'm having an annoying problem with Blender.  FYI, I have never done and any 3D modelling or edited any meshes until the release of skyrim.

Link to comment

If you're willing to post the Blend file, I'd be happy to take a look.

 

My initial guess would be that you might be experiencing a problem with boneweights and vertex groups.  If any given vertex has too many vertex groups, Nifscripts will tend to split that vertex into several vertices during export.
 

But there are lots of other possibilities.

Link to comment

I did a test just now.  I imported the LadyBody_0 mesh into blender.  I then redid the material and bdismemberment and exported it again.  Verticies went from 4959 to 26903 md the file size grew from 476kb to 3,014kb.  I'm clearly doing something wrong.  I have been following this tutorial: http://wiki.tesnexus.com/index.php/Creating_an_armour_for_Skyrim._Part_1#Import_into_Blender_all_parts_of_the_0.nif_body

post-32908-0-94936100-1360178655_thumb.jpg

Link to comment

I did a test just now.  I imported the LadyBody_0 mesh into blender.  I then redid the material and bdismemberment and exported it again.  Verticies went from 4959 to 26903 md the file size grew from 476kb to 3,014kb.  I'm clearly doing something wrong.  I have been following this tutorial: http://wiki.tesnexus.com/index.php/Creating_an_armour_for_Skyrim._Part_1#Import_into_Blender_all_parts_of_the_0.nif_body

 

I think I see the problem.

 

Take a look at the mesh in Blender.  Do you notice how the entire mesh looks almost faceted, as if it were a cut gemstone rather than a person?  That generally means that your vertex edges are set to sharp.  In order to preserve these sharp edges, the vertices must be split during the export process.

 

This is fine if your goal is to create gemstone monsters, not so much if you want realistic human meshes.  Fortunately, there is an easy solution.

 

Select the mesh, and hit the tab key to enter edit mode.  Now hit 'a' until all of the vertices are selected.

 

Next, hit 'w'.  This should open a popup menu.

 

Look for the entry 'Set Smooth' and select it.  (NOTE: do not click on 'Smooth'.  That's something completely different and NOT what you want)

 

Tab back out of edit mode and export.  You should be good to go.

Link to comment

I'm sorry to say, I have no idea how that system is set up (I mostly mod Blender rather than Skyrim).

If I were to hazard a guess (and to be clear, this is just speculation), they are probably averaging vertex positions between the meshes, and the position of the slider determines the relative weight given to the respective meshes. If that's the case, then they are probably just matching the vertices up by vertex index.

That would mean that anything that causes the vertex indices to be different between the two meshes is likely to cause weird distortions and other horrors.

So how do you fix it?

That's a toughie. My recommendation?

Grab my BodyType Converter Script and use it to convert your light body mesh into the shape of your heavy body mesh and export your modified light body mesh as your heavy mesh.  Since you'll have exported two versions of the same mesh (the converter will move vertices, but it won't change their index) you should be good to go.

 

If you have any questions for me about using the converter, please feel free to ask in the tool's thread.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use