Jump to content

Bug reports

Recommended Posts

Not sure where to post this, so I'll just start a thread for it.


The center sections of the front and back walls in the Lucid Dream cell are missing. It's not a big deal, I know, since that cell is only used once, but it's not hard to fix.


The following scripts have errors: GoFindVToyScript, SummonVToyScript, VToyDDong, VToyEggFortCutSceneScript, VToyJointClaudiaAugustaScript, VToyKissClaudiaAugustaScript, VToyKissLeftScript, VToyKissRightScript, VToyKissScript, VToyLidya6EggScript, VToyLidya7EggScript, VToyPileDriverBottomScript, VToyPileDriverScript, VToyPileDriverTopScript, VToyPilloryBottomScript, VToyPilloryMonsterScript, VToyPilloryScript, VToySarah3EggScript, VToyScript, VToySERVICE2worshipScript, VToySERVICEworshipScript, VToyShameScript, VToyStandingKissScript, VToyStoolScript, VToyTestersGiftScript, VToyTokenShameScript, VToyUPScript, VToyUseDualD1Script, VToyUseDualD2Script, VToyUseScript.


All of these scripts have invalid characters in their names: VToy_F_Clone, VToy_F_FindActors, VToy_F_PeaceCreatures, VToy_F_Rotate, VToy_F_RotatePS, VToy_F_SetLevel, VToy_F_SetMarker, VToy_F_SetMarker2, VToy_F_Squish, VToy_F_ToMarker, VToy_F_ToMarker2


VT9EggCredit crashes the CSE every time I try to compile it. The CSE log says something about "Syntax error: mismatched quotes".


GVTICTifaLisaScript calls a package named GVTSpectators, but there is no such package.

Link to comment

Hi Walker,

Thanks for the report.

I'll move your post in the Debug section as soon as you tell me you've seen this message :)


I need to know if you're using the last esp, check download section in the beta sub thread.


I'll review the scripts one by one.



Link to comment

Thanks, here's what I found:


R : Some variables were declared inside blocks, not an error per se but CSE doesn't like it. This is because those scripts were made with Vanilla CS, before the CSE existed (pure black and white editor, no help...)

U : This script is probably not used anymore but I won't delete it, just in case...

V : Some unused variable were declared.

F : This script is fixed now.



GoFindVToyScript -> Flagged as deleted R

SummonVToyScript -> R U F

VToyDDong -> R U F

VToyEggFortCutSceneScript -> No error for me, what did you get?

VToyJointClaudiaAugustaScript -> R F

VToyKissClaudiaAugustaScript -> R F

VToyKissLeftScript -> R F

VToyKissRightScript -> R F

VToyKissScript -> R V F

VToyLidya6EggScript -> V F

VToyLidya7EggScript -> V F

VToyPileDriverBottomScript -> R F U

VToyPileDriverScript -> R F V U

VToyPileDriverTopScript -> R F U

VToyPilloryBottomScript -> R F U

VToyPilloryMonsterScript -> R F U

VToyPilloryScript -> R V F U

VToySarah3EggScript ->Elseif error, that script needs to be rechecked in game ASAP!!!!!!!!!!!!!!!!!!!!!!!

VToyScript -> Probably the very first script of them all :) R F U

VToySERVICE2worshipScript -> R F

VToySERVICEworshipScript -> R F

VToyShameScript -> R F

VToyStandingKissScript -> R V F

VToyStoolScript -> R F U

VToyTestersGiftScript -> R F U

VToyTokenShameScript -> R F U

VToyUPScript -> R F U

VToyUseDualD1Script -> R F U

VToyUseDualD2Script -> R F U

VToyUseScript. -> R F U

I supposed we were talking about VT9CreditEggScript? -> U, no error for me.

GVTICLifaTisa -> Indeed, the package was mispelled. Question is, why did it worked then??? Probably a compilation thingie. Strange. F


So thank you, we need to retest Sarah's encounter with borund to see the effect of the change. We also need to pay attention to Tifa & Lisa routine in the TS Extension.




PS: The CS doesn't like _ in anything but ultimately I'm the boss :D

Link to comment





GoFindVToyScript,SummonVToyScript,VToyDDong,VToyPileDriverBottomScript,VToyPileDriverScript,VToyPileDriverTopScript,VToyPilloryBottomScript,VToyPilloryMonsterScripted,VToyPilloryScript,VToyScript,VToyStoolScript(S) all,VToyUPScript,VToyUseDualD1Script,VToyUseDualD2Script,VToyUseScript.






My only question then is about "VT9EggCredit"


Link to comment

I really need to pay attention. I'm not sure what's wrong with VT9EggCredit... if I hit compile, the CSE locks up and I have to close it via the task manager. And I just tried it again, to see if I could get the message - it worked fine. Go figure. :P


I was going to say I'm using 2.06 because 7-zip won't open the other stuff (mentioned this before), but I just the download section and got the latest updates. Woohoo.

Link to comment

I think I figured out the issue with VT9CreditEggScript... you've got %r in place of a semicolon, but it should be %a. I just happened to find this when I was skimming this article: http://cs.elderscrolls.com/index.php/Scripting_Tutorial:_My_Second_Script; I'm editing another mod as well.


I'm also trying to find out if there's a way to manually remove ITM records, so we can clean the mod without removing all the animations.

Link to comment


The link you gave leads to an empty page.


VT9CreditEggScript is not in use anymore so don't bother with it, I'm going to delete it.


Removing ghosts is easy with the CSE, there shouldn't be that many left now. On the other hand, don't go crazy with it, most of the time it totally doesn't worth the effort at all.



Link to comment

Here's the proper link: http://cs.elderscrolls.com/index.php/Scripting_Tutorial:_My_Second_Script


I figured out the issue with the animations being removed by TES4Edit. Well, ShadeMe figured it out: http://forums.bethsoft.com/topic/1425288-tes4edit-question/ Long story short, the parent references are listed out of order. All you have to do is rearrange them, and then you can clean the mod without screwing things up.

Link to comment

Thanks Bud. As we can flag ref in the CSE as unchanged, I'd prefer we do that instead of running the esp through tes4edit to clean ITM records.


We can use Tes4edit, but only after we want to release the mod as it'll need a complete retesting of the entire story/dialogues/animations with every option and that's a two weeks work...


Now, on the other hand, merging esp have create a missing "sexywalk" animation somewhere... I never used it so it can only come from a previous merge. I have no clue where this reference is and it's bugging me for months now :)


Can you also give me an example of ITM record so I can have a look at them?



Link to comment
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use