Jump to content

Sexlab Hotkeys not working--cannot adjust positions.


Recommended Posts

I recently had a problem pop up in my current load-out---with Sexlab (v1.59) the hotkeys for actor positioning stopped working entirely. They had worked just fine the night before.

 

Using Google to look for a solution, I came across a few threads that discussed this issue, even one with what turned out to be the solution, but not the cause of the problem. I wanted to know what caused it so I could avoid it in the future. Those threads are all archived, and thus I could not post on those threads. I thought I would post my findings since there are no more recent threads addressing the problem, a problem that others may still encounter.

 

In order to narrow down possible causes, one of the things I do is order my data folder based on "Date File Created". This will put the most recently changed files at the top of the list in Windows Explorer. When I did this, I realized quite quickly that Sexlab.ESM was at the top of the list for a reason--I had editted it to decrease the sound multiplier for the audio file playback (The voices were way too loud, and the voice slider wasn't working as expected).

 

I suspect that there is a date check built into the .esm in order to verify that the .esm has not been altered. It could also be that changing the sound multplier screwed things up, all by itself. Either way, changing the Sexlab.esm in any way results in the same thing--broken hotkeys.

 

I tested this by putting the original Sexlab files back in the data folder, verifying that the hotkeys worked again, then went and made a single change, saved it as a new .esm, then reverted the change and saving it again. In effect, the .esm was exactly the same in terms of data after doing so, but the hotkeys were still broken. The ONLY thing different is the "date created" for the .esm file itself.

 

TL,DR

If your hotkeys are broken, reinstall Sexlab, manually dropping the files in your data folder and allowing them to overwrite all the old files. Altering the .esm will bring the problem back.

 

Hope this saves some hair-pulling,

Bug

Link to comment
  • 11 months later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...