Jump to content

Naked NPCs And Constant CTD At Main Menu


Recommended Posts

Hey everyone, hope all is going well for you!

I'm having a bit of an issue right now where random NPCs don't actually wear what they should be wearing, with them ending up being naked instead. Also I'm constantly having a CTD issue whenever I get to the main menu, but before the options appear.
As an aside, in passing I learned about something called modwatch, so I'll provide a link to that, hopefully. If it doesn't work, just let me know!

If any other information is needed, also let me know!

PS: I haven't changed any mods during this (very short) playthrough, just updated the ASIS patch to rule that out as a possible problem. I also checked in TES5Edit to see if anything was funky there with an NPC that's naked, but it shows that he should have his armor. I'll keep poking at this to see what I can come up with, but outside thought is always welcome. =-)
 

Link to comment

First off it would be nice if we could see your loadorder. Do the NPC's have their clothing in their inventory and it is just not equipped? And if you have a previous save that was unaffected please try loading that to see if the problem is still there.

Link to comment

Hey Nick501, thanks for the response!

Mm, did my link not work? Unfortunately, from the very start this issue has been present.

In case my link indeed did not work, I'll attach the file Mod Organizer has made concerning the load order.
I'll check once I get back in-game and see if it's in his inventory. What I do know is after trying to use the resetinventory console command, only one piece of armor would actually show up, not the full set, and it would be random even. So you would get boots, then chestpiece, boots, then gloves, for instance.

 

plugins.txt

Link to comment

Hothtrooper44_Armor_Ecksstra.esp

Mods like these are changing armor. Uninstalling these could possibly provide a little help. If NPCs are trying to equip these items and there's something wrong they'll be nude. You have several mods that are affecting clothing so these are most likely the cause of your issue.

Clothing and Clutter fix could quite likely be causing the issue as it is changing how clothing appears on the NPCs and MIGHT be making it either not equip or simply making the textures invisible. 

 

So overall try deactivating any mods that are affecting clothing and see if that resolves the problem. If it does we'll look at which mod it is and from there can figure out how to fix it.

 

PS: If you didn't run LOOT you should do that.

Link to comment

Thanks for pointing those out to me. =-)

I first looked into IA, and remembered something I found earlier about disabling NPC distribution. I gave that a try, and after disabling and enabling my test dummy, he equipped all armor that he's supposed to have.
Looks like I might be pruning that one out of my list, which might be for the best as it's installed by default now, as opposed to what I actually want/need at this point, if that makes sense.

Anyways, thanks so much for the help with that!
Do you have any ideas why I keep crashing, though? I've tried narrowing it down, but I can't seem to get anywhere with it.

Link to comment

Mm, digging into my memory, that's quite possibly the issue. As far as FNIS is concerned, I typically run that last after the SkyProc patchers.
I think it's time I just prune my list in general, lol. I was able to play with a lot of stability not too long ago, so it only makes sense some recently installed mods messed it all up for me.

Well, I'll leave you alone now, looks like I have some work to do. =-)
Thanks for your help, it's much appreciated!

Link to comment

Hothtrooper44_Armor_Ecksstra.esp

Mods like these are changing armor. Uninstalling these could possibly provide a little help. If NPCs are trying to equip these items and there's something wrong they'll be nude. You have several mods that are affecting clothing so these are most likely the cause of your issue.

Clothing and Clutter fix could quite likely be causing the issue as it is changing how clothing appears on the NPCs and MIGHT be making it either not equip or simply making the textures invisible. 

 

So overall try deactivating any mods that are affecting clothing and see if that resolves the problem. If it does we'll look at which mod it is and from there can figure out how to fix it.

 

PS: If you didn't run LOOT you should do that.

Mark this post as the solution so people popping in here will first see the solution if they have the same issue as you.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...