Jump to content

Need help with Daedric armor conversion- BSEffectShaderProperty


Lady Horus

Recommended Posts

Hello all! Been a while since I last posted here, been busy with many things.

 

Currently one of my projects has been to convert the vanilla armor/clothes to DreamGirl by hand in 3DSMax. I've run into a bit of a problem that I need help sorting out though.

 

I've never tried dealing with glowing elements on character models, at least not like the one the Daedric set uses. I converted this armor the same way I do everything else, and as far as I can tell only altered the shape and skin weights of the glow mesh... I didn't alter the UV mapping or anything of that sort. However when opened in Nifscope it looks completely different compared to the vanilla mesh. I copied over the BSEffectShaderProperty from the original "DaedricCuirassFemaleGlow" NiTriShape on the vanilla model to my new one like in my screenshot.

 

su1Rt2c.jpg?1

 

I thought at the very least it wouldn't look right in-game, but I can't even load the armor in-game without crashing. So, I'm at a loss. I tried looking up tutorials on the web and on the Nifscope website but came up with nothing. Was getting errors on the Nifscope site, not sure what's up there.

 

I hope someone here would be willing to give me a hand? I've attached my meshes here for download if anyone wants to take a look:

 

DreamGirl daedric test.zip

 

I was thinking maybe I imported/exported wrong in 3DS Max, but I didn't see any options on the importer/exporter that looked like something I should have used.... I'm really stumped.

 

Any help would be very appreciated! Thanks.

 

- Horus

Link to comment
  • 3 months later...

The only thing I see wrong is the vertex colors/vertex alpha values didn't make it out of 3DS alive, so even though the NiTriShapeData on the daedric glow branch says yes, it's basically blank. You'll have to manually edit each vertex color value by hand, to the values of the vanilla armor.

 

I'm not sure if this is the cause of the crashes or not (didn't test), but it's a good chance. Plus it'll look much better with the alpha.

Link to comment

Thanks for the reply, par. :)

 

I have tried editing the glow mesh entirely by changing the UV mapping and using a BSShader property with glow mapping instead- still no changes. Game still crashes.

 

So I thought maybe I could use it without the glow layer entirely so I deleted that mesh from the nif and tried it without, and there's still CTD. I'm not sure but I think Daedric must use some hardcoded properties? I even tried editing it to use a different mesh with creation kit and kept crashing there too regardless what mesh I told it to point to.

 

I'm thinking I'll probably just leave it unaltered at this point since it's become too much of a headache to deal with now.

 

I appreciate your input though. I would have thought that'd be it if I hadn't already tried what I mentioned here.

Link to comment

Alright, I took a closer look, and notice the armor has an extra skin partition, 4 instead of 3. One of the partitions is the entire armor and is completely useless. This is not something you can fix in Nifskope either.

 

I tested by importing the mesh into Blender, re-partitioned it for the 3 proper partitions, re-rigged it (using the vanilla daedric armor skeleton - this is important because of the pauldron bones), and can now get it to show up in the CK.

 

So it's either the extra partition (can't have overlapping faces in partitions) or the skeleton rig you used, but a little clean up will fix it. :)

Link to comment

Alright, I took a closer look, and notice the armor has an extra skin partition, 4 instead of 3. One of the partitions is the entire armor and is completely useless. This is not something you can fix in Nifskope either.

 

I tested by importing the mesh into Blender, re-partitioned it for the 3 proper partitions, re-rigged it (using the vanilla daedric armor skeleton - this is important because of the pauldron bones), and can now get it to show up in the CK.

 

So it's either the extra partition (can't have overlapping faces in partitions) or the skeleton rig you used, but a little clean up will fix it. :)

 

Ah thank you. I hadn't realized that! I was at a complete loss. I will try that and see what happens. :)

 

Edit:

 

Worked! Well I feel really silly for not seeing that myself, as I'm usually good about catching that sort of stuff! Thanks for being another set of eyes for me par, I really appreciate the help. :)

 

Daedric_zpsiz67igcj.jpg

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...