Jump to content

Script properties vanished


Recommended Posts

Hey, hope someone can help out


I'm working on adding some perks to a mod. I added one, yesterday, as a proof of concept, and everything worked fine. Longest the CK has ever gone without crashing in fact!


Then, after playtesting what I'd made, I went back, and started adding more, the fans of this mod have given me a suggestions list as long as your arm, however, after adding ONE lousy line to a script that previously worked A-OK, I lose the ability to edit it's properties in the creation kit.


The script compiles in Notepad++ fine, no errors or warnings, but the CK refuses to look at it, just gives an error "errors encountered while trying to reload the script". Interestingly, I can click 'Add property' and add something in - whereupon the CK gives the same "errors encountered" error.


Yet, lo, upon looking back in notepad++, the property HAS been added.


It's frustrating the hell out of me, because I finally cracked the key to adding a lot of new stuff to a defunct mod, but the CK is not for co-operating with me.


Has anyone any advice on resolving this?






Edit: It's spreading to other scripts now. Everything compiles fine, if i restore a backup of the COMPILED scripts, everything is fine... Quite confused now.


Edit the second. Fixed it, I think.

Turns out I needed to have the SkyUI SDK installed. Why this only started causing problems after a certain number of edits, I don't know, but the problems seems to be resolved.


Mods feel free to lock or delete this please.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...