Jump to content

Animations stopped working after reinstall - NO FNIS problem

Recommended Posts

Hi folks,


normally I try to resolve all my gaming issues by myself, so I am - and hopefully always will be - a rare guest in the support section. My PC had a hard disk crash and I had to reinstall everything, unfortunately Wrye Bash recovered badly and I started to use savegames to have a clue on what to reinstall, downloaded several files here too that were updated since.


So I started with the framework, than some Sexlab stuff, than DD stuff.


In Tes5edit everything looks fine, in MCM too. BUT: Sexlab itself doesn't save the time settings - they aren't in the export file, either. Means: every animation has a playtime of 0 seconds and none of the mods work that needs those time settings. 


I tried new installs, way old mods like Animated Prostitution and Sex Addicts work without any issues.


Than I tried a new install again (thanks to VMWare... I have a clean Skyrim system saved only with the official DLCs as I am a "hardcore" mod tester) and installed nothing else than the framework. And there, too, Sexlab didn't save any time settings in MCM.


What causes this? I am pretty sure it is the same version of the framework I used on my working system. Any clue? I'm seriously running out of ideas.

Link to comment
  • 2 weeks later...

Thanks for the answers...


What I did by now:

Reinstalled Skyrim from scratch (no Steam reinstall, really deleted the whole thing and got rid of the registry keys). My chars were running over 7000 scripts causing Papyrus to stall every now and then, so I had to dig further (and reduced the scripts to something around 6200). Maybe my VM save of the game wasn't that good after all, so I saved one with the DLCs only (with something more than 100 scripts running, can you believe that? :D .

Installed SexLab Framework only - latest version - and got the same problem. Time settings in MCM are not saved, everything is put to 0 seconds and changes back to 0 after checking back. Which causes dialogues to start and the char going on after a light hickup without any animation used.


I'll try on my backup pc, buuut: I installed SkyUI from Steam on this pc - which obviously has some problems - and the backup has a downloaded version of SkyUI - way older, but working perfect (no Steam install). If it works on that old thing, I'll kill the guys of SkyUI ;)


After all, the only issue I found were the settings not being saved, which never happened before. The old rule "Never change a running system" comes to mind... Everything worked fine before I had the idea of updating every Loverslab and SkyUI files.

Link to comment

Could it be possible that you were using a previous version of Sexlab in your old saves?


You can also use PDTWrapper to try solving script issues.

Tried new games, same result. And yes, I used some tools - forgot the names by now. Old saves are completely unplayable, new games get unplayable or simply don't save the timers. Edited savegames which made them startable - with no timers saved either.

If youre loading a previous save with an old version or sexlab, youll certainly have to go into the utility(?) panel and at the least, reset animation regristry, or at the most completely rebuild sexlab.

I am not using previous saves and have no old version of sexlab. And as I already wrote I completely reinstalled Sexlab.

Link to comment
  • 4 weeks later...

Found the issue finally: Double install of SkyUI, once from Nexus, once from Steam Workshop. Seems the new version from Steam didn't update all the files, so some incompatible files were left and caused trouble. Killed the one from Nexus, Steam reinstalled SkyUI correctly -> everything works. 


Wasn't easy to find out as SexLab was the only mod that seemed to work weird in MCM.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...