Jump to content

More Nasty Critters - Creatures don't have schlongs


Recommended Posts

I have recently installed More Nasty Critters to test it out, but problem is, whenever i try to have sex with a creature, it doesn't get erect, like it has it schlongs but it won't come out, and that goes for every creature, except Seeker but i guess its because its tentacles ... I have Creature Framework, SexLab, MNC, Dawnguard, Dragonborn, Hearthfire, hentai creatures, SOS, and some other things, but In the MCM menu for Creature Framework I only have one menu (Creature 1) saying : No mods have registered any creatures, So i go into SL menu and do the reg thingy, and still nothing. Also in SexLab Nude creatures MCM menu i have another Creature with the Husky, Dog and Death Hound Option. Also i have Hentai Creatures on but i don't seem to be getting any menu for it at all

So if anyone knows how to fix this, thanks for the help.
 

EDIT: Sorry if this was already discused somewhere, but i couldn't seem to find a fix for it.

Edited by Brandon87500
Link to comment

I have recently installed More Nasty Critters to test it out, but problem is, whenever i try to have sex with a creature, it doesn't get erect, like it has it schlongs but it won't come out, and that goes for every creature, except Seeker but i guess its because its tentacles ... I have Creature Framework, SexLab, MNC, Dawnguard, Dragonborn, Hearthfire, hentai creatures, SOS, and some other things, but In the MCM menu for Creature Framework I only have one menu (Creature 1) saying : No mods have registered any creatures, So i go into SL menu and do the reg thingy, and still nothing. Also in SexLab Nude creatures MCM menu i have another Creature with the Husky, Dog and Death Hound Option. Also i have Hentai Creatures on but i don't seem to be getting any menu for it at all

 

So if anyone knows how to fix this, thanks for the help.

 

EDIT: Sorry if this was already discused somewhere, but i couldn't seem to find a fix for it.

 

It would be really helpful, if you could post your logs.

 

Link to comment

Well, i'll see after im done reinstalling the game, im doing a complete reinstall to see if i still have the problem.
 

EDIT: So like im reinstalling it, if i want to have only MNC, here are the mods im going to install:

UNP Blessed Bodies

SexLabFramework
SexLabMatchmaker

Schlongs of Skyrim
Creature Framework
Defeat
MNC
SexLab NudeCreatures (Do i need this one or i use the one included in MNC ?)
 

Link to comment
  • 8 months later...

Another fix for people not being able to get Creature Framework to show up in MCM

 

1: Save in a small cell with few to no NPC's (Breezehome) and exit the game

 

2: Uninstall MNC and then run FNIS (If you have Creature Framework, uninstall that too since it's already incorporated into MNC)

 

3: Start up Skyrim and load your savegame, once loaded up immediately save and then exit the game

 

4: Install MNC and then run FNIS again and you should be done, start up Skyrim and load your save, after 15-60 seconds you should notice everything registering

Link to comment
  • 2 months later...

Another fix for people not being able to get Creature Framework to show up in MCM

 

1: Save in a small cell with few to no NPC's (Breezehome) and exit the game

 

2: Uninstall MNC and then run FNIS (If you have Creature Framework, uninstall that too since it's already incorporated into MNC)

 

3: Start up Skyrim and load your savegame, once loaded up immediately save and then exit the game

 

4: Install MNC and then run FNIS again and you should be done, start up Skyrim and load your save, after 15-60 seconds you should notice everything registering

 

THANK YOU!

Link to comment
  • 5 weeks later...

Another fix for people not being able to get Creature Framework to show up in MCM

 

1: Save in a small cell with few to no NPC's (Breezehome) and exit the game

 

2: Uninstall MNC and then run FNIS (If you have Creature Framework, uninstall that too since it's already incorporated into MNC)

 

3: Start up Skyrim and load your savegame, once loaded up immediately save and then exit the game

 

4: Install MNC and then run FNIS again and you should be done, start up Skyrim and load your save, after 15-60 seconds you should notice everything registering

 

When I load back into the game after re-installing MNC... I see "Creature Framework successfully installed"... then my game fades to black and goes back to the main menu... Does this everytime i load that save... I can load a prior save fine. but the Creature Framework doesnt show in the MCM menu.

Link to comment

Well, just a little tip from my experience for almost a year using MNC (for rookie guide, since I'm a rookie up until now lol)

 

1. If you install a creature replacer for example Skyrim Monster mod and now all creature schlong won't show up (dog bang your pc with invisible stick or troll rape your pc with it's flaccid dick)

--try to re-register all mods in creature framework general and go to another cell

 

2. if you have too much sex (in my case too much Defeat player as victim) until the creature aggressor stop detecting you as enemies not just for example a wolf, but every time you spawn a wolf and wolf everywhere won't detect you as enemy even you hit them right in the face (and butt).

--try to uninstall MNC and a mod you use to trigger sexlab animations, save then install them again.

 

3. Your PC and npc doing T-pose* while sexlab animation occurring or even when you load a save (followed with CTD in my case)

--Run Generate FNIS for user, click update FNIS Behaviour.

 

4. You can't change view (scroll up or down with mouse with no effect)

--Assuming you use TFC or free camera--- Turn Auto Free camera feature OFF in sexlab or any other mod (like estrus), or at least stop tfc when the animation is about to end 

 

For Reminder, everytime you install or uninstall mod that adds animations or doing something with animations it would be safer to always update FNIS Behaviour to see if there's any problem,

 
Re-installing almost always solve and fix some mods errors and issues, might worth trying  
 

*T-Pose=no walking, running, equipping, sheathing, etc animations were done, just doing the same pose whatever the circumstances

 

Sorry for bad Grammar and for posting here, afraid that in the future someone will have issues like these

Link to comment
  • 1 month later...

Another fix for people not being able to get Creature Framework to show up in MCM

 

1: Save in a small cell with few to no NPC's (Breezehome) and exit the game

 

2: Uninstall MNC and then run FNIS (If you have Creature Framework, uninstall that too since it's already incorporated into MNC)

 

3: Start up Skyrim and load your savegame, once loaded up immediately save and then exit the game

 

4: Install MNC and then run FNIS again and you should be done, start up Skyrim and load your save, after 15-60 seconds you should notice everything registering

OMG...  I didn't realize MNC included J containers....  I've had two versions of it this whole time, lmao.  And two versions of creature framework for a while too.   Upon reinstall of MNC I noticed that these were included in MNC so I unticked them in the install (already have the newest versions of both) and now everything runs smoothly!   I can't help but wonder if that's actually the secret to this little trick here.  XD    To make me realize I was being stupid and it was my fault all along.   Either way, thank you very much.  :3

Link to comment
  • 7 months later...

Same issue. Creatures are dickless. I tried everything suggested in this thread, to no avail. Using mod organizer, have MNC and FNIS(with all its created animations attached to it) as the last two in my mod organizer order, and esm/esp in Loot suggested order. No schlong meshes.  Animations work fine, but my creatures are censored no matter what I do.

 

Nifskope loads what looks like the right meshes when invoked from MO.  Example, I load meshes\characters\..\bear_hard.nif or bear_flaccid.nif, and the junk is there, but it doesn't appear in-game.

 

In MCM, most of my creatures show up as "Disabled" with no changeable options for them.  Even the basic ones that have options, such as "Default", "Crude vein", whatever, don't show with their junk in game.

Link to comment
  • 2 weeks later...

I have a problem , not all creatures have their schlong : Deer and Elk have not, wolves, dogs, horses and others have them.

Do i need to deinstall creature framework for FNIS  or what ?

I just got done fixing the exact same issue.

 

In the MCM Menu for Sexlab Aroused, I enabled the option for SOS and now it works.

Link to comment
  • 1 month later...

 

I have a problem , not all creatures have their schlong : Deer and Elk have not, wolves, dogs, horses and others have them.

Do i need to deinstall creature framework for FNIS  or what ?

I just got done fixing the exact same issue.

 

In the MCM Menu for Sexlab Aroused, I enabled the option for SOS and now it works.

 

Thx works for me ;)

Link to comment
  • 4 weeks later...

Same issue. Creatures are dickless. I tried everything suggested in this thread, to no avail. Using mod organizer, have MNC and FNIS(with all its created animations attached to it) as the last two in my mod organizer order, and esm/esp in Loot suggested order. No schlong meshes.  Animations work fine, but my creatures are censored no matter what I do.

 

Nifskope loads what looks like the right meshes when invoked from MO.  Example, I load meshes\characters\..\bear_hard.nif or bear_flaccid.nif, and the junk is there, but it doesn't appear in-game.

 

In MCM, most of my creatures show up as "Disabled" with no changeable options for them.  Even the basic ones that have options, such as "Default", "Crude vein", whatever, don't show with their junk in game.

 

I think I may be having the same issue as lordcayleth. 

 

Going to try some things in game but wondering if there has been a solution to this issue already. 

 

I will I have MNC AND SL Nude Creatures.  Saw the OP had those as well and not sure if it was ever answered whether both is needed or if it matters. 

 

Thanks in advance 

Link to comment

 

Same issue. Creatures are dickless. I tried everything suggested in this thread, to no avail. Using mod organizer, have MNC and FNIS(with all its created animations attached to it) as the last two in my mod organizer order, and esm/esp in Loot suggested order. No schlong meshes.  Animations work fine, but my creatures are censored no matter what I do.

 

Nifskope loads what looks like the right meshes when invoked from MO.  Example, I load meshes\characters\..\bear_hard.nif or bear_flaccid.nif, and the junk is there, but it doesn't appear in-game.

 

In MCM, most of my creatures show up as "Disabled" with no changeable options for them.  Even the basic ones that have options, such as "Default", "Crude vein", whatever, don't show with their junk in game.

 

I think I may be having the same issue as lordcayleth. 

 

Going to try some things in game but wondering if there has been a solution to this issue already. 

 

I will I have MNC AND SL Nude Creatures.  Saw the OP had those as well and not sure if it was ever answered whether both is needed or if it matters. 

 

Thanks in advance 

 

 

Same problem here. I'm not sure why the creatures are junkless. I'm assuming there is somethiing conflvting with the creature framework mesh swap. but I don't know what it could be.

Link to comment

 

 

Same issue. Creatures are dickless. I tried everything suggested in this thread, to no avail. Using mod organizer, have MNC and FNIS(with all its created animations attached to it) as the last two in my mod organizer order, and esm/esp in Loot suggested order. No schlong meshes.  Animations work fine, but my creatures are censored no matter what I do.

 

Nifskope loads what looks like the right meshes when invoked from MO.  Example, I load meshes\characters\..\bear_hard.nif or bear_flaccid.nif, and the junk is there, but it doesn't appear in-game.

 

In MCM, most of my creatures show up as "Disabled" with no changeable options for them.  Even the basic ones that have options, such as "Default", "Crude vein", whatever, don't show with their junk in game.

 

I think I may be having the same issue as lordcayleth. 

 

Going to try some things in game but wondering if there has been a solution to this issue already. 

 

I will I have MNC AND SL Nude Creatures.  Saw the OP had those as well and not sure if it was ever answered whether both is needed or if it matters. 

 

Thanks in advance 

 

 

Same problem here. I'm not sure why the creatures are junkless. I'm assuming there is somethiing conflvting with the creature framework mesh swap. but I don't know what it could be.

 

 

now its work for me i have reinstall jcontainer

Link to comment
  • 3 weeks later...

 

 

I have a problem , not all creatures have their schlong : Deer and Elk have not, wolves, dogs, horses and others have them.

Do i need to deinstall creature framework for FNIS  or what ?

I just got done fixing the exact same issue.

In the MCM Menu for Sexlab Aroused, I enabled the option for SOS and now it works.

 

Thx works for me ;)

 

I have the exact same problem but doing the SoS thing did not work. Did you guys do anything else?

Link to comment
  • 3 months later...

I have a problem , not all creatures have their schlong : Deer and Elk have not, wolves, dogs, horses and others have them.

Do i need to deinstall creature framework for FNIS  or what ?

In MNCv10 at least, the Elk and Reindeer have the wrong mesh defined in the ArmorAddon - a quick fix with Tes5Edit to the Hard versions.
Link to comment
  • 3 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...