Jump to content

JFF creating corrupt XML's


hypno88

Recommended Posts

It's the first time I'm using JFF. I'm having a problem where the XML's it is saving aren't right and result in the game crashing to desktop.

 

They are very small in file size compared to the original XML I loaded in. When I open it up in Sublime instead of the normal code it's just one huge column of numbers.

 

I have downloaded the program from both the nexus and here and even tried not upgrading and using v3, but all do the same.

 

I'm not sure what I'm doing wrong?

 

EDIT: By the way, this is what I'm working on:

Horse Cloak

 

- Hypno

Link to comment

Yep. Initially I was having the "missing dll" message, which was fixed eventually by downloading the x64 version of Visual C++ 2012. Throughout I was running as administrator just in case.

 

The rest of the program works as advertised; it loads the XML fine, I see my new rigidbodies and constraints, can edit everything. It's just when I click "save as" the new XML is only 32mb and consists of just a huge column of number pairs (hex?), even if I don't make any edits and just save right after loading.

 

Im not sure what to do next to get JFF working?

 

All I want to do is tweak my XML a little bit. Currently the horse cloak is flailing about out of control with no sign of calming down. So I want to just up the Mass and add some Dampening so that it quickly comes to rest once the horse in stationary.

 

This was supposed to be the "quick, last step in the process"...bloody Sod's Law! (Murphy's Law for you guys across the pond)

 

- Hypno

Link to comment

Right...Just got home.

 

Investigated further and it's not JFF, it's the XML i made in 3DS Max/Havok Content Tools. I decided to load up and immediately save the XML file that comes with the HDT plug-in and it worked fine. I dont know what's wrong. I followed Canderes tutorial for exporting the XML and it seems to work alright in-game, just not when i re-save in JFF. It must be the way i set up the export in Havok Content Tools, but to be honest i just blindly followed not really understanding what i was doing. I'm going to go back into 3DS Max now and try exporting again.

 

Fingers crossed!

 

EDIT: Nevermind. Instead of using JFF to quickly adjust my values, I just bit the bullet and used 3DS Max to keep exporting new XML files. Slightly longer workflow between adjustment and testing, but ah well it worked

 

- Hypno

Link to comment

Thank you for the advice and trying to help me with this issue. I gave up on using JFF in the end and just did the adjustments inside 3DS Max and regerating an XML every time with Havok Content Tools.

 

For some reason the XML's I generate aren't cooperating with JFF. They work perfectly in game and even JFF loads them without troubles. But it's just when I then go to save is when JFF chokes. Perhaps I'm using a newer version of Havok Content Tools then JFF is used to? Maybe this newer version is adding stuff to the XML's that JFF doesn't know what to do with? No idea, and can't check at the moment as I'm at work currently.

 

Ah well, things worked out in the end. Here's a short demo video of my horse cloak in action:

 

- Hypno

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...