Jump to content

CTD just before Sex starts (only sometimes)


Recommended Posts

Just a minor thing I thought I'd mention.

 

 

For some reason, sometimes when I go to have sex, I crash just before it starts. But when I reload my game, it works fine after that. Like I said, it is only sometimes that this happens, so not sure what could possibly be causing it.

 

I checked my papyrus log, and no luck there. The same thing happens if I crash, and if I don't crash. There is no indication of what is causing it to crash. It is just random.

 

So I started thinking of the mods I have installed for SexLab. I have Aroused, Lovers Comfort, Matchmaker, Defeat, and Romance. Figured maybe one of them might be causing the issue here. So I tried initiating sex via Romance. Still CTD. Tried Defeat, still CTD. Tried Matchmaker, still CTD. Even Lovers Comfort caused me to crash if I rested and my arousal was high enough to masturbate when I woke up.

 

But then other times, it worked just fine. It feels like if I go too long without having sex, I crash when I try to have sex. But if I have sex constantly, I don't crash. So I thought it might be Arousal causing the issues. Though I have no way to test if it is or not, besides removing it and trying again. But there is no guarantee that will do anything, as I said, the crash I get is random. Sometimes it happens, other times it doesn't.

 

As well, if I haven't played Skyrim for awhile, and then start it up and try to have sex, it crashes. Yet once I log back into the game again, it seems to work. Though I have had it crash like twice or three times in a row before it started working again.

 

 

 

All in all, it is an odd bug/glitch. Sometimes I crash, sometimes I don't. It is just random. Crash just before having sex, yet other times, it works just fine. Papyrus loads the same thing regardless of if I crash or not, so no help there. I am seriously thinking it might be Aroused that is causing it, but I have no way of checking unless I just completely remove it (which in turn means removing Lovers Comfort as well). My load order is fine, no issues there. No major script mods or anything, except for SexLab only.

 

It's just weird is all. It's not a big deal, as I can fix it easily by just logging back in and trying again, but it is still kind of annoying not knowing what is causing it. Was just hoping someone might have an idea of what might be going on or experienced the same exact thing. Any ways, thanks again for any insight you guys can provide.

Link to comment

Same thing here. I guess it's Microsofts Virtual Machine that sometimes freezes or crashes.

 

SexLab also is a script monster (it must be, because the functions are not expendable and therefore cannot be reduced, and it I'm still surprised that it works at all - thanks Ashal by the way, you're doing a great job).

 

On medium range PCs it can make the script engine of the game struggle when other script heavy mods are running such as SkyRe or the like.

 

SexLab for me works best if I use it on a script-light install.

 

Also, when I load a save I mustn't do so immediately after I the game lets me click the save in the main menu, it's best for me to wait a few seconds. Otherwise the game may ctd due to the papyrus engine not having enough time to load all the scripts before the game is loaded. I don't have missing master problems or dirty edits, load order problems or anything like that. It's just the sheer script load that I have on one of my Skyrim profiles.

 

I'm running Skyrim on a six core with 8 GB RAM, so it's a medium machine and should be able to handle such an install, but the Skyrim Papyrus crap just isn't designed to handle heavily scripted game configs. But the dirty (N)PC interaction is worth it...    :D

Link to comment

Check Your MCM settings for all of Your Sexlab dependent Mods.

I had to reset many MCM options when I upgraded from 1.59 to 1.59b, but if I load a character that I have not taken the time to reset the MCM settings on, I will get consistent CTD's on Sex.

Having Race/Gender specific Animations or restricting aggressive Animations in the Sexlab MCM wil make some Mods fail to start, or restrict the available Animations for a scene.

 

Link to comment
  • 2 weeks later...

You might want try to change some papyrus script settings. http://forums.nexusmods.com/index.php?/topic/633229-less-ctds-maybe-none/

 

fUpdateBudgetMS is probably the most important one, but if you raise it too much you'll also get FPS hit. Try 1.6 first and then 2.0 at maximum.

 

Other settings can remedy the issue when you try to load a save immediately after game has started. At worst, I've had to start a new game before I could load any saves at all (or just the indoor auto-saves).

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...