Jump to content

Need some help with FNIS and then getting it to work correctly with MO


Recommended Posts



As of right now, everything seems to be working fine, EXCEPT for the following error-


No matter what I do, when I run FNIS, it runs fine, but when I hit exit, I get the following error-


D:\Games\Mod Organizer\mods\FNIS Behavior V 5 1 1 -- ALWAY nescessary\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe failed to run


and MO then  acts like it hasn't run.


See post #4 for latest and exact details.




EDIT #2:   Working now, see post #12 if looking for details



Now that I have hit the ending of FONV and have played through vanilla Skyrim, I decided it was time to delve into a modded playthrough of Skyrim.


I am using Mod Organizer.  I attempted to do this a while back, (and had a few  things, including a body and FNIS, working), but during upgrading my computer, I formatted, so I'm now using a brand new version of Skyrim, and reinstalling mods.


Before I go any further, question number one-  How do I get the list of mods that I am running in a format that I can copy and paste it here?   I've done this for FONV when asking questions, but I used FOMM there, and as I decided to post here, I looked and looked, and searched, and I can't seem to figure this out.  I can only find how to export it to a csv format, but that looks like it is for a spreadsheet.


If I can figure that out, I'll be glad to post my load order.



Anyway, here is where I am at-   I installed several basic mods I wanted, nothing much, stuff like SkyUi, some weather, lighting and sound stuff, all the DLC and patches, and everything worked fine.



Next up was a body and FNIS.


I installed the realistic ragdoll and force thing, then I installed Groovtama's XP32 Max Skeleton from here, then I installed CBBE body type.


Then I think is where my mistake came.  I installed FNIS, but I put it in the REAL Skyrim directory, instead of installing it with Mod Organizer, I'm not sure what I was thinking.    It showed up in Mod Organizer, like the other stuff that is already there does, the DLC stuff, so I just made an executable for the generate for user thing from MO, and ran it.     Seemed to run fine.    (the only warning I got was that it was in an illegal directory, but I ASSURE you, I have a legal copy, I just put the whole Steam directory somewhere other than Program directory, and I think thats why I get this warning)


But when I went into Skyrim to test, my character would not move at all when in 3rd person or with no clothes on.   If I put the guild armor on, then she moves, but she just glides along, with her arms out.


I thought, well maybe I was supposed to install it via MO since I am running it through there.     I tried that, and got the same result.   


I have also tried running the skeleton arm fix, I've tried running the generate program from the real Skyrim directory, without running MO, and always have the same result.  also tried reinstalling the skeleton, and CBBE.  


So then I decided, well, lets uninstall it.    According to the instructions, you run the generate program, and pick the option to de-install the creature pack.  Here is where I am stuck.  That is greyed out for me.   It doesn't give me that option.      If I go into my Skyrim directory, I can see all the creature files from the archive are there....  but there are so many, I'm not sure which ones to remove safely.   


So can anyone help, or give pointers?     since I've installed hardly anything else, is there anything that Should be in that mesh file?  or can I just delete the whole thing?    At this point is there any way I can fix this, other than just reinstalling from scratch?    In looking at what I've posted, and the order, can anyone spot anything I did wrong?


Any help would be appreciated, and I'll gladly answer any questions that I haven't covered.



Link to comment

Well, I finally got it uninstalled, manually, by comparing what was in the archives, and what was in my actual Skyrim directory, and taking each file out one by one.


I then reinstalled everything through Mod Organizer.   in reading the FNIS + MO thread, I realized that I could set the FNIS checker in MO to true.   It now asks me to run the generator program when I try to run Skyrim, via SKSE, through MO.   (like I normally do)

It says this-

ERROR(53): Could not find file 'D:\Games\Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users\FNISmodList.txt'.

-and then fails to run.


  I'm really at my wits end, been working on this all evening.    Every time I try to google or research, I find something different, so know I don't know what is the correct way to do this.



Link to comment

I  changed the plugin sensitive setting to true, and now it seems to run ok when I click "yes" when it asks to run.  It updates behavior like it is supposed to,  and gives me the report that looks ok.   but when I click exit, to go back to MO and let Skyrim start, it gives me an error that says it failed to run.

Link to comment

Thank you!!    Just that much helped me immensely.   I was so tired last night, I couldn't find that info on my own.


Ok, so I'm still having a problem.    I uninstalled everything, and then let Steam verify the integrity of the cache, recleaned my masters (thats the only ones Steam found and overwrote), and started putting things back one by one.    Right now, my character can now walk ok.


I put FNIS in, exactly as the link above said too. 


But no matter what I do, when I run it, it runs fine, but when I hit exit, I get the following error-


D:\Games\Mod Organizer\mods\FNIS Behavior V 5 1 1 -- ALWAY nescessary\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe failed to run


and MO then  acts like it hasn't run.


Here is my FNIS log



>>Warning: Generator not run from a legal (Steam) Skyrim installation directory.<<
FNIS Behavior V5.1.1 8/3/2014 4:57:08 PM
Skyrim: -
Generator: D:\Games\Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

Skeleton female: Unknown (123 bones) male: Unknown (123 bones)
Patch: "SKELETON Arm Fix"

Reading FNIS V5.1.1 ...
Reading FNISBase V5.1.1 ...

All Anim Lists scanned. Generating Behavior Files....

Creature Pack not installed

129 animations for 2 mods successfully included (character)
1 Warning(s).



and here is my load order




Unofficial Skyrim Patch.esp
Unofficial Dawnguard Patch.esp
Unofficial Hearthfire Patch.esp
Unofficial Dragonborn Patch.esp
ELFX - Dragonborn.esp
ELFX - Dawnguard.esp
SoS - The Wilds.esp
SoS - Civilization.esp
SoS - The Dungeons.esp
SoS - The Wilds-PatchCoT.esp
Bashed Patch, 0.esp

the only other things installed, not showing there, is CBBE body, and the Groovatron, or however you spell it, skeleton from here.






So any suggestions on what to do from here?     I'm afraid if I just install FNIS into the real Skyrim directory, it won't be able to recognize the mods installed with MO.


thanks for any help!

Link to comment

You installed FNIS as instructed on that link, and run it from under MO?


It's Groovtama, and that skeleton has more than 123 bones, s to me it looks like your just running GenerateFNISforUsers without starting it from MO.


Probably a good idea to download and install the creature pack from the same place you got FNIS & FNIS Spells.


All three should be placed into Mod Organizer\downloads folder and installed as mods, then enabled.

Then use Sort button, Then make Bashed Patch.


Read the information on the first link I gave you, it tells exactly how to setup FNIS to run from underneath Mod Organizer.


Once that is done, it will be available in the drop-down list in the upper right of MO window.select it there, then click "Run"


After it is done, it will leave files in the overwrite folder, needs to be moved to the FNIS folder OR right-click the Overwrite entry in the left-hand panel and choose make mod option (call it something that makes sense to you, like "FNIS OverWrite"

That will need to be enabled as well.

Link to comment

My apologies to Groovtama on the horrid misspelling of the name.


But yup, I followed that link and did it like it said, and did everything like you just said to do it.   


The only thing I notice different is in the link it says to put this in the binary field-

ModOrganizer>/mods/Fores New Idles in Skyrim - FNIS/tools/GenerateFNIS_for_Users


I can't do that, because there is no directory called Fores New Idles in Skyrim - FNIS.   Mine is called-


D:\Games\ModOrganizer\mods\FNIS Behavior V5 1 1 -- ALWAYS necessary\tools\GenerateFNIS_for_Users


I'm assuming that FNIS had changed or updated since that Step Project was written?   If not, then I don't know where to find that Fores New Idles in Skyrim - FNIS directory.


Another thing I am wondering, should there be anything the "start in" field?  would that cause the problem?


I'm running FNIS from MO like you said, and basically did everything (except the creature pack and spells) just like you said.   It seems like it runs fine, but when I exit, it gives me that error, and then MO acts like it has not been run.


Basically, on the creature pack and spells, I didn't see a reason to install them yet, until I could get the main generator program to run properly.

Link to comment

Ok, I just noticed something else weird.   


( I installed the older FNIS version V5 02, just to see if that solved the problem.    In the window at the bottom of Mod Organizer, it always says this, when I get that error, that says it failed to run.


23:56:13 [D] start of "D:/Games/ModOrganizer/mods/FNIS Behavior V5 0 2 -- ALWAYS necessary/tools/GenerateFNIS_for_Users/GenerateFNISforUsers.exe" canceled by plugin



Shouldn't those forward slashes be backslashes?  It is doing that whether I run V 5 02 or 5 11.


If thats the problem, I have no idea how to fix that.   

Link to comment

Try this instead:

click on Data tab of right-hand panel

scroll to the bottom

til you see "tools"

click it's arrow, it'll open up

Then click the arrow beside "GenerateFNISforUsers" to open it up

then right-click "GenerateFNISforUsers.exe" and click on "Add as Executable"

Change the name so 511 is added to the end of it

Click OK

then select the dropdown list for that entry and try running it that way (all those details will be added for you)

Link to comment

Ok, it is getting weirder!   get this-


I tried what you said to do.    I tried running it.   I had forgot to have steam running  in the background, the program told me.  So I tried x 'ing out of everything and hitting no, to go run Steam first.    The FNIS generator program ran anyway, and seemed to run fine.


Thinking it was working now, I ran Steam and tried it.    It didn't work, got the same error about it failing to run, on exit.


So I started testing.


If I run the program, the way you showed me above, and do it the right way, I get the same error.   But if I pick "no" when it tells me the source data has changed, and asks me if I want to run GenerateFNIS now, it runs anyway, and seems to run fine, no errors....


Edit:  It actually does this on the old way too.      But it doesn't know that it has run, and it keeps asking me to run it, every time I run SKSE.

Link to comment

Looks like a wrong setup. Did you set it to FNIS for users and not accidentally to the other folder for modders?


Did you do a manual installation earlier? There should only be FNIS files in the Mod Organizer FNIS directory and no where else. Data/modorganizer/mods/FNIS. If it's not there delete any FNIS you can find in the Data folder.


Download the 3 FNIS packs with MO and install them.from the right window pane


Activate all 3 in the left window


Then setup the executable for FNIS in MO


Run the executable, it will run on a complete vanilla game and return a message it updated xx animations for xx mods even without the xpms skeleton.


After that you can install any other mods

Link to comment

Just reporting in that it is working now, at this moment, and posting the solution for me, so if any others have this problem it may help.


I posted to fore on the Nexus page, and he said that the problem was that my Steam/Skyrim registry was gone.    Said that MO is not set to detect properly between FNIS errors and warnings, and this is an effect.


So after reading this, I decided to try to do everything I could to force Skyrim to  create another Steam registry.    I had already verified cache, and run it from Steam, so I had figured that would have done it, but apparently not.


I removed all the FNIS things I could find from MO, cleaned the overwrite folder, set the FNIS checkers in the plugins back to false.


Then I started running Skyrim from the launcher, from MO without SKSE, from Steam directly, basically I ran it every way I could think of that would be vanilla.


Then I started adding FNIS back in, installed them in MO, and checked them.


Then I set up the executable again, by going to tools in the right pane, and simply right clicking add as executable.


I ran that one, and it ran through fine, no errors., just one warning still that Steam wasn't in the right directory.


I DID NOT change any of the FNIS check boxes in the plugin section back to true.   Right now its working, so i'm leaving it that way.  :)

Link to comment
  • 2 months later...

Please help me, i'm having the same problem. My character walks, and runs fine, but when I try to run when i hold a weapon, my character just glides around. I had recently installed sexlabs framework, but uninstalled it, please tell me how I can fix this, does it have anything to do with the generate fnis for users?  

Link to comment

Please help me, i'm having the same problem. My character walks, and runs fine, but when I try to run when i hold a weapon, my character just glides around. I had recently installed sexlabs framework, but uninstalled it, please tell me how I can fix this, does it have anything to do with the generate fnis for users?  

 Have you re updated FNIS behavior after your uninstall? 

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use