Jump to content

Help me fix a .nif, please!


Cicattrix

Recommended Posts

Friday, after seeing the Corpse Killer mod, it crossed my mind to adapt it to my liking. so, I have mixed a few pieces from some mods into 3ds Max and everything went fine. then I have copy/paste in NifSkope proper BSLightingShaderProperty branches (with 9 textures) and made a special folder for the textures to not have them pathed to all those mixed mods folders. then I have put it in game as replacer for elven light chest. I have used the same file for _0 and _1, because I didnt wanted to make both sizes, until I am not sure it works, but I dont think this make a big difference, apart from body scalling.

well, thing is that it crashes my game when I want to equip it. the game thinks for 1-2 seconds then instantly CTD.

 

I must also tell you that I am kinda n00b at this, learning to use these tools last month, when I have played with the idea of porting Hentai Bikini Clothes and reading/watching some tutorials. well, I had issues back then, but although Ive got a huge red triangle instead of the body (until I figured that I must attach bones to the armors pieces), it showed up and never crashed the game.

 

is not a big deal about this nif, I have made it just for fun, but it makes me crazy because I dont understand why it doesnt work. so, I will be grateful if someone will be nice enough to take a look at this nif and fix it. and I will also appreciate telling me what was wrong with it.

 

http://www.mediafire.com/?y14k4ya1tfdw34p

 

thank you in advance...

 

Link to comment

At first glance' date=' change in nitrishapedata the has vertex color option to yes and try again. The original mod use the alpha layer??

[/quote']

 

well, I have started with the Corpse Stalker mod (shirt and belt) then I have brought in some pieces from the asian Airy port (bra and panties) and the socks from that stripped mod. I have also tested diff other mods, but kept deleted their files. but the nif file should be clean cuz I have took care to not let any undesired files.

 

you ask about NiAlphaProperty? if so, yes, the socks and the Airy bra had this. the panties too, but I see that I have deleted it on the nif I had posted here. I didnt attached nothing more in NifSkope, apart from those BSLightingShaderProperty branches. and I dont know what does NiAlphaProperty anyway. I have seen that is rarely used, so I suposed is kinda expendable.

 

anyway, meantime I have cleaned all the NiAlphaProperty from the nif, but I keep get CTD...

 

k, I have turned Has vertex color on and tested it in game... well, I think this time it took 3 secs to CTD...

Link to comment

It seems like you didn't delete the NiAlphaProperty - it was still present in the nif you posted, and that's what's causing the issue. After removing these branches, the armor shows up fine in the game, but without the bra and socks.

 

I cross referenced with another mesh that has that property, but found no differences. I tried re-creating it, and copying it from the working mesh, but it still CTD's. Something in the alpha usage is bugging out the game. Maybe something with the texture channels?

Link to comment

yes, the version that I have posted here had the NiAlphaProperty on bra and socks, but I have already deleted it from the pants.

after making this thread, I have deleted those too and tested it, but still had the CTDs...

then I have tried your idea with Vertex colors, still unsuccessful. although from what I have seen, people dont use this option enabled...

 

an entire day I have compared my nif with many other modded or vanilla ones, but I couldnt see any difference.

 

if by texture channels you mean those from BSLightingShaderProperty branches, I have replaced those with 6 created by 3dsMax export by copying ones with 9 from a proper working nif. I did this before and it worked. and I did it following a tutorial that exist on youtube.

 

aside from importing those outfits and deleting the undesired pieces and extrabodies, the only change I have did in 3dsMax it was to resize a bit the shirt to cover the bra. so, I expected to not have issues, like when you try to adapt Oblivion mods and there come bones assignment issues. well, I dont know what skining and vertexing and other such pro thing are, so maybe I should have done more before exporting it.

 

anyway, if I must remove bra and panties, then practically is the Corpse Stalker with the stocks, which can be easily achieved by using the stocks and the undies as built into the body file. so, the issue seem to come from mixing the other mod in? I have another version similar to this, only w/o the shirt and it crashes also.

 

whats intriguing me is that each time I change the name of the SceneRoot parent node, it get a different and bigger number attached at the end (the one between brackets). should it have there the number of its childrens?

 

also, I dont know what ~Unknown Short 1~ does, but I see that i get 8 there while most of the nifs that I have checked have 0.

Link to comment

 

on the other hand, doing this in 3dsMax is fun and handy, but the need to replace the BSLightingShaderProperty branches after that is annoying.

I wonder if this mod pieces mixing can be done only in NifSkope? I tried it, but the main NiTriShape branches of the armor pieces refuse to be copy/pasted from a nif file to another. maybe I should duplicate one existing and then replace its childrens?

Link to comment

Basically, if it's just copy pasting and scaling, it can be done only in nifskope. It is possible to copy paste the tri shape branches, or even the whole NiNode, but requires some patience, since those can take up to a minute to copy (depending on the complexity of the branch). Also, if you do it that way, make sure to change the number of children on the NiNode and assign each tri branch to it.

Link to comment

well, is not a matter of patience, because I kinda get instantly some error message ”failed to map parent link NiNode”

I have just tried to copy the bra from the Airy_Armor nif to my nif and I got this error again.

I have tested this using the head nifs of Lydia and Hroki and it worked. but there are some different arrangements, as all the TriShapes are childrens to a NiNode that is children to a BSFadeNode along with the bones.

 

well, from what I see, I cant only copy the main TriShape and the BSDismemberSkinInstance branches. NiShapeData and the BSLightingShaderProperty branches can be copied.

 

 

Link to comment

”failed to map parent link NiNode” you definitly should look some basic tutorials before start do edition. In order do fix it you needed to change the root name of the NinNode to similar file you are coping.

anyway

be sure that Vertex colors are on

BsLightning is first in properities and NiAlpha is second

BSDismember -> Partition -> Body Part should be 32

 

Link to comment

@Handelo

I am using the last version of NifSkope... v1.1.0-RC5...

 

@Vitriks

hmm, I have read and watched a few tutorial, but it seems I wasnt paying too much attention... didnt knew about the same root name. thx!

Handelo already have put me to activate Vertex colors... done

BSDisremember to 32... that I have already knew and checked always...

BSLight was indeed on second positions on those pieces that had NiAlpha, although on the original mods nifs they were on first. 3dsMax must have changed them.

 

anyway, I have did what you said, still CTD. then I have even recopied the NiAlphas, still CTD...

 

Link to comment

@Vitriks

oh, you have tutorials? will watch them. thank you for sharing and for the advices.

until now I have related on those made by officerbeardontcare, which kinda helped me to port Hentai Bikini Clothes. well, I made the outfit show up in game, although the bra was kinda dangling around like having juggling attached to it. probably I havent attached the proper bones. anyway, next morning I have just discovered that the outfit was just ported successfully by some asian modder, so I have give up. but was a fun and challenging experience...

 

@handelo

yeah, thats what I am gonna do tomorrow, will see if I can do it only through NifSkope. as I have said this project is just for fun, but I have asked for help to understand what is wrong on this nif, although comparing it with other working ones it looks to have the same settings...

thank you for trying. I really appreciate it.

 

anyway, if you or anyone else still wanna look at it and try to fix it, I wont mind to solve this mystery...

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...