Jump to content

My Skyrim isn't launching.

Recommended Posts

Before I say anything, I've literally tried everything I could think of. I've spent two days trying to figure this out with no luck whatsoever..

At first, I had thought that maybe it was a problem with SKSE. I tried the original Skyrim launcher and pressed play. Nada. Then I thought maybe it's my mods? I disabled all my mods and it's still not working. Skyrim appears in my Task Manager, but it never launches the game. No Bethesda logo, nothing. I've tried running it as administrator and that didn't work either. I don't know what else to do.

Link to comment

Probably cause by some SKSE plugin, try to rename/remove all plugin in data\SKSE\plugins one by one to see if any of them is the culprit.


For me, I used to have problem with OneTweak.dll and new (1.58b2) sexlabutil.dll.  I have to fallback to previous version of both.

Link to comment

How much time do you give your PC to launch the game? I say this because I've got a similar problem where the game may take up to two minutes to actually launch sometimes. Like you, it appears in the task manager as usual but then nothing happens until the game launches a minute later.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use