Jump to content

Problem With Creation Kits


MajorKururu

Recommended Posts

Lately I have some problem while editing and saving an esp that contain NPC in it. Everytime I try to save the esp, the dependency will change. 

 

Example 1

 

The esp only has 2 dependency, skyrim.esm and update.esm but after saving, the dependency change to 4, skyrim.esm, update.esm, dawnguard.esm and  racecompatibility.esm. If I try to load a savegame with the esp active, it will CTD.

 

Example 2

 

The esp only has "XX" dependency, skyrim.esm, update.esm and XX.esp but after saving, the dependency change to 4, skyrim.esm, update.esm, dawnguard.esm and  racecompatibility.esm again, eliminating other dependency. The same CTD problem still occur.

 

Note.

 

The "XX" refer to how many dependency the esp has, example, 5 or 6 dependency.

 

I've re-install the CK but the same problem still occur. Is there a way to fix this?

 

 

Link to comment

The Creation Kit will set the dependencies automatically, if you have checked other *.esm files while loading the plugin in question. When you load the plugin, make sure nothing is checked. Check the plugin file, set it on active and load it.

 

You also can open the plugin with TES5Edit and remove the added masterfiles from the Header section.

Link to comment

I've double check the list, nothing is tick in the list other than the plugin that I wanted to edit. I will give my detail example.

 

The plugin that I wanted to edit is the [The Ningheim - Followers.esp]. The plugin contain 2 dependency, skyrim.esm and The Ningheim.esp. After i've save, the dependency change to 4, skyrim.esm, update.esm, dawnguard.esm and racecompatibility.esm. If I tried to load back the plugin, the ningheim tab under actor is gone but if I fine search, the follower somehow relocated under foxrace tab. Also in the foxrace tab, a duplicate of every single actor on the entire actor tab is in the foxrace tab. 

 

Similar problem occur when I tried to edit [seductress Serane.esp] (mod from the LL member) .DLC1Serana somehow got relocated under the foxrace tab and the imperialracevampire tab is gone.

 

I'm completely at loss on what currently happen to my CK.  

 

Link to comment

Hmm strange. I doubt the CK itself is broken but maybe the problem has to do with those mods you want to edit. The Serana mod has to have Dawnguard as dependency anyways so something is wrong with the plugin itself if it shows that is has only Skyrim.esm and Update.esm as dependencies.

 

Have you checked the plugins in question with TES5Edit? What does it tells you when you look at the Header Record?

Link to comment

Ahh yeah, look also on the Ningheim.esm. There you should see the dependencies you have after saving your plugin. The problem you have is the following: Every ESM the CK loads will be saved as a dependencie whe saving the plugin.
This includes EMSs that are masters of plugins you loaded and by this become a master of your active plugin as well.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use