Jump to content

Sexlab problem? Frame rate reaches single digits in first person

Recommended Posts

I ran the same set of mods for close to a year with fairly minor additions and subtractions (adding removing an occasional armor or weapon mod), then I finally decided to try some of the sexlab stuff. Now, I can create a new character and everything is fine for the first 10 hours or so of game play. But after that, 1st person view gives me a frame rate in the single digits. I can do a player.sexchange twice in the console without exiting, and my frame rate will return to normal until I enter 1st person view again. So far, I've tried the following:


replicated via starting several new characters

examined papyrus logs for hours

analyzed with script scalpel

Completely disabled hdtpe by renaming the dll

disabled any mods using scripts except sexlab mods

checked for dirty mods

rebuilt skyrim from scratch


1st person view is  the regular 1st person view

skeleton is groovtama's, most recent version

Using racemenu 3.0

Body is the same UNPB body I've been using for around 2 years, or whenever it was that Bunny release the unp bodyslide .5 preview


What's even stranger is that I noticed tonight that if I draw a bow, my frame rate returns to normal. Is there a 1st person idle or something that I can't see? That could certainly explain this bit. I've tried different idle sets along with vanilla idles, but none of that resolved the issue.


I'm not even a 100 percent sure that this is a sexlab problem, but adding sexlab mods was the last change I made to my set up.


In any case, I'm really looking for information on some of the underlying technology, like jcontainers and especially if there's a way to remove data stored in a save. I read through documentation, but unless the data is stored in a .json file, which is seem most mods don't do, I don't see how to clear corrupted data from a game, which I suspect is my problem.


Alternatively, is this something anyone else has seen? Or if not, any hints on where I might go next in trying to figure this out? Short of activating a single mod at a time and playing for a week or two to see if the problem happens, I'm out of ideas.


Load order in the spoiler.




(0) Skyrim.esm
(1) Update.esm
(2) Unofficial Skyrim Patch.esp
(3) Dawnguard.esm
(4) Unofficial Dawnguard Patch.esp
(5) HearthFires.esm
(6) Unofficial Hearthfire Patch.esp
(7) Dragonborn.esm
(8) Unofficial Dragonborn Patch.esp
(9) SexLab.esm
(10) RSkyrimChildren.esm
(11) ApachiiHair.esm
(12) Devious Devices - Assets.esm
(13) SGHairPackBase.esm
(14) EFFCore.esm
(15) ApachiiHairFemales.esm
(16) hdtHighHeel.esm
(17) CreatureFramework.esm
(18) KS Hairdo's.esp
(19) RaceCompatibility.esm
(20) SexLabAroused.esm
(21) SGHairPackAIO.esm
(22) ZaZAnimationPack.esm
(23) Devious Devices - Integration.esm
(24) daymoyl.esm
(25) Devious Devices - Expansion.esm
(26) HighResTexturePack01.esp
(27) HighResTexturePack02.esp
(28) HighResTexturePack03.esp
(29) Unofficial High Resolution Patch.esp
(30) Abundant Enchantments.esp
(31) Pureweather.esp
(32) Brawl Bugs CE.esp
(33) AncientBladeWeapons.esp
(34) iHUD.esp
(35) Purewaters.esp
(36) Ayame Kunoichi.esp.esp
(37) Schlongs of Skyrim - Light.esp
(38) ArmorOfIntrigue.esp
(39) dD - Realistic Ragdoll Force - Realistic.esp
(40) ImmersiveFP.esp
(41) SexLabWerewolves.esp
(42) NighteyeSpell.esp
(43) ELE_Legendary_Lite.esp
(44) FS_UltimateAssortment.esp
(45) Devious Deviants.esp
(46) EpisodeParallax.esp
(47) Better Stealth AI for Followers.esp
(48) Ghosu - Weapon Pack 1.esp
(49) HearthfireMultiKid.esp
(50) HearthfireMultiKid_LastName.esp
(51) MoreNastyCritters.esp
(52) FNISSexyMove.esp
(53) dc-mana-tanks-000.esp
(54) ForcefulBashPerk.esp
(55) ProperWeaponScale.esp
(56) Big N Maru.esp
(57) Auto Unequip Ammo.esp
(58) SexLabNudeCreatures.esp
(59) EFFDialogue.esp
(60) Fantasy Soundtrack Project.esp
(61) FSP - Dragonborn Edition.esp
(62) BlacktalonArmorV11UNP.esp
(63) SGEyebrows.esp
(64) Immersive Sounds - Compendium.esp
(65) DovahBlingJewelry.esp
(66) immersivesnowice.esp
(67) Better Dynamic Snow.esp
(68) PWwaterfall.esp
(69) RaceMenuPlugin.esp
(70) SOS Equipable Schlong.esp
(71) InigoPerkPointGiver.esp
(72) Invisibility Eyes Fix.esp
(73) Vivid Landscapes.esp
(74) Krill_AurielsBowFix_20BaseDamage.esp
(75) Dual Flurry for all.esp
(76) LunariRace.esp
(77) MaskofBlades.esp
(78) warpaints and tattoos.esp
(79) MidnightBreed.esp
(80) NightHawkTBBP.esp
(81) TrueBrows.esp
(82) NonSexLabAnimationPack.esp
(83) RaceMenuOverlays.esp
(84) Combat Evolved.esp
(85) Duel - Combat Realism.esp
(86) ImprovedSneakDetection.esp
(87) UIExtensions.esp
(88) RaceCompatibilityUSKPOverride.esp
(89) OrientalRace.esp
(90) mslVampiricThirst.esp
(91) YotoHatamonba.esp
(92) RaceMenu.esp
(93) RaceMenuPluginXPMSE.esp
(94) RSChildren_CompleteUSKP.esp
(95) SexLab Sound FX Replacer.esp
(96) SexLabNudeCreaturesDB.esp
(97) SexLabNudeCreaturesDG.esp
(98) Skyrim Immersive Creatures.esp
(99) FSP - Dawnguard Edition.esp
(100) SVS Merged Jewelery.esp
(101) Skyrim Immersive Creatures - DLC2.esp
(102) AnnaNPCs.esp
(103) HentaiCreatures.esp
(104) Bob's Boots SevenBase.esp
(105) SexLab Romance.esp
(106) SMIM-Merged-All.esp
(107) SamuraiBlades.esp
(108) Gifts Of The Outsider.esp
(109) SamuraiBladesWeapons.esp
(110) Jinhua.esp
(111) Neo's Slave Leia Renewal.esp
(112) sobcheat.esp
(113) DynDOLOD.esp
(114) SexLabDefeat.esp
(115) Skyrim+ALL DLC.esp
(116) SkyUI.esp
(117) Dual Sheath Redux.esp
(118) Customizable Camera.esp
(119) SL Deadly Drain.esp
(120) SPS - Sexlab Position Selector.esp
(121) SPTConsistentOlderPeople.esp
(122) sr_FillHerUp.esp
(123) Strap.esp
(124) SuiFonOutfitBBP.esp
(125) Variable Movement.esp
(126) Immersive Weapons.esp
(127) Lore Weapon Expansion.esp
(128) NPC Overhaul.esp
(129) PotemaCrashFix.esp
(130) serana.esp
(131) TrueEyes.esp
(132) Unique Uniques.esp
(133) Insanity Weapons.esp
(134) UnreadBooksGlow.esp
(135) Vampiric_Drain_Fix_BloodChalice.esp
(136) VioLens.esp
(137) yurica_daisho.esp
(138) Bashed Patch, 0.esp
(139) Dual Sheath Redux Patch.esp


edit to add a couple of other trouble shooting things I tried and some more detail on my set up

Link to comment

Not sure how to export a mod list other than typing the whole thing up by hand. But here's the rest of the info:


1st person view is  the regular vanilla 1st person view

skeleton is groovtama's, most recent version

Using racemenu 3.0

Body is the same UNPB body I've been using for around 2 years, or whenever it was that Bunny release the unp bodyslide .5 preview


I did try disabling everything on that list except racemenu and the body, which becomes irrelevant in the first person view since the 1st person body would be used, and that's the same first person body I've used since I installed UNP at least 2 years ago. But I tried replacing it again just for the heck of it.


I also checked the hdt logs for errors about missing bones, since I've seen something similar happen when you go into an area with, say, a draugr using a skeleton that lacks bones that are in the hdtpe xml. Nothing in that log either, though.


Hope that answer is not completely useless.

Link to comment

Well, I'm back to some sort of data corruption happening. Spun up a new character and played to level 6. By then, I was already seeing a frame rate drop of about 25%. My frame rate is high enough that I wouldn't easily notice something like that, so I kept comparing it in different places to doing the player.sexchange thing and going in and out of 1st person.


So I'm back to my original questions regarding the underlying tech. And now, potentially, if there's a way to clear that data out of my save.

Link to comment

If you suspect some mod causing the issue you should uninstall the mod, and continue doing this, one by one, until the issue will gone. Also look at save cleaners, although it's a struggle with the cause, rather than a consequence..

Link to comment

Yeah, tried that. Disabled all the sexlab stuff in fact and ran it through script scalpel. Didn't help. Seems like once the bad data is there, it's too late. If I knew where the bad data was, or at least what I was looking for in general, I could probably rip it out with scalpel. Otherwise, I'm pretty sure I'd just destroy the save.

Link to comment

What is the point of ripping your 'bad data' if loadorder will still contain a mod causing issues? Also try zeroing stack (via Papyrus Data Transfer tool) and/or disable HDT, JC, PU. You may even try disable all esp plugins except vanilla and see what happens

Link to comment

You're not following. Just disabling the mods doesn't fix it. The bad data still causes the problem. So both disabling and ripping out the data seem to be required. Thus, I'd have to be able to locate all the data for at least everything outside the base sexlab framework, which I'm fairly sure is not the problem. if it was, I wouldn't be the only one seeing this.

Link to comment

Well, disabling some SKSE plugins, mods partially prevents data from being loaded, partially invalidates stacks, etc. Thus, consequent save file will contain less data. And, if you disabled all your mods, skse plugins, zeroed stacks and the issue still there then it can't be resolved

Link to comment

  Being an MO fanboy, I may likely not be of help, but I've used the PDTWrapper program with good results on a three-year-old Skyrim installation. It will load the papyrus log of a save for analysis of dead-ends and such for removal. Also a list of orphan scripts for deleting.

  While not what you are saying, recently I was getting a frame rate of 6fps and no greater than14 in-game. I found it was a follower mod I had installed but not made a follower. It as discribed as having HDT physics hair.

Link to comment

Very much doubt it's specifically a SexLab problem. But if it works fine on a new save and then creeps up after a chunk of playtime like you say, and you haven't added or removed any mods in that time leading up to it; Than it is most likely a problem with with an improperly installed/uninstalled mod.


Enable your papyrus debug log if you haven't yet, replicate the problem in your save file, then check and post the resulting log file.

Link to comment

So as I said in the OP, the sexlab stuff is the last set of mods I added to a mix  that had been running for over a year without this problem. 


One other interesting thing I've noted over the last few days is that if I zoom out from my character, the frame rate goes up a lot. As in from single digits up to almost 30 FPS. I don't get that at all, but it makes me think there might be a visual effect I can't see that's causing this. Though I'd always been under the impression that visual affects don't appear in first person.


Another point to clarify is that I usually play in 3rd person, but the extremely low frame rate is happening as soon as I load or reload, so something in an OnGameReload or OnPlayerLoadGame has to be responsible, yes? The problem does not show up when simply going through a load door.


Link to comment

Some progress, after starting an untold number of new characters and disabling a single mod at a time. At least part of the problem seems to be more nasty critters. I've got about 10-12 hours on a new PC and my frame rate dropped some, but is still at least in the 30's outside, so about a 300-400% improvement.

Link to comment

OK, this will read as something from a crazy person, but I'm completely confused at this point.... My game had at last gotten down to single digits again. But then I finished the quest to read the elder scroll at the time wound and the problem disappeared. I have no idea why, and it'll probably be back tomorrow, but at least I get some relief. And I can go into first person again.

Link to comment
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...