Jump to content

Don't know what to do

Recommended Posts

So, the SexLab animation weren't working for me, and no matter how many times I reinstalled it or went into the game and "cleaned" it, the animations refuses to play. I still get sounds, prompts, and notifications, but no animations. The NPC's will just stand there making sex noises. (Which I will say is kind of funny.) So after a couple tries at resetting it I went to the technical support and it said this: 

  1. Click the big yellow button that says "Update FNIS Behavior" and wait for abit to let it finish, it may appear frozen for a short while during this process.
    • Ensure you see the lines "Reading SexLab ..." and "Reading SexLabCreature ..." after it finishes
  2. Ensure FNIS didn't output any important errors in the box after finishing as well. A major error that people seem to often ignore is having PCEA patch checked when they don't have it installed - this prevent FNIS from properly completing.

    So I went to my FNIS generator and it didn't say "Reading Sexlab..." So I went to fix it and realized.... IT DOESN'T TELL ME HOW TO FIX IT. So after looking through the page for a couple of minutes I decided to make a post. I'm extremely sorry if it turns out it does say how to fix it and I missed it, but I would love if you would tell me what's wrong and how to fix it. I installed FNIS manually, and all my other mods are installed through ModOrganizer, due to the fact I find manual installations tedious.

    Edit: This might help, but I haven't a clue to do with it...
    (Apparently theres a link in there somewhere, and since I can't post links for some reason I added some spaces in it, I hope it doesn't throw anyone off...)

    Skyrim: - C:\Program Files (x86)\Steam\ steam apps\common\Skyrim (Steam)
    Skeleton female: Default (99 bones)   male: Default (99 bones)
    Patch: "GENDER Specific Animations" 
    Patch: "SKELETON Arm Fix" 
    Reading FNIS  V5.1.1 ...
    Reading FNIS Base V5.1.1 ...
    Reading FNIS CreatureVersion V5.1 ...
    Reading FNIS Spells V5.0.1  ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 alternate animations) ...
    All Anim Lists scanned. Generating Behavior Files ...
    No GENDER directory Animations \male\
    No GENDER directory Animations \female\
    Generating animationsetdatasinglefile. txt ...
    Create Cr eature Behaviors ...
    0_master usage: 2.9 %   ( 9 paired, 0 kill animations)
     224 animations for 4 mods successfully included (character)
Link to comment

  1. Stop using the skeleton arm fix patch when you aren't even using a custom skeleton. Or better yet install a custom skeleton such as xp32's  Maximum Skeleton OR xp32's Maximum Skeleton or xp32 Maximum Skeleton Extended.
  2. If you are using a mod manager you have probably installed and are running FNIS incorrectly here.
  3. If you are using Nexus Mod Manager as your mod manager here, aside from being terrible, it is also renown for not properly extracting the FNIS files when installing mods with it. This may have been fixed by now, I don't know, I stopped using NMM a long while ago.
  4. If you are using Mod Organizer (YAY for smart choices!) than your FNIS log suggests you aren't starting it with MO but are trying to start it manually, which is wrong. Read the FNIS section of http://wiki.step-project.com/Guide:Mod_Organizer#tab=Third_Party_Programs if you haven't.
Link to comment

Do you have a gender specific animation mod installed? 


No GENDER directory Animations \male\
No GENDER directory Animations \female\
/\ This makes me think you don't, and ergo have patch selected in the generator that you shouldn't.
Edit: that's aside from the patch Ashal pointed out that you shouldn't have without a custom skeleton.
Also post the entire generator line, it just looks like you installed fnis wrong or are a pirate when you edit that to post it. We like to see where the actual .exe is in the generator line to know if you even have it in the right directory.
Link to comment

FNIS through MO doesn't seem to work for some reason, but I'm guessing that it'd be best to manually install sexlab then?

You need to run every single executable (including FNIS) through MO. It makes changes to the structure of your game's directory, hence why it allows you to make seperate profiles. So, if you want to run FNIS, you'll need to boot up MO, go to that medium-sized box top right that in your case should say "Skyrim" or "SKSE", then scroll down and "Edit", search for FNIS_for_users.exe (just an example, I don't think the exe is called exactly like that), and apply it. Then click OK and run it.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use