Jump to content

Getting crash at specific point with my script.

Recommended Posts

I am getting a very consistent crash at a specific point when starting a scene and I am not sure why. I am not having the issue with other mods just mine currently. I have reinstalled SexLab and several other mods, run FNIS (no errors) and have even started a new game but the issue persists. The papyrus log doesn't show any errors at the time of the crash either.


Here is the script I am using:



Function StartElenwenOral() ;start sex with Elenwen

actor[] sexActors = new actor[2]
sexactors[0] = Playerref
sexactors[1] = ActorElenwen
sslBaseAnimation[] anims
;anims = SexLab.GetAnimationsByTag(2, "oral", "FF")
RegisterforModEvent("HookAnimationend_Elenwen", "CheckElenwenDone")
sexlab.startsex(sexactors, anims, centeron = PosElenwenSol02, allowbed = false, hook = "elenwen")
Event CheckElenwenDone(int threadID, bool hasPlayer)
if quest02.getstage() == 165
;debug.notification("Elenwen wants more")
elseif quest02.getstage() == 175
;debug.notification("Elenwen is finished")


It will work properly on occasion but most times it crashes. This is the log from the most current one, it worked properly on the first pass but crashed on the second: Papyrus.0.zip


Every other time it crashes it crashes at the exact same point (same last line).


Link to comment

In the last dozen attempts (and crashes) it has made it through the first of the two acts twice but not the second. The thing is once I had it working at first it would work fairly regularly but got worse and worse as I tested, the only line that changed was the anims= line.



This quest will do far more than tease, this part is just to warm things up a bit.

Link to comment

Ok, I reactivated the anims= line and added a tag:


anims = SexLab.GetAnimationsByTag(2, "oral", "FF", TagSuppress = "boobjob")


And the scene works as it was before, it seems like the fewer the tags the worse the stability. I was down to just the oral tag before when stability worsened and commenting out that line seems to have made it completely unstable but it should work without it. I will continue testing to see if that has resolved the problem.


Also, can you use more than one tag with the tagsuppress or can you block the use of the strapon for that scene? If so I have not been able to figure out how.

Link to comment

Only time I had CTD when starting SL scene was because of bad skeleton/body mesh combo.


That YgNordRace(female) works fine? I mean YgNordRace is a custom race. For some odd reason custom races come with pretty wierd mesh/skeleton.


Edit: oh, and not all animations are created equally. It could be just some combos of animation, mesh, skeleton.


Long shot: Long, long time ago, there was a bug with elven races. Instant CTD if you switch between 1st and 3rd person view.

Link to comment

The other odd issue I am having is with equipping a blindfold just after that scene (if it makes it through). The command is set up correctly (identical to the gag that is equipped just before it with no problem) and the properties are all correct, I have even tried 3 different blindfolds and it crashes with each of them. I know that they are working as I can equip them on myself and the same command works in the other scripts I am using. It doesn't throw any errors in the log with that either.

Link to comment

When things stop working for me, I:

- add shit load of Debug.Trace lines. Like every second line. Not a joke. (Ever since I learned how to make SKSE plugin i replaced Debug.Trace with Windows OutputDebugString. It sends text to external app, DBWin32. If Skyrim crashes, that external app is still alive, so I don't lose log)

- I add 'trace' everywhere, including other mods. They come with source. And even if they wouldn't theres pex decompiler.

- comment out everything until things start to work ... and then add things back one by one


Link to comment

Sexlab already has a lot of those, I can see the point where it crashes. This is all the entries in the log from it:



[09/08/2014 - 02:03:02PM] -- SexLab -- NOTICE: Found Animations(1): Arrok 69, 

[09/08/2014 - 02:03:03PM] -- SexLab -- Thread[0] - Thread[0]: Entering Making State
[09/08/2014 - 02:03:03PM] -- SexLab -- NOTICE: ValidateActor(Lira) -- TRUE -- Cache MISS
[09/08/2014 - 02:03:03PM] -- SexLab -- [sslActorAlias <alias ActorAlias004 on quest SexLabThread00 (0F061EEF)>]: Slotted 'Lira'
[09/08/2014 - 02:03:03PM] -- SexLab -- NOTICE: ValidateActor(Elenwen) -- TRUE -- Cache MISS
[09/08/2014 - 02:03:03PM] -- SexLab -- [sslActorAlias <alias ActorAlias003 on quest SexLabThread00 (0F061EEF)>]: Slotted 'Elenwen'
[09/08/2014 - 02:03:03PM] -- SexLab -- NOTICE: Found Animations(10): Arrok Blowjob, AP Blowjob, AP Kneeling Blowjob, AP Standing Blowjob, Arrok Boobjob, Arrok Foreplay, Arrok Sitting Foreplay, Arrok Standing Foreplay, $Zap_Armb_Boobjob01, $Zap_Wri_Boobjob01, 
[09/08/2014 - 02:03:03PM] -- SexLab -- Thread[0] - Adjustment Profile: ArrokSittingForeplay.Adjust.YgNordRaceF.HighElfRaceF


It ends at the exact same point every time and happens 95% of the time it runs.



Link to comment

SL didn't crash there (where theres log entry). Up to that point it was OK. It crashed somewhere after that line.


Only way to know when it crashed is to add more traces. Crash would be just before the 'trace' that doesn't show in log file.


As SL sends mod events, you'd also have to comment out those or disable mods that listen, catch SL events. Just to be sure the problem is not one of other mods.


Link to comment

Well, what I found helped a lot but didn't eliminate the issue.


The SexLab script is triggered during a scene where the player is bound on their knees. There are 2 sessions with a short 1 phase scene between them.


Originally I was using an Idle Marker with the idle assigned to it, apparently it was having issues releasing the player. With this setup it crashed every time on the first session


I added a command to reset the players idle just before the scene and the stability improved. Out of 6 runs it completed both sessions 3 times and crashed on the first 3 times.


I went back in and changed the Idle marker to a xmarkerheading and put the idle in the AI package for that part and kept the idle reset and the reliability improved again. Out of 7 runs it completed the first session every time and crashed on the second 3 of the 7 times.


When it does crash, it crashes at the same point every time though.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use