Jump to content

Sexout & Interior Lightning Overhaul conflict


Recommended Posts

Hi,

Just doing a FNV install and came upon some issues with Interior Lightning Overhaul and Sexout preventing FNV to launch (ILO also has the same conflict with Readius and Flashlight NVSE). This is with a bashed patched game.

 

By curiosity (My knowledge in modding is zero so it's really just that) I launched FNVEdit and looked at the two. It appears both ESMs share same FormIDs (References) for totally different 'items'. For example the FormID of a script or a misc item in Sexout ESM is a cell in ILO.

 

As I said my knowledge is null so I may say something totally silly and FormIDs get assigned their respective ESM mod index so it doesn't conflict at all.

 

But if this could be the issue is there some workaround to let both ESM work in harmony?

If this has nothing to do with it, would someone know the conflict between the two and how to resolve it?

 

Thanks

Link to comment

There would be no FormID conflicts. FNVEdit can be misleading if you're not sure what you're looking at. I've used ILO with my install for quite a while now and have never experienced any issues. You've eliminated everything else? What exactly is the issue? What is your complete load order?

Link to comment

 

...FormIDs get assigned their respective ESM mod index so it doesn't conflict at all.

 

This is exactly the case. This is why, when mod authors give console codes for working around bugs, its usually as xx000000 or whatever. The xx is replaced with the mod's index number. So while each mod may have a formID of 12000000 for two different objects when loaded alone, when loaded together one may be 12000000 and the other is 42000000.

Link to comment

Ok I just rechecked everything and the conflict is not between ILO and Sexout, but between ILO and Spice of Life. I'm sure I did re check ILO in my load order after having installed a few Sexout packages and before I came across Spice of Life. And it didn't work. But maybe I did mess up and left NVSE Flashlight or Readius on... I don't know.

 

Still I don't understand how ILO and Spice prevent the game from launching. When I launch FNVEdit with my load order I get no warning, no missing masters and such. A few lightning config and imagespaces conflict/override in some cells but that's all. I also tried to manually put everything ILO was overridden  with into the bashed patch but it didn't help.

 

This is my load order

This file was automatically generated by Mod Organizer.
FalloutNV.esm
DeadMoney.esm
HonestHearts.esm
OldWorldBlues.esm
LonesomeRoad.esm
GunRunnersArsenal.esm
ClassicPack.esm
MercenaryPack.esm
TribalPack.esm
CaravanPack.esm
YUP - Base Game + All DLC.esm
oHUD.esm
Detect Traps.esm
Ambient Temperature.esm
Inventory Access.esm
Sortomatic.esm
Advanced Recon Tech.esm
JIP Selective-Fire.esm
NVInteriors_Core.esm
New Vegas Redesigned 3.esm
ELECTRO-CITY - CompletedWorkorders.esm
NVInteriors_ComboEdition.esm
Tales from the Burning Sands.esm
Project Nevada - Core.esm
Project Nevada - Equipment.esm
Caliber.esm
ELECTRO-CITY - Highways and Byways.esm
CoitoErgoSum.esm
domecity.esm
Project Nevada - Rebalance.esp
Sexout.esm
SexoutSlavery.esm
SomeguySeries.esm
T6M Equipment Replacer NV.esm
Another-Kick-in-the-Head.esm
SexoutCommonResources.esm
The New Bison Steve Hotel.esm
Project Nevada - Cyberware.esp
More Perks.esm
SexoutDRTL.esm
Afterschool Special.esm
D.E.I.M.O.S..esm
Project Nevada - Extra Options.esm
NevadaSkies.esm
Weapons.of.the.New.Millenia.esm
Interior Lighting Overhaul - Core.esm
Interior Lighting Overhaul - L38PS.esm
Advanced Recon Range Finder.esp
FPSWeaponWheel.esp
Boacombat2glove.esp
The Weapon Mod Menu.esp
JIP Companions Command & Control.esp
ArmourRepairKits.esp
JIP Realistic Weapon Overheating.esp
Casino Exchange All.esp
CASM with MCM.esp
DarNifiedUINV.esp
Detect Traps Merged.esp
Advanced Recon Tech.esp
Vurt's WFO.esp
New Vegas Redesigned 3.esp
Cass alternate version.esp
TrooperOverhaul-Dragbody.esp
Type 6.esp
populatedcasino-medium.esp
YukiMergedMods.esp
FCO - Sweat.esp
Improved Casinos 2X.esp
EVE FNV - ALL DLC.esp
Improved-ammoingredientsloot.esp
RaestlozFactionArmorEnhancement.esp
Jump Fall Fixer.esp
LessIntrusiveKillCam.esp
Sandbox6 Mods Merged.esp
vault22FloralOverhaul.esp
WeaponModsExpanded.esp
1nivVSLArmors.esp
1nivPNSLPatch.esp
Integration - Couriers Stash+WMX.esp
WMX-DLCMerged.esp
Project Nevada - WMX.esp
Project Nevada - EVE All DLC.esp
WMX-ModernWeapons.esp
NewVegasUncutSeries.esp
Delay DLC - DM + HH + OWB + LR + GRA.esp
GRA - The Right to Bear Arms.esp
Alternative Start.esp
EMR-StealthSuitMkII.esp
OWB-Path Lights.esp
Machienzo Merged Mod.esp
Laurens_Bathroom_poetry.esp
CONELRAD 640-1240.esp
Project Nevada - Cyberware Additions.esp
Project Nevada - Rebalance Complete.esp
Project Nevada - All DLC.esp
ADAM Complete.esp
Advanced Recon Gear.esp
Advanced Recon Gear - Project Nevada.esp
Nipton Fires Extinguished.esp
Merged Fixes.esp
Powered Power Armor.esp
Ambient Temperature - PPA.esp
SCS - CombatArmour.esp
SexoutDRTLEx.esp
SexoutSound.esp
SmallerTalk.esp
Sortomatic_for_House_of_the_Chef.esp
Tales PN.esp
The Mod Configuration Menu.esp
Tutorial Killer - Merged .esp
NVInt_ARoomWithAView.esp
NewVegasBounties.esp
NewVegasBountiesII.esp
PortableCampsite.esp
T6M Merged.esp
T6M Gambler Female Suit.esp
ILO - Merged Patches.esp
NevadaSkies - Ultimate DLC Edition.esp
DragonskinTacticalOutfit.esp
Advanced Recon Armor.esp
Improved Sound FX - WMX - Merged Major DLCs.esp
Weapons.of.the.New.Millenia.CaliberX4+.Patch.esp
Weapons.of.the.New.Millenia.Leveled.Lists.esp
dD - Enhanced Blood Main NV.esp
mapmarkers.esp
Sexout-Another-Kick-Extension.esp
NukaCola-Ojo.esp
ExtendedDialogueVulpes.esp
GRARG.esp
Holster.esp
Weapons.of.the.New.Millenia.Store.LITE.esp
Distributed Necklaces and Chains Neck Seam Concealer.esp
nu_women_of_the_wasteland.esp
Better Burned Man.esp
pipboy2500_edisleado.esp
Bashed Patch, 0.esp

 
Oh well, I guess for now I'll just skip NVSE Flashlight (pity) and Spice of life.
 
Link to comment

From what I can see in your quoted load order, you are probably getting too close to the limit of how many ESPs the game can load.

 

At that point, the game starts to behave pretty chaotically, and I wouldn't be surprised if it also refused to launch.

 

Too much is just too much.

 

Try to merge (unsafe), or remove mods (safer) till you are down to 120 or so, and please report if you still have issues.

 

 

 

PS : I know the limit is 255 esps and about 400 esp+bsa for TES4/Oblivion, but much lower for FNV. Does someone have a link to an accurate source for FNV ?

Link to comment

It's 254 for Oblivion and technically also 254 for FNV and FO3. That's the hard limit, anyway. There's a soft limit which is in the process of being tracked down, but it's not the number of plugins that ever causes an issue. Recent findings suggest it's at least partially dependent on the number of records contained within the loaded plugins (so more complicated mods will make you hit your limit faster) but what that limit is still isn't certain.

 

Regarding the load issue: Simple thing but it's best to start with the basics. Have you uninstalled and reinstalled ILO and the mods that it appears to be conflicting with? Dumb as it may sound I have, more than once, completely broken my entire installation by accidentally compressing a texture in a way the engine doesn't like. If some of the assets didn't install properly it could break everything, so a reinstall is a good thing to try.

Link to comment

Thank you for your insight, Zippy57.

You are of course correct about the 254 ESP limit : I inadvertedly skipped the presence of the main ESM in my mind.

Coming from TES4 and TES3, the much lower limit of FNV was a surprise to me when I first discovered it. It still baffles me since I am fairly sure that my fully modded TES4 game references more resources than my modded FNV game, but what do I know. Bethesda/Obsidian perhaps wanted to play it safe, and allocate increased space to the main game (+DLCs) at the expense of user mods. Or perhaps is it just that the upgraded engine is more demanding on memory overall ?

In any case, it's good to know that the limit seems not to depend on some arbitrary number (120? 130? 140, more or less?), but on a more reliable factor like the total number of records. I was fully prepared to do a test with 250 dummy ESPs, just to check if I could launch the game, and prove the most common "theories" wrong.

Link to comment

Thanks for the clarifications zippy57.  :)

 

To answer your question, yes I did. Luckily I use MO which makes reinstalling and swapping mods much easier. I've tried playing around with load order, removing other mods not directly involved in the conflict, or mods involved with ILO through patches but to no avail. Really I feel like I'm dealing with black magic here. :P

 

And since I really wanted to make a Playthrough with Daughter of Ares, if something has to go it will be ILO then. But it's sad the enhancement it provides seems really gorgeous.

 

But at that point I have no idea what I could do. And I don't even understand how any conflict between these mods could prevent the game from launching.  :blink:

Link to comment
MO would launch the process but it would kill itself before reaching the stage where it open a window (where the process actually become the program). Mmmh it's really not clear the way I put it, but I don't know how to explain it otherwise. Note that part of my gibberish is tied to the fact I'm a non English speaker ;)

 

Anyhow I nailed it! It was tied to the amount of BSAs in my load order. I realized when I came across the same issue with a different pattern not involving ILO and with mods who were previously running fine together, that the issue occurred when I was adding a mod, at a certain point, containing BSA(s).

It might have been an Invalidation issue, but I had always make sure Datas were activated and had played ticking/unticking the Archive invalidation option in MO, and closing/reopening MO afterwards to make sure. Which didn't help. That's why it looks to me an issue with the sheer size of BSAs present (The ultimate version in itself contains a lot of bsas).

 

But at last everything run smooth even with ILO in my load order.

When I decided to get another go at FNV (Last playthrough must have been in 2011) I didn't think the modding part would take me so long. So naive, I should have known. :P

 

Anyhow many thanks for helping me through this, especially since it wasn't even tied to a SO issue. :)

 

While I'm here a quickie concerning SexOut resources. I saw in game that it adds perks (Dom related, sex size related) and was wondering how it actually affects the game. Do they need to be called by external SO mods to have any effect? Or are they directly affecting the Sexout core?

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...