Jump to content
IGNORED

new sexlab skyrim/skse running slowly problem help.


CeeTeeDee

Recommended Posts

hi,

 

I just updated sexlab to the latest version and now skyrim is running slowly, basically all the graphics, scripts, dialog, everything except the audio.

 

i might have borked the sexlab installation a little... but its working.

 

i've narrowed it down to an skse problem because disabling skse solves the speed issue.

 

the HUD also keeps disappearing...

 

so there must be something with either mfgconsole.dll or storageutil.dll, though neither are blocked by windows.

 

 

Link to comment

ok, managed to solve it ...mostly.

 

i've worked for a while on technical support projects myself and

 

[whine]its running slowly[/whine] is a common complaint :P

 

i promise this is not only a customer perception issue! ;)

 

disabling skse, saving and reloading does help a little...

 

is there any way to optimize the way skse loads dlls? a load order of sorts?

 

i've got the feeling all those plugins are bottle necking the shizz

 

...let me know...

Link to comment

My HUD is also disappearing as well please give me a heads up if you find out any solutions for that problem. With the slowed down performance I think you can point fingers at SKSE 1.7. and blame that version for the troubles (It is an alpha version for a good reason). It's one helluva heavy scripting extension so if you got a more weaker computer like me (I found mine in an ancient tomb, it must be a couple of centuries ago since this bad boy was created). 

Anyways, try to see if you have any mods that can cause troubles with the 1.7 SKSE vers.

Try out by un-installing SKSE and all your other mods that requires SKSE to work. Then re-install 1.7 and then all the mods after make sure all the mods you've installed are up-to-date as well (remember to run FNIS on the animation bad boys).

 

Hope it'll work, I wish I could help you out with some magical scripting fix but this is what I can do =)

 

Cheers! 

Link to comment

hi Destroy

 

my hud was disappearing only when i was standing idle without pressing any keys, the minute i activated a key the hud reappeared.

 

I reinstalled skse 1.7 by saving/loading without it running and that seemed to help a little.

 

for the processing / playback speed of the game i narrowed it down to the Immersive first person firstpersonplugin.dll, specifically the 'Immersive first person and SexLab integration' .esp i was loading,  disabled the esp and it seemed faster, basically i deleted all the skse plugins and added them in one by one until i had reset the script engine somehow, i'm still not sure what made it run slower

 

'slower' in terms of the character animations, scripted-dialog and the npcs lip-synching in slow motion, it is still not as snappy as it is without skse, neither is it enb/sweetfx dll's because i've been troubleshooting without them

 

good news is the hud for some reason has decided to stay put after reinstalling skse and changing some skyUI variables like icons or the 'active effect' box, so i'll assume its an mcm or skyui problem but it could also be the high heels system .dll because that was also glitching until i reloaded it.

 

i now vow to install sexlab updates with only the update files provided and not the entire package  :dodgy:

 

 

 

 

Link to comment

i'm still using immersive FP!, i just disabled the immersive FP for sexlab esp, but it still works with sexlab even without the esp, if you're using sex disabling the 'automatic free camera' might help, bind that to a key instead...

 

its a glitch, not a serious issue, try removing the immersive FP, highheels system, mempatch dll's etc... and it should correct itself. 

 

it did for me.

 

just copy them elsewhere and load, exit, and copy them back into the plugins directory... see if that works.

Link to comment

Well apparently the slowed down issue got me too really good. I tried running FRAPS at the same time with this issue I'm getting 30 FPS in-game but everything is playing out like a fight scene from Matrix, I believe it's the SKSE 1.7. Did you manage to figure that out? It's just weird that yesterday my copy of Skyrim was running perfectly right until now when I tried to play it today *sigh* 

Link to comment

If you're convinced it's skse1.7 or one of it's plugins causing it, than navigate to your Skyrim\data\SKSE\ folder, the actual folder, don't do this from a Mod Organizer folder, and edit a file, or create it if doesn't exists called, "SKSE.ini"  then edit these two settings to look like this, leaving any other potentially existing settings in there alone.

[General]
ClearInvalidRegistrations=1

[Debug]
WriteMinidumps=1

Start up your game after than and do do some stuff for a little bit like startup a sex scene with sexlab, play it through to completion, wait a couple seconds afterwards and then save and exit the game.

 

Than in your computers My Documents folder, goto My Games\Skyrim\SKSE\ open the file "skse.log" check it for any obvious errors and post the file here.

Link to comment

hey Ashal, thanks for your work on sexlab! I don't assume sexlab is the direct cause of these problems, only that they occured immediately after installing the latest sexlab version.

 

I have ClearInvalidRegistrations=1 and WriteMinidumps=1 in the SKSE.ini file already.

 

I no longer have the problems i described above, I managed to clear those, so let me clarify my posts...

 

I have confirmed the bugs are related to SKSE by launching skyrim without skse running

 

those bugs were slow-motion animation, npc dialog and disappearing hud when idle.

 

i've managed to fix both the slow-motion script + disappearing hud glitch by

 

-> uninstalling SKSE

-> saving + reloading without SKSE

-> reinstalling SKSE

-> removing FirstPersonPlugin.dll, hdtHighHeelNative.dll, hdtSkyrimMemPatch.dll and sr_ifpssl.esp (the esp was the cause imo)

-> loading, saving and reloading.

-> replacing FirstPersonPlugin.dll, hdtHighHeelNative.dll, hdtSkyrimMemPatch.dll

 

fortunately any skse .dll plugins, like chargen.dll or hdtphysicsextension keep their data in files, so its safe to disable SKSE.

 

then I scripted-cleaned the save game by using the save cleaner found here : http://www.nexusmods.com/skyrim/mods/52363/ using the 'fix script instances' and 'clean havok modified'

 

after all that I reinstalled the latest version of sexlab from the complete package and all is well.

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...