Jump to content

Broken Nif file as soon as i change & save texture w/ nifskope

Recommended Posts

I been going back to modding Oblivion, i am not new to modding either Oblivion or Skyrim and i have done weapons and followers for Oblivion before,  i even know how to use Nifskope since i have used it many times before, but every single time i try to change the texture and file path within a nif file the damn mesh breaks up, it either makes the mesh completely invisible (not being rendered) or it breaks some parts of the rig as they appear twisted, even some parts of the mesh appear purple, like if i did not assigned a texture, but i did.


I don't remember this happening before when i modded oblivion back in 2010 with Win7 x64, i just upgraded to Win10 Creator Update but i am not sure the issue is Windows itself, since i created a Win7 x64 VirtualMachine just to BASICALLY test Every version of NifSkope and it keeps happening... what the hell am i doing wrong? mind blown! just selecting a different texture it shows the change in NifSkope alright, then once i save and test the mesh in Oblivion... nothing! like if there is no mesh, i even checked like 10 times the ConstructionSet mesh file path but it is not working... i am 100% sure the file path are correct in ConstructionSet, so what the hell is going?


I been have tried with the following versions of nifskope:




and even newer ones such as:





I even tried with a new WinXP Virtual Machine but nothing works! it's driving me mad honestly... i really need help.

Link to comment
10 minutes ago, etayorius said:

Not oblivion itself, more like issues with Nifskope and modding. Should i post there regadless?

A Moderator may swoop in and close this thread and tell you to go to the Technical support forum, (I don't know if they're able to move threads or not) So for now, you may as well just stay here.

Link to comment

When the nif is invisible or purple you have missing textures.

What textures do you want to use ? You made your own textures?

Maybe wrong size?

in wrong folder.

No normal map ( _n.dds )


Can you upload a nif and the textures you want to use ? And the folder path you want to use.



I use for Oblivion NifSkope-1.0.22




You know you can not change body, hair or eye textures in a Nif ! The Textures path of such nif files are in the esm or esp.


Link to comment

Daaamn my texture was corrupted or something, i tried a random DDS texture with the same name and it worked, weird thing is that the Texture loads fine on Gimp, no big deal i can work on the texture again, it would probably take me like 20 minutes to set it up. 

Thank you fejeena! i honestly thought NifSkope was at fault, your suggestion on checking the texture turned up correct!

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...