Jump to content
IGNORED

From Blender to Nifscope - gaining/losing vertices - Also Shrinkwrap question


dashipper

Recommended Posts

General project:

 

I've been messing around with blender and meshes lately and I've reached the point where I am comfortable changing meshes around. Now I'm trying to figure out how to get them to scale properly with _0 and _1 versions.

 

 

More specifically what I'm doing:

 

I've been editing a femalebody_0.nif and femalebody_1.nif to get it slightly more to my liking. I can import them into skyrim and can see the changes without any problems. However, when using any weights between 0% and 100%, the object explodes into a pretty hodgepodge of shimmering polygons.

 

 

The problem:

 

I noticed in nifskope that the number of vertices is changing during the export process from blender. While in blender, both meshes have the same number of vertices/faces/edges.

 

When exporting as a .nif WITHOUT materials on the mesh, I get the same number of vertices in nifskope with both _0 and _1 versions.

 

When exporting as a .nif WITH a material and texture applied in blender, there is a change in the number of vertices when looking at it in nifskope.

 

 

The solution:

 

I have no idea. I just finished going through the _1 mesh and manually resized it down to the _0 mesh in blender. Maybe that'll work?

 

 

The question:

Anybody know what the hell is going on with my vertices not being equal when adding a material to my mesh?

 

Also, is it possible to shrinkwrap object 2 to the surface of object 1 and then delete object 1 without object 2 reverting to it's default position?

Link to comment

General project:

The solution:

 

I just finished going through the _1 mesh and manually resized it down to the _0 mesh in blender. Maybe that'll work?

 

yups. that is the solution' date=' just do the method you prefer, i do the same thing tho (using _1 and shaping into _0). this tutorial really help me so you might wanna check it, and see the section of "Adjust the _0.nif armour shape".

 

The question:

Anybody know what the hell is going on with my vertices not being equal when adding a material to my mesh?

 

did you edit any of the vertices ? maybe transforming the faces from triangle into square (which sometimes can mess up the uv map) ?

 

Also' date=' is it possible to shrinkwrap object 2 to the surface of object 1 and then delete object 1 without object 2 reverting to it's default position?

[/quote']

 

the only way i've known is to freeze the shrinkwrap in your case is on object 2 (apply it) or if you afraid something gone bad well you can just duplicate the object 2 while it still in shrinkwrap mode and hide it (thats what i do), or you can hide object 1 instead, object 2 will still maintain its shape/position.

 

hope that help

 

 

Link to comment

General project:

 

I've been messing around with blender and meshes lately and I've reached the point where I am comfortable changing meshes around. Now I'm trying to figure out how to get them to scale properly with _0 and _1 versions.

 

 

More specifically what I'm doing:

 

I've been editing a femalebody_0.nif and femalebody_1.nif to get it slightly more to my liking. I can import them into skyrim and can see the changes without any problems. However' date=' when using any weights between 0% and 100%, the object explodes into a pretty hodgepodge of shimmering polygons.

 

 

The problem:

 

I noticed in nifskope that the number of vertices is changing during the export process from blender. While in blender, both meshes have the same number of vertices/faces/edges.

 

When exporting as a .nif WITHOUT materials on the mesh, I get the same number of vertices in nifskope with both _0 and _1 versions.

 

When exporting as a .nif WITH a material and texture applied in blender, there is a change in the number of vertices when looking at it in nifskope.

 

 

The solution:

 

I have no idea. I just finished going through the _1 mesh and manually resized it down to the _0 mesh in blender. Maybe that'll work?

 

 

The question:

Anybody know what the hell is going on with my vertices not being equal when adding a material to my mesh?

 

Also, is it possible to shrinkwrap object 2 to the surface of object 1 and then delete object 1 without object 2 reverting to it's default position?

[/quote']

 

What ever body you first meshed in blender. you have to use that body for the bigger version. This can be a bitch but you will have to re size the wrist holes, ankle holes and the neck hole. Do not re weight any thing after your done with the second body. But what I mean is you bring in _0.nif then mesh it the way you want. then bring in the the mesh again and bone weight copy the new body to the old. Then that's it make the second body and don't re weight it after that and export it out then see what happens. The armor works the same you can only weight it once other wise you'll end up with one file bigger then the other. I have no idea what to tell you about shrink wrap I always sculpt every thing.

Also when you put armor piece from one nif to another make sure to name every piece the same as the first. Make sure to put each piece of armor in in the same order for each body type as well.

 

Link to comment

Thanks for the responses!

 

 

General project:

The solution:

 

I just finished going through the _1 mesh and manually resized it down to the _0 mesh in blender. Maybe that'll work?

 

yups. that is the solution' date=' just do the method you prefer, i do the same thing tho (using _1 and shaping into _0). this tutorial really help me so you might wanna check it, and see the section of "Adjust the _0.nif armour shape".

 

Yeah, that's the tutorial I pretty much learned how to do everything with. It's been really helpful so far, just getting stuck on this one problem.

 

 

The question:

Anybody know what the hell is going on with my vertices not being equal when adding a material to my mesh?

 

did you edit any of the vertices ? maybe transforming the faces from triangle into square (which sometimes can mess up the uv map) ?

 

Nope' date=' not to my knowledge. All that I had originally done to the mesh was some scaling and rotating, nothing that would add, remove, or alter the shape of the vertices (beyond stretching etc). I never updated the UV map as I still wanted the texture applied to the exact same vertices.

 

 

Also' date=' is it possible to shrinkwrap object 2 to the surface of object 1 and then delete object 1 without object 2 reverting to it's default position?

[/quote']

 

the only way i've known is to freeze the shrinkwrap in your case is on object 2 (apply it) or if you afraid something gone bad well you can just duplicate the object 2 while it still in shrinkwrap mode and hide it (thats what i do), or you can hide object 1 instead, object 2 will still maintain its shape/position.

 

hope that help

 

Thanks, Anubis, I'll go back to my mesh tomorrow and try your suggestions (after figuring out how to do them xD). This is the part that I was stuck on in putting the manual resize into the game.

 

 

What ever body you first meshed in blender. you have to use that body for the bigger version. This can be a bitch but you will have to re size the wrist holes' date=' ankle holes and the neck hole. Do not re weight any thing after your done with the second body. But what I mean is you bring in _0.nif then mesh it the way you want. then bring in the the mesh again and bone weight copy the new body to the old. Then that's it make the second body and don't re weight it after that and export it out then see what happens. The armor works the same you can only weight it once other wise you'll end up with one file bigger then the other. I have no idea what to tell you about shrink wrap I always sculpt every thing.

Also when you put armor piece from one nif to another make sure to name every piece the same as the first. Make sure to put each piece of armor in in the same order for each body type as well.

[/quote']

 

I did none of this in my initial trial. I didn't make any real fundamental changes to the body when I was editing BOTH of the _0 and _1 body meshes. I'll give this a try just to be on the safe side now that I've scaled the _1 body down to the _0 size.

 

Thanks again for the responses.

Link to comment

Okay, I'm still doing something wrong. Even after shrinking body 1 down to body 0, I'm still getting a different number of vertices in each.

 

 

The edits I'm trying to do are for personal use and are for caliente's body (CBBE). When I open the original meshes in nifscope to begin with, they have 3471 vertices. In blender they have 3488 vertices, 6516 faces, 9807 edges. After exporting as a .nif again.. the Num Vertices under NiTriShapeData is 18700 or so.

 

Am I missing a step here? Do I have a wrong setting somewhere? Am I zigging when I should be zagging?

Link to comment

After some fidgeting I have been unable to resolve the issue with blender so I switched to 3ds max where I continued to have the same loss of vertices initially. However, after turning off "auto smooth mesh" when importing new meshes, I am now able to successfully export meshes without vertices vanishing. Testing the weight slider in game works just fine, too.

 

Only problem now is I'm back to having 19541 vertices instead of the original 3500 something resulting in a larger mesh. Just will have to avoid having lots of naked girls on my screen at the same time...

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...