Jump to content

Broken Companion Dragon Quest

Recommended Posts

So, I'm having a REALLY weird issue.  I've done all the "main" Companions quests, curing Kodlak etc., and Aela's Radiant quests, including all three totems (because I LOVE being a werewolf!) and started working on Vilkas.  Well, he sent me on a lot of random stuff, and still no option to cure him, so I went and did other things for awhile.  Came back, and he asked me to kill a dragon at Ancient's Ascent.  Well, okay. . . except I'd already killed a dragon there (WAY earlier) for the Jarl of Falkreath (the little snot.)  Well, there was a dragon there when I went (interestingly enough), but killing it didn't give me a dragon soul, and didn't let me talk to Vilkas to complete the quest.  The quest is marked as complete in my journal, but I couldn't get the finishing stage from him.  So, I fast-traveled back to Whiterun, thinking that might clear it (my autosave before the quest was already overwritten, dammit), and now Vilkas gave me his Purity quest.  Went and did that, and now he asks me to kill a different dragon.  Cool beans.  Except, now that the new dragon is dead, it still won't give me the complete dialogue option.


What REALLY makes this strange is that Farkas won't give me any "looking for work" options at all, and Kodlak is back sitting in his room like nothing ever happened, except he'll only say "Hmm?" when I try and talk to him.


I REALLY don't want to have to start a brand new game over from scratch, or go back a few hours to my previous save.  Any way I can fix this schlomozzel?


EDIT:  Oops, meant to post this in general Skyrim Tech Support.

Link to comment

EDIT:  Oops, meant to post this in general Skyrim Tech Support.


Heh, Never mind.


The lair dragons respawn after ten days or so, or as part of quest objectives. you can kill them as many times as you like. There is a bug related to the Dragonborn DLC (I am assuming) that means a dragon will occasionally skip the soul reward for no apparent reason.


I'm a little confused about the order of events here. There are certain things that have to take place as part of Companions primary quests which unlock further radiant quests. But from your description there are conditions not yet met for some primary quests and yet you are getting radiant quests that only unlock after them... I'm totally beating around bush here as I don't know if you are worried about spoilers.


If you are not too worried about spoilers you should go through the list of Companions quests [uESP Wiki] and see if your game is missing a step somewhere.


Otherwise it might mean using the console to advance one or more of the quests if they are stuck which can have unpredictable consequences.



Just an afterthought: do you have any more witch heads in your inventory? Perhaps you missed one.

Link to comment

I have all the witch heads.


The thing is, I've done all the prerequisite quests, I'm sure.  I've done this on a few other partial playthroughs and never had a problem (with those quests, those partial playthroughs were due to other reasons.)  I ran the Companions quests until I got to curing Kodlak, and did that.  Then I went did a bunch of Animal Exterminations for Aela, and got the Totems with her.  Then I went to Vilkas, and he gave me a bunch of random Radiant quests until I finally got the Dragon one (which, if my strategy guide is to be believed, should only happen after I've cured him.)  That's where things started bugging out.


If the bug is related to the Dragonborn DLC (I got the soul on the second one Vilkas and I went after), would the Unofficial Patch help?

Link to comment

What I'm reading on UESP suggest that there are bugs in some of the Companians quests that are fixed by the unofficial patch. However, I have no idea what the patch will do for quests that are already active or complete when it's applied. It may do nothing at all.


I don't think the patch does anything about the lost dragon souls. You could always add one via the console if you feel you've earned it fair and square:


player.modav dragonsouls 1

Link to comment

Well, I'm running Deadly Dragons with Assault every three days, so I have more Dragon Souls than I know what to do with at this point.  So that's not really the issue, I just want to be able to finish this quest.


I downloaded the unofficial Skyrim patch to unbug another quest, and it worked fine, even while I was standing in the home of the person I had to turn the quest into.  Guess I'll look into the other unofficial patches, see if they'll fix it.


EDIT:  The Unofficial Patches didn't help fix the save I had going.  Stuck completely on talking to Vilkas, can't even talk to other Companion leaders for work now.  Guess I'll reload my earlier save and replay about four frelling hours of game. . .

Link to comment

Since Kodlak is still kicking around let's assume that the Blood's Honor quest is the one that has messed up. Make a new save outside of Whiterun and try this in the console:


setstage C04 30


This should give you the prompt to return to Kodlak. Wait an hour then go back to Jorrvaskr and see if the scene plays out. If this works then Kodlak should be out of the picture and hopefully the dependant quests will function properly. You may have to wait a few days and keep trying to get radiant stuff.

Link to comment

Well, I went back to before I started the most recent round of Companions quests already, now I'm grappling with fixing dark face (yet a-frelling-gain.)  If the quests bug out again, I'll give that a shot.  Thanks.

Link to comment

Huh.  Did the stuff I'd done previously, went back to the Companions to try and finish things off, and Farkas still won't give me the 'I'm looking for work" option.  I'm almost afraid to talk to Vilkas, since it might just bug things out again like it did last time (definition of insanity, and all that.)

Link to comment

Huh, now things are working fine.  Didn't wait much in-game, but reloaded where I'd left off and gave it a shot.  Farkas gave me his quest to cure him, Vilkas sent me to rescue a kidnapped person from Markarth (I've decided I hate Markarth and will never return if given the option), then asked me to cure.  Then Farkas and I slew a dragon (well, actually three, thanks to Assault from Deadly Dragons.)  All wrapped up with a bow.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use