Jump to content
IGNORED

Texture Issue


Recommended Posts

I am trying to change CHSBHC V3-T Daedric replacer armor to the body that I use. I have everything set up correctly in nifskope, all the texture paths lead to the correct place, the texture shows up correctly in nifskope but when I go into game its the default skin texture. I have tried everything and I can't figure out WHY it is using the default texture and not what I pointed to. Anyone know what would cause that?

post-7703-0-70715900-1400811702_thumb.jpg

Link to comment

I am trying to change CHSBHC V3-T Daedric replacer armor to the body that I use. I have everything set up correctly in nifskope, all the texture paths lead to the correct place, the texture shows up correctly in nifskope but when I go into game its the default skin texture. I have tried everything and I can't figure out WHY it is using the default texture and not what I pointed to. Anyone know what would cause that?

 

attachicon.gifannoying.jpg

 

It's probably because the shader branch for that mesh in the .nif file is one copied from a naked body mesh from a different .nif file (so the skin tag was transferred over (I'm not sure what the exact flag settings are as I haven't looked into it with detail--it's probably because it's set as "Skin Tint" under the "Skyrim Shader Type", though not sure if other things correlate with it too)--because the skin color needs to change for customized characters, Skyrim reads in shaders with a skin tag and changes them to whatever was designated in the game's .esp for handling skin.

 

Basically, you just need to select that body mesh, delete it's "BSLightingShaderProperty" (Ctrl+Del), copy a "BSLightingShaderProperty" from another nif (Ctrl+C--most likely one that already has that chainmail set up; or any is fine, as long as it's not a naked body or one that dynamically swaps textures/colors in-game), select the "NiTriShape" of the body mesh and paste the non-skin "BSLightingShaderProperty" back into the body shape (Ctrl+V), change the texture paths accordingly, and save and test.

 

Hope this helps!

 

Link to comment

 

I am trying to change CHSBHC V3-T Daedric replacer armor to the body that I use. I have everything set up correctly in nifskope, all the texture paths lead to the correct place, the texture shows up correctly in nifskope but when I go into game its the default skin texture. I have tried everything and I can't figure out WHY it is using the default texture and not what I pointed to. Anyone know what would cause that?

 

attachicon.gifannoying.jpg

 

It's probably because the shader branch for that mesh in the .nif file is one copied from a naked body mesh from a different .nif file (so the skin tag was transferred over (I'm not sure what the exact flag settings are as I haven't looked into it with detail--it's probably because it's set as "Skin Tint" under the "Skyrim Shader Type", though not sure if other things correlate with it too)--because the skin color needs to change for customized characters, Skyrim reads in shaders with a skin tag and changes them to whatever was designated in the game's .esp for handling skin.

 

Basically, you just need to select that body mesh, delete it's "BSLightingShaderProperty" (Ctrl+Del), copy a "BSLightingShaderProperty" from another nif (Ctrl+C--most likely one that already has that chainmail set up; or any is fine, as long as it's not a naked body or one that dynamically swaps textures/colors in-game), select the "NiTriShape" of the body mesh and paste the non-skin "BSLightingShaderProperty" back into the body shape (Ctrl+V), change the texture paths accordingly, and save and test.

 

Hope this helps!

 

 

 

Thank you very much, that worked perfectly! You rock.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...