Jump to content
IGNORED

Horse Animation Not Starting


Recommended Posts

First off, all other creature animations I have tried work (bear/dog/chaurus/dragon/draugr/etc), however, when I try to perform either animation Horse_Doggystyle_A2 (via sexlab matchmaker) or Bestiality_horseDoggystyle_Horse1 (via Creature Sex - Spell), the character animation plays correctly, but the horse doesn't orientate itself or play the animation.

I have opened the animation files in 3DS max, and they work, so there's nothing wrong with the animation files themselves.

 

Given that the horse is facing the wrong direction, and the first stage of a creature animation is to rotate 180 degrees, it seems as though the animation is not being initialized at all.

 

My 'Update FNIS Behavior' dialogue is below:

 

 

FNIS Behavior V5.0.2 2/05/2014 4:11:13 PM
Skyrim: 1.9.32.0 -
Generator: D:\Steam\steamapps\common\Skyrim\Data\tools\GenerateFNIS_for_Users
Skeleton female: XPMS (242 bones) male: XPMS (242 bones)
Patch: "SKELETON Arm Fix"

Reading Bestialityrap V?.? ...
Reading FNIS V5.0.2 ...
Reading FNISBase V5.0.2 ...
Reading FNISCreatureVersion V5.0.2 ...
Reading FNISSpells V5.0.1 ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 alternate animations) ...
Reading SexLab V?.? ...
Reading SexLabCreature V?.? ...
Reading SexLabDefeat V?.? ...

All Anim Lists scanned. Generating Behavior Files....
Generating animationsetdatasinglefile.txt ...

Create Creature Behaviors ...
Reading Bestialityrap V?.? ...
Reading SCFollow V?.? ...
Reading SexLabCreature V?.? ...

( 9 paired, 0 kill animations) - 0_master usage: 3.0 %
1374 animations for 8 mods successfully included (character)
450 animations for 3 mods and 16 creatures successfully included.
1 Warning(s).

 

 

Any help would be appreciated.

 

 

post-413798-0-96394400-1399012317_thumb.jpg

Link to comment

I have a stranger problem in the way that it used to work perfectly (used enchantress with all the requirements), but suddenly they just went away without me uninstalling them.

 

And now... same problem. They face the wrong way and do nothing.

Link to comment

Well there is 3 horse animations in two of them the horse doesn't move very much only the character moves a lot.

 

As for the facing the wrong way there is I believe a hotkey to just rotate one character I think or maybe I am misremembering.

 

Anyways the facing the wrong way just happens sometimes, not sure why.

Link to comment

Well there is 3 horse animations in two of them the horse doesn't move very much only the character moves a lot.

 

As for the facing the wrong way there is I believe a hotkey to just rotate one character I think or maybe I am misremembering.

 

Anyways the facing the wrong way just happens sometimes, not sure why.

This is what Horse_Doggystyle_A2_S1 looks like:

gu4c2Zo.gif

The other 3 animations are fairly similar (but quicker), so its apparent that the animations are not playing.

EDIT: Other 3 animations in the Horse_Doggystyle_A2 sequence

 

I wasn't so much mentioning facing the wrong way as a problem as much as a potential symptom of whatever is causing the issue.

 

It would make sense if no creature animations were working (enable toggle creatures in SexLab, FNIS creature pack not installed etc), but all other creatures except the horse work. If it was only on one save, it could be a script issue, but it happens on old saves and new games.

 

Really confused as to what it could be.

post-413798-0-47358000-1399098069_thumb.gif

Link to comment

There is 3 possible animations sets that can play, that is one of them. The other two has the horse barely moving. I was merely saying it depends on which animation was pulled up on how much the horse moves. You can go check Panics forum thread for the other two horse ones he has Gifs up showing them in action.

 

Each animation set has 3 or more animations tied to it. I was talking about sets.

 

Does the horse animation always face the wrong way? If so then that could be a bug in sexlab.

 

Is horses selected in the SLNC menu and checked? Not sure if that would stop the animations or not.

 

What mod are you using to cause the sex to happen?

Link to comment

The horse always faces the wrong way for Horse_Doggystyle_A2; it orients correctly for Horse_Groping_A2 (though it doesn't seem to animate).

 

I have tried it both selected and unselected in SLNC, but I think that just affects sheathed/erect behavior (though I don't know if that works or not; I couldn't get sheathed/erect to work, so I usually just used EB's erect model and had permanently erect horses wandering around).

 

I've tried using both Matchmaker (which uses the bundled SexLab animations) and Creature Sex - Spell (which uses the Bestiality animations pack animations).

Note that initiating animations with every other supported creature using either of these methods works fine (no orientation issues/animations not starting etc).

 

Regardless of whether we manage to resolve the issue, I appreciate that you took the time to respond.

Link to comment

Yeah the horse BJ one the horse doesn't move much until the very end and even then it doesn't move a ton.

 

This could just be a bug with the new sexlab getting the orientation wrong on the one animation. You might actually want to report it as a bug in the sexlab 1.5x forum thread.

 

I have only had that animation come up twice and once it was reversed like yours and once it wasn't and I just chalked it up to a glitch.

Link to comment

@nutluck: I've had that behaviour also with SL 1.39.

I wonder if it is related to having 2 horse animations registered if you have EB. One DoggyStyle in \horse\animations and the SexLab ones in \horse\animations\SexLabCreature

Maybe SexLab is getting confused here?

 

Today I stumbled across this patch: Compatibility Fix For Sexlab And Eternalblack - Immersive Bodies - Skyrim Adult Mods - LoversLab

I have it installed but due to lack of horses in Dawnstar I had not yet a chance to see if it fixes the issue.

Link to comment

@nutluck Not so much concerned about the orientation as the animation not starting. Good idea, I'll post on the sexlab thread.

 

@JDough I don't have EB or EB gender installed, I just extracted files from EB gender and used the horse penis mesh/texture, so I don't imagine that EB is the problem

Link to comment

@nutluck Not so much concerned about the orientation as the animation not starting. Good idea, I'll post on the sexlab thread.

 

@JDough I don't have EB or EB gender installed, I just extracted files from EB gender and used the horse penis mesh/texture, so I don't imagine that EB is the problem

 

Well the animation is starting just not for the horse. Thats why i asked if you had the horse checked in nude creatures menu. By default I believe it is off.

Link to comment
  • 2 weeks later...

Hi all, I recently broke my really messy skyrim install trying to get ECE to work, so I've done a complete reinstall, this time using Wrye Bash; and after everything was setup, the horse animations worked. Not sure why it didn't work to start with, but it works now.

 

Thanks for all your replies.

 

Mods feel free to lock thread.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...