Jump to content
IGNORED

Why isn't my mesh changing from 0 to 100 weight?


gooboo

Recommended Posts

I've been working on a new outfit, and it's almost done, but I've run into a strange problem. When I was testing to see if everything was working properly, I realized that the mesh of the clothes weren't changing when I changed my npc's weight from 100 to 0, and I have no idea why. As you can see in the screenshot I named the meshes properly, (shirt_0 and shirt_1) but it's like the game isn't recognizing it. I already double checked to make sure I didn't accidentally use the same 100 weight mesh for both files, so that isn't the problem. I've also had this problem with an earlier piece I was working on, and I don't know why. I've modified vanilla meshes before, and the weights have worked just fine, but it seems like when I create a completely new armor/clothes type and add it into the game with the ck, it doesn't work. Am I doing something wrong in Blender, or is it the CK? I would appreciated any help I can get. 

 

post-89575-0-06576000-1398365448_thumb.jpg

 

post-89575-0-82078700-1398365466_thumb.jpg

 

Here it is at 100 weight. No problems. 

 

post-89575-0-48749500-1398365501_thumb.jpg

 

Here it is at 0. The head mesh changes, but the body doesn't. What am I doing wrong here?

Link to comment

They have the same meshes, as in the same amount of vertices, just shaped differently. The _0 version is skinnier and thinner than the _1 version, just like every other mesh I've done, but I don't know why it isn't working here. 

Link to comment

For whatever reason, replacing the _0 and _1 nifs one by one bugs them out in the game and only one weight is shown. Open the ESP with your item in the CK, go into the item's ArmorAddon entry, and reselect it as its model. That fixed it for me when I ran into this problem.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...