Jump to content

PC Exclusive Idle


Recommended Posts

EDIT: Released it. Grab it here


I'm disappointed by the lack of gender-separate idle animations, even more so by the lack of PC Exclusive animations (but the last is mostly bonus)


Currently, I'm researching a way to use an idle specifically used by the player (and gender-specific). Actually, I already got it to work (it only affects the PC), thanks to the conditions applicable to the idle. [Edit]I know it works because I used the f_masturbate.kf animation from sexout for testing (it's highly visible, and immediately distinguishable. Testing environment is Mojave Outpost Barracks, chock full of male and females)[/edit]


This is how I do it:

  1. Create a new Sibling above General Idles, so that other, more important animations (like being hit and activating stuff) takes priority
  2. Set the Animation Group Section as Idle
  3. Enable "Must return a file"
  4. Create conditions which basically say: "If it's PC", "if PC is female", "If not in combat", "if not in 1stP cam", "if not moving", "if not turning", "if not running", "if not sneaking" and "if weapon is holstered", then play animation


The problem I encounter are these:


  1. Using siidle.kf from "idleanims" folder, doesn't work. It looks like the animation is empty. Using the preview window with sunny smiles
  2. Moving to any direction will cause you to move to that direction indefinitely. The only way to stop is to turn (not strafe) to either left or right, which invokes the turning animation. Even then, the turning animation is played in slow motion until it ends, at which point the animation proper starts. It's very annoying


To that end, I'm thinking of adding one last condition: If IsLastIdlePlayed = mtidle, then maybe I can nail this. The problem is the fact that the usual idle itself doesn't exist as a value, and is pretty much mentioned nowhere.


Anyone can help me here? I'm tired of the usual idle. I'm thinking of using the "hand on hips" as my idle.

Link to comment

I ve Never tried this ,


But here is a Suggestion , Open Up Your Idle in NifSkope and Rename it The Value From "SpecialIdle" to "Idle"


1. Try placing and Using it from the Locomotions Folder

2. Try placing and Using it From Idles Folder


There Shuould Be some conditions For Sitting as Well "IsSitting=0" Perhaps



Link to comment

Nailed it.


I had to use Upper Body instead of Idle. This way, the whole problem is gone.


Well, I've only tested with f_masturbate2.kf. But so far works just fine. I can open my PipBoy (Readius) and generally move the usual way (even jumping), except every time I stop moving my character starts to masturbate. No problem with sitting and the likes.


I'll try to extract the talking idles (hands on hip), and maybe I can be a happier gamer.


I'll break the idles to 2 pieces of gender-specific anims. Perhaps it'll be useable, and people can start making awesome animations without affecting both genders.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use