Jump to content

Skyrim keeps switching to 3rd person mode by itself! WTF?


Recommended Posts

Okay, things are getting bloody annoying now lol... While trying to figure out whats broken the combat animations in Skyrim (either FNIS or Pinup Poser, maybe Minilovers... Who knows), the game has lovingly slapped me in the mouth with yet ANOTHER bug.


After creating another clean save from a different vinilla indoor location (breezehome), I found that it did nothing to fix the newly messed up combat. However! One thing it DID seem to do is mess the game up even more. Now, when I switch to FPS mode, within 1-30 seconds, the game just automatically switches back to 3rd person.


Has anybody else experienced this? How do you fix it?


I've done a fair bit of googling around, but as usual (contrary the "google is your friend" stigma), it revealed NOTHING but 1 or 2 people with the same problem, but no replies or no solution.


Some1 PLEASE help me out here. Im starting I wish I never installed all this stuff...

Link to comment

I noticed this thread and the related one you posted about the combat animation glitch. I remember when 1.8.151 first came out, FNIS was at 3.3.1, and there were several notes about combat animation issues. Upgrading to 3.3.2 seemed to fix those issues. You said you were up to date, but just verify which FNIS version you have, just in case. As far as this issue, I have seen animations get "locked". For instance, using the alchemy/enchanting/smithing activators, the animation would start, then back out as if I a had purposely backed out. Your problem here sounds very similar (although I never saw THAT particular issue). To fix what I was seeing, it was actually simple - used AP to have sex with an NPC, and the problem cleared up. I swear to you it worked ;) . Here's what I would suggest as well, use my clean sweep method for clearing issues with FNIS/FNIS mods. This seems to work well for most:


1) Uninstall all FNIS related mods (MLA, AP, Poser, etc).

2) Uninstall FNIS base and spells (if you have spells installed). You should not have to launch Skyrim to make a clean save, but it might not hurt (never had to do that myself).

3) Reinstall FNIS as per the normal instructions (version 3.3.2). Reinstall the spells (if you want them).

4) Reinstall all FNIS based mods with 2 special notes:


a) Install MLA LAST. Every time I had issues and reinstalled, if I didn't do MLA last, then I would have to do it all again.

B) IF you use AP as well, make sure you follow APs rules about removing the 3 files prior to running the FNIS generator. Some people forget about that, but it is important. Look in the (rambling) AP description (about mid-way down) for the 3 files.


5) Once MLA is installed and the 3 files removed per AP (if either is installed), then run the FNIS Generator for Users as per FNIS instructions.


Makes sure you run BOSS/verify your load order, then launch and see if the problem(s) still persist.

Link to comment

This is a post I probably can make a hundred times, because it hits users in so many forms.


Remember: FNIS is NOT as "fire and forget" mod !!!


Whenever Skyrim changes it's behaviors, we will run into all these kind of problems. Again and again. It's an issues of behaviors not matching.


The last 3 times Skyrim behaviors were changed:

- 1.6

- 1.8.145 (Beta)

- 1.8.151 (Final)


Whenever this happens, 3 thinga HAVE to match:

1) Skyrim version

2) FNIS version

3) other behavior files (in meshes/character/behaviors)


The 3rd point is MOST important. There are several mods out there which modify behaviors. Most popular: AP's mt_behavior.hkx. And if they are not updated, then you will see all kind of problems, even when Skyrim and FNIS do match.


Unfortunately, both users and modders providing these behavior changing mods tend to forget about these things. And then FNIS gets the blame.


So with the most recent "FNIS Behavior Files 3.3.2 fix1" I have added a warning to the generator, which will remind of other behavior files lingering arounf in the behaviors folder. Besides mt_behaviors.hkx. But probably I will now get dozens of questions what this warning is all about. :-/

Link to comment

Sorry I didn't mean to sound like I was slandering your mod, I'm actually really impressed with what it allows you to do, its just that I've suddenly been overwhelmed with a full-frontal assault of problems. The mod, in and of itself works fine, but something (Either FNIS or Pinup Poser, maybe even MLA) has cause the combat to become broken. I updated my Skyrim quite a few days before installing FNIS, so Im guessing its not because of something Bethesda has done to screw up the way your mod works in their latest update (like a modders game of cat & mouse). I hope that is the case though, because maybe that means when you release the next version, your behaviours will match the way Bethesda's newly updated ones work.


Interesting, so mt_behaviors is part of Animated Prostitution? I dont even have that mod. I must have tried it a long time ago, deleted it for whatever reason (forgetting to delete data files), then forgot I ever had it.


If you need any more information or details on my current setup, let me know, but I have the latest versions of Skyrim, SKSE & FNIS, and have only started using FNIS after the update, never before (apart from the time I installed it long ago, but uninstalled because it wasn't compatible with my older version of Skyrim IIRC).


I'll try the fix you mentioned and post back when I get the chance.

Link to comment

I don't feel slandered at all. I just felt I need to explain the current behavior situation in more detail, hoping the multiplier users at this site will spread the information.


But from your response I see that it is really hard to understand the full picture.


It's not "my behaviors (FNIS) that do not match the way Bethesda's newly updated ones work". The last 2 times it just took one day or so, until I had a Skyrim compatible version, with matching behaviors.


Its THE USER, who has forgotten either

  • that it's necessary to have a new FNIS version when Skyrim changes behaviors, or
  • that he has installed other mods (like AP, TK Dodge, ...) that have their own behavior files which can or WILL cause incompatibilities. Like those 2 I mentioned, which have NOT been updated for Skyrim 1.8

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use