Jump to content

Creating new script in Creation Kit error


Schoobli

Recommended Posts

(I launch Creation Kit through Mod Organizer)

So I'm trying to add a new script to an object, but when I do, I get this error:

Starting 1 compile threads for 1 files...
Compiling "zNewScript"...
<unknown>(0,0): unable to locate script zNewScript
No output generated for zNewScript, compilation failed.

Batch compile of 1 files finished. 0 succeeded, 1 failed.
Failed on zNewScript

I literally started to learn how to mod a couple of hours ago (spend most of the time googling this problem but my google-fu is weak) so I'm sorry if I'm missing something obvious! D:

 

I've tried verifying integrity/reinstalling CK without any success.

Here's a picture of what I'm doing wrong...
 

 

post-664676-0-75110900-1419446373_thumb.jpg

Link to comment

Hi, go in the Skyrim/Data folder, subfolder scripts.

Delete a scrips zNewScript.psx if present, go in sources, delete zNewScript.psc if present and re-try.

Small recommendation: when you create a script for an object (r an actor or a quest) name it as the main object with Script at the end (e.g. zMyActivatorScript). It will make more easy to find/rearrange in the future.

 

CPU

Link to comment

Thanks for the quick response! :)

 

None of my scripts appear anywhere in my scripts folder/sub folders although CK says "That script already exists, pleast choose a different name" if I try to make a new script with the same name.

 

I found the scripts in my MO/overwrite folder. Tried deleting them/moving them to the normal Skyrim scripts folder without anything changing.

[edit]

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...