Jump to content
IGNORED

Whore based Economy.


Sybian

Recommended Posts

So I need a little help getting this mod going. I've gone over it like a dozen times and can't figure out why it's not working. 

 

I really love the game and want to make an entire race of synthetic/biological hybrid sex dolls who out lived their race of advanced aliens (due to all the fucking) try to take over the galaxy, I want to add a few features to the mods that I love by making my own. So I decided I'd start small with a single economy mod. 

 

It's called "All You Need Is Whores" 

 

It's "Suppose" To add a trade policy with some flavor text that gives you a little bit of everything, alloys, food, minerals and energy for every trade point you have. So that way you can use Lustful void and just stack nothing but housing/brothels/milk farms/street prostitutes as your buildings, and have a race with only traits for sex jobs and milking. 

 

Here is my test file that I've spent a few hours working on and can't seem to get working. 

 

There is nothing fancy as I was just trying to start small but have already ran into the problem of it just not working. Any help would be wonderful! *-_-*

All_you_need_is_Whores.rar

Link to comment

 

19 hours ago, dekeche said:

Why are there two decimals in your conversion rate? energy=0.4.5 minerals - 0.2.5

Not going to test it right now, but I think that's going to be the main issue.

 

Ahhh, yeah that might be part of the issue. 

 

*edit. So checked the walkthough and they did the same thing, soooo... No idea, I'm just gonna round the numbers down and see if that works. 

Link to comment
On 12/14/2019 at 1:25 PM, Moncoyoule42 said:

Huh. I'm interested in where this goes.

It's not working at the moment, I'm very new at this, The mod folder and text doc goes in the same install path. But until I can get it working the files are just free for people to experiment with. 

Link to comment
12 hours ago, 420BonerHitler said:

It appears you didn't close the bracket for trade_policy in your policies txt, hopefully that fixes it.

Edit: Ok I edited the resource values to remove the extra decimals from the conversions and localization, and added the bracket and I can see the policy in game.

Can you copy paste where I didn't close the bracket? I'm looking at it but don't see it. >.< This was my first attempt at doing any stellaris modding with text files. 

Link to comment
On 12/17/2019 at 2:50 PM, Sybian said:

Can you copy paste where I didn't close the bracket? I'm looking at it but don't see it. >.< This was my first attempt at doing any stellaris modding with text files. 

Sorry i haven't been on in a while, you just need to add a bracket on a new line at the very bottom to close the trade policy bracket that is still open at the top:

 

trade_policy = { This is the open bracket I meant
    potential = {    
        NOT = { has_ethic = ethic_gestalt_consciousness }
    }

    option = {
        name = "trade_policy_whores"
        
        policy_flags = {
            trade_conversion_whores
        }
        
        modifier = {}
        
        AI_weight = {
            factor = 0    
        }
    }
And this is the one needed

Link to comment

Something's weird.

 

I've updated the file with the fix 420BonerHitler pasted to try the policy out, but I'm still not seeing it in the trade policy drop down. The mod is activated and it shows up on the launcher, but the policy just isn't anywhere to be found. Makes me wonder if there's a conflict with something else in my load order or if I'm looking in the wrong place.

 

SCModManager doesn't recognize any conflicts with the file so I have no idea.

Link to comment
  • 3 weeks later...
On 12/19/2019 at 10:29 PM, 420BonerHitler said:

Sorry i haven't been on in a while, you just need to add a bracket on a new line at the very bottom to close the trade policy bracket that is still open at the top:

 

trade_policy = { This is the open bracket I meant
    potential = {    
        NOT = { has_ethic = ethic_gestalt_consciousness }
    }

    option = {
        name = "trade_policy_whores"
        
        policy_flags = {
            trade_conversion_whores
        }
        
        modifier = {}
        
        AI_weight = {
            factor = 0    
        }
    }
And this is the one needed

Thank you so Much! I've been away for a bit but I'm going to make this into a mod if it's working now! Thanks again!

Link to comment
On 12/19/2019 at 10:29 PM, 420BonerHitler said:

Sorry i haven't been on in a while, you just need to add a bracket on a new line at the very bottom to close the trade policy bracket that is still open at the top:

 

trade_policy = { This is the open bracket I meant
    potential = {    
        NOT = { has_ethic = ethic_gestalt_consciousness }
    }

    option = {
        name = "trade_policy_whores"
        
        policy_flags = {
            trade_conversion_whores
        }
        
        modifier = {}
        
        AI_weight = {
            factor = 0    
        }
    }
And this is the one needed

I've added the lower bracket, however, I cannot get the mod working. What should be done with the top brackets?

Link to comment
12 hours ago, Moncoyoule42 said:

Do let us know in this forum when you get it working, the new Lustful Void mod is out and I'm eager to get back into Stellaris.

I really do wish to get it going. This would be my first mod and it's not very big. >.<

Link to comment

For some reason it does work for me, I see the new policy under policies: trade policy, which defaults to blank until i change it to All We Need Is Whores. The only change I needed was adding that right bracket on the end in the trade policy and I edited the trade conversion and localization to remove the extra decimal, but it even works with the extra decimals regardless.

Link to comment
6 hours ago, 420BonerHitler said:

For some reason it does work for me, I see the new policy under policies: trade policy, which defaults to blank until i change it to All We Need Is Whores. The only change I needed was adding that right bracket on the end in the trade policy and I edited the trade conversion and localization to remove the extra decimal, but it even works with the extra decimals regardless.

That is so weird, Although I have been having a lot of issues with non-steam mods running in my game. What do you use as an installer?

Link to comment
8 hours ago, 420BonerHitler said:

I use steam and haven't had any problems with non steam mods myself. Are you putting them in Documents\Paradox Interactive\Stellaris\mod and making sure it's enabled? That's all I can think of, the mod was drag and drop for me other than the fix I posted before.

Can you post a copy of the files? I'll see if I missed something. 

Link to comment

I've reinstalled it several times. I think the issue is on my side, however, as I've discovered by going through my mods that there are several bugs and issues currently causing other problems. So I guess I'll put it out there and see what others are able to figure out. 

Link to comment
On 1/14/2020 at 10:08 PM, Moncoyoule42 said:

Do let us know in this forum when you get it working, the new Lustful Void mod is out and I'm eager to get back into Stellaris.

Holy shit, I figured out the problem! All the new mods were not being properly turned on. The new launcher is a peice of hot... Ya know. Check out this guide video. 

 

 

OMG paradox... >.<

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...