Jump to content
Kimy

Devious Devices SE 5.1 (2021-03-24)

Recommended Posts

How do i get the physics working on the devices? The pear of anguish with the sign, chain, and bell, as well as all the other physics objects are just frozen in place. I have HDT-SMP for SSE 1.5.97 v2.11-30872-2-11-1578745910 installed and it's working with other mods.

Link to post
17 hours ago, coffeeink said:

Hello,

 

Maybe someone give me some hints, i'm currently stuck in the Setup. I have the issue that the Chains are not moving and connected etc.

 

I was searching this thread i found a lot of questios regarding this topic but some of the infos seems outdated or not valid anymore.

 

If my understanding is correct it should be as simple at this:

Install DD and SMP, run FNIS and you are done.

 

The setup: Newest version of SE and SKSE -> installed DD with "None"

DCL installed and loaded after DD

HDT SMP installed and working (clothes, hair etc is moving)

Used Body: CBBE with 3bbb

3BBB Slider installed and batche builded everything

FNIS was executed afterwards

 

I tried setting in FNIS MO the option "Devious ... LL" Patch but i'm not sure if this is working, i can't find the option if i run FNIS normaly

i was reading something about a 3bbb patch. Is there a link to it? Is it related to the chain problem?

 

regards

 

Don't use that FNIS patch, I have no idea where it comes from. I don't have it.

I've also configured FNIS as an executable and run it from MO2 that way, I don't use the Tools > FNIS in MO2.

 

Otherwise, that looks right.  I stopped using 3BBB, but when I was using it there were no new issues with the chains.

It is a known issue that we cannot fix that the chains do not all connect. They should move though.

 

Are you using DD 4.3?

Tried starting a new game? Does it work there?

If you have ddhotfix, remove it. It is only to remove physics when the cause of CTD can't be found or SMP is not installed.

Link to post
16 hours ago, loversusers said:

hi as a new user.  Does this work?

 

1. buy from  Laura's Bondage Shop

2. trade with follower to let them wear it

3. initiate animation with follower using eager npc.

 

I got this result.

1. the follower has arms not tied to devices, or hands showing it unbound position

2. no device animation playing.  still running regular slal animations

The NPC should get the arms tied in the back with an armbinder, or other appropriate poses. You may need to wait a few minutes or load a new cell before it applies.

There are not many bound animations. DD comes with some, but they don't seem to consistently play based on reports from others. Make sure you only have DD or ZAZ handling the animation filter. They both cannot have the option set.

Link to post
12 hours ago, lenxxx said:

How do i get the physics working on the devices? The pear of anguish with the sign, chain, and bell, as well as all the other physics objects are just frozen in place. I have HDT-SMP for SSE 1.5.97 v2.11-30872-2-11-1578745910 installed and it's working with other mods.

Make sure you don't have DD hotfix installed, and try testing on a new game.

Link to post
10 hours ago, zarantha said:

Don't use that FNIS patch, I have no idea where it comes from. I don't have it.

I've also configured FNIS as an executable and run it from MO2 that way, I don't use the Tools > FNIS in MO2.

 

Otherwise, that looks right.  I stopped using 3BBB, but when I was using it there were no new issues with the chains.

It is a known issue that we cannot fix that the chains do not all connect. They should move though.

 

Are you using DD 4.3?

Tried starting a new game? Does it work there?

If you have ddhotfix, remove it. It is only to remove physics when the cause of CTD can't be found or SMP is not installed.

Thanks for clarifying about the chains issue, been looking around for solutions. Does the picture below, look normal?

 

Spoiler

TIM截图20200422204900.png

 

Link to post
1 hour ago, dzpliu said:

Thanks for clarifying about the chains issue, been looking around for solutions. Does the picture below, look normal?

 

  Hide contents

TIM截图20200422204900.png

 

Yes, sadly, that's normal until we can find someone with the skills to redo the meshes.  It's the same with other wrist bindings and the prisoner chains are in a similar situation.

Link to post

I've been messing around with converting the Petsuit to CBBE bodyslide and made pretty good progress on it. Here's what I've got so far

 

Pet Suit Bodyslide v0.1.7z

 

Known issues-

 

Some minor deformities, especially in the right shoulder - I'm probably gonna need to delete some morph sliders and correct others. Tried to fix some of these, but the edge seams made it difficult. May try exporting to Blender to seal seams.

 

Morph file _0 isn't being recognized - Currently, setting the weight slider to lower than 1 doesn't shrink the Petsuit to fit, Probably because the morph files are too different. I suspect minor deformities are to blame. May not be a issue, depending on the body type.

 

 

The process of fixing this proper may take quite some time, so I decided to post what I have now.

Link to post
22 hours ago, zarantha said:

Yes, sadly, that's normal until we can find someone with the skills to redo the meshes.  It's the same with other wrist bindings and the prisoner chains are in a similar situation.

That's good to know, They look really great in Oldrim.

 

Is there a way to disable chains? It's looks strange with them floating in thin air.

Link to post
3 hours ago, crayne said:

That's good to know, They look really great in Oldrim.

 

Is there a way to disable chains? It's looks strange with them floating in thin air.

You could probably open the meshes in nifskope and just delete the chains. I'd backup the file first in case you run into problems.

Link to post

Hello I encountered a strange problem (check the picture). I haven't been using any devices for a while in my playthrought so I have no idea when the problem started. From what I checked the error is on all devices (belts, corsets, straitgh jackets, etc.)

What I checked:

- not a bodyslide error. I have rebuilded and the problems persists. If I start a new game the devices are shaped correctly

- devious devices body morphs are greyed out

- running cursed loot disabled the body morphs problem still persists

 

Any idea?

 

image.png.0245511188fe4f33a71db339cf9c92a4.png

Link to post
18 hours ago, xseno said:

Hello I encountered a strange problem (check the picture). I haven't been using any devices for a while in my playthrought so I have no idea when the problem started. From what I checked the error is on all devices (belts, corsets, straitgh jackets, etc.)

What I checked:

- not a bodyslide error. I have rebuilded and the problems persists. If I start a new game the devices are shaped correctly

- devious devices body morphs are greyed out

- running cursed loot disabled the body morphs problem still persists

 

Any idea?

 

It looks like a mod is increasing the pregnant belly morph but your characters outfit/body doesn't support the specific slider it is increasing, but the belt does have the slider. You could try playing around with the sliders in racemenu to check.

Link to post
On 4/22/2020 at 4:03 PM, zarantha said:

Yes, sadly, that's normal until we can find someone with the skills to redo the meshes.  It's the same with other wrist bindings and the prisoner chains are in a similar situation.

I managed to fix and add SMP to the harness wrist bindings, it seems to work fine here but I've not extensively tested them... I might clean them up a bit later as there's still the old UUNP hands in there (it's not very noticeable however) and try to make the physics a bit less rigid.

 

About the prisoner chains, aren't those all fixed in the files you linked here? Thanks for those!

 

DDX HarnessGloves SMP.7z

Link to post
4 hours ago, guns said:

when will  this be compatible with skse 2.0.17 1.5.97

I feel like this question gets brought up nearly every page since the update.

 

If people take the time to browse the previous couple of pages rather than leave a comment with questions, they can get answers to their questions without waiting for them.

Link to post
2 hours ago, NobodyImportant33333 said:

I feel like this question gets brought up nearly every page since the update.

 

If people take the time to browse the previous couple of pages rather than leave a comment with questions, they can get answers to their questions without waiting for them.

It does. sometimes two or three times on the same page. I've thought about hot keying a response.

Link to post
On 4/23/2020 at 4:30 PM, xseno said:

Hello I encountered a strange problem (check the picture). I haven't been using any devices for a while in my playthrought so I have no idea when the problem started. From what I checked the error is on all devices (belts, corsets, straitgh jackets, etc.)

What I checked:

- not a bodyslide error. I have rebuilded and the problems persists. If I start a new game the devices are shaped correctly

- devious devices body morphs are greyed out

- running cursed loot disabled the body morphs problem still persists

 

Any idea?

 

image.png.0245511188fe4f33a71db339cf9c92a4.png

This is usually a body issue,but it could be the outfit doesn't support it like evilbbq mentioned. If you're naked except for the belt, is your belly still flat?

If it is, try rebuilding your body, make sure morphs are checked.

If it's not, it's an issue with the outfit. You can try conforming the sliders and copying weights to the outfit from a reference shape.

Link to post
7 hours ago, evilbbq said:

I managed to fix and add SMP to the harness wrist bindings, it seems to work fine here but I've not extensively tested them... I might clean them up a bit later as there's still the old UUNP hands in there (it's not very noticeable however) and try to make the physics a bit less rigid.

 

About the prisoner chains, aren't those all fixed in the files you linked here? Thanks for those!

 

DDX HarnessGloves SMP.7z 1016.16 kB · 2 downloads

They are in there, but they're still not connected. We only managed to add physics to them.

 

Pfiffy and I have been working on the damn things for over a year, and that's the best we've managed. If you're able to do something with them, that would be awesome. I think we're both sick of looking at them. I know I am. :)

Link to post
7 hours ago, evilbbq said:

I managed to fix and add SMP to the harness wrist bindings, it seems to work fine here but I've not extensively tested them... I might clean them up a bit later as there's still the old UUNP hands in there (it's not very noticeable however) and try to make the physics a bit less rigid.

 

DDX HarnessGloves SMP.7z 1016.16 kB · 3 downloads

 

Looks a lot better, but still not connecting the left and right for me. I think you may need to have the kinemetic / base bones on a higher up bone. The first link or two of the chain is not moving.

 

I really wish I knew why the heretic stuff works in LE but not SE. Maybe it was something PE did that SMP doesn't do.

 

 

Link to post
2 hours ago, zarantha said:

 

Looks a lot better, but still not connecting the left and right for me. I think you may need to have the kinemetic / base bones on a higher up bone. The first link or two of the chain is not moving.

 

I really wish I knew why the heretic stuff works in LE but not SE. Maybe it was something PE did that SMP doesn't do.

 

 

Do you mean connected as in the chain connecting the left glove to the right? Because I don't remember it ever doing that in LE either.

 

The first couple of links of the chain are moving together because they don't have individual bones assigned to them and they never had, if you check the LE models' bone animation weights you'll see; I think the physics settings in LE was just much better which is why it wasn't really noticeable.

 

I might see if I can manage to increase the amount of bones in the chain and improve the physics file... But I don't have much experience with this so no promises!

Link to post
1 hour ago, evilbbq said:

Do you mean connected as in the chain connecting the left glove to the right? Because I don't remember it ever doing that in LE either.

 

The first couple of links of the chain are moving together because they don't have individual bones assigned to them and they never had, if you check the LE models' bone animation weights you'll see; I think the physics settings in LE was just much better which is why it wasn't really noticeable.

 

I might see if I can manage to increase the amount of bones in the chain and improve the physics file... But I don't have much experience with this so no promises!

It's been so long since i played LE, and I never could get DD working well on my old pc. If they didn't connect together, I wouldn't worry about it then. Just seems like they should.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...