Jump to content
Kimy

Devious Devices SE 5.0 (2020-11-26)

Recommended Posts

Alright, it's a few days now i try to solve the issues. I played SSE for sometime now and most of the mods i enjoyed, even those that weren't ported from Oldrim so SSE worked just fine with minor tweaks, like my temptress race.

 

However ass soon as i tried to play mods that were requiring DD it was starting to be a mess. First attempt with Angrim Apprentice and after Vortex insulted me a few time i just removed both and played mods that weren't requiring DD ...

 

Now i want to try Sanguines debauchery and once again DD is required like for many mods and it makes them simple UNPLAYABLE on SSE. It was hard to figure what was going wrong really but with SD+ at least i had a hint. First when i'm enslaved cuffs are added to my character before being taken away the following second, meaning i guess they weren't locked and the game removed them with the rest of the inventory. And then from time to time i get this messageIA9eM3A.jpg

that clearly means that mods related to DD will just not work on my current config cause well, i don't know?

 

So yeah i installed it a few time, cause the select version as "none" of course got me, as i took the last version available, like almost anybody i guess? So i reinstalled with it correctly. I ran Fnis. I installed  SSE Engine Fixes which is a pain to install too, cause you have a vortex installer version but in fact noooo it's manual install only ...

So it's checked too but in the end i simply continue to have this error.

 

Sexlabs works perfectly, SL aroused too, scent of sex works fine too, same for SoS, in fact every mod on my Skyrim works just perfectly except all those that are bound to devious device.

So i'd really wish to know what is the issue, apparently there are quite a lot of issues with this SE version from browsing this topic but i can't find any answer to the issue (except "wait for next version that isn't for tomorrow"). So is there a way to really make it work? Or someone should edit this thread https://www.loverslab.com/topic/94228-sse-conversion-tracking-oct-4-5756/ to remove the compatibility status for DD and all the mods requiring it. Cause i'm really bored to go there, see a mod tagged green and in the end that won't work cause requiring DD that is not working on SSE at all. (Something that won't load anymode correctly and bring fatal errors is not working in my standards)

 

Link to post

Just installed this, all works well except for the fact that bound animations don't work, for some odd reason, if the character has her arms bound behind me, no animations will play, NPC's will reset on my location and then just walk away. Not really sure what I did wrong, suggestions?

Link to post
12 hours ago, Shalassan said:

DD that is not working on SSE at all.

At first i don't understand any of your words in thread. Because i say: you don't need convert DD to SSE because on first page of this thread is SSE converted fully worked. DD 4.3a AIO (all in one) installer. You don't need load DDA, DDI, DDX from LE section and convert through CAO. Also even if you do it: DDI will not work because in converted version of DD is reworked scripts for SSE and ddl is converted to SSE version what CAO never do.

 

PS: For me DD works by simply install in Vortex from this thread download with first try in SSE.

 

Link to post
10 hours ago, LazyVegetable said:

Not really sure what I did wrong, suggestions?

If you are in straitjacket similar outfits in that version is DCL animation filter bug - NPC not do sex with you. (from DCL) If you use no DCL - have no clue.

Link to post

Oh yes you are right, it do not works cause i'm too stupid to install SSE version that are on this thread but used the oldrim ones ...

Come on ... What i mean is currently all my mods works perfectly even some that i ported myself. All except SSE version of Devious Device. But if it works for you then i guess it's fine, too bad for those that are not so lucky.

And i guess the conversion track thread is wrong too when they say

"📝Notes for Devious Devices SE:

Devious Devices is a bit tricky to work with. Make sure you have:
-  SSE Engine Fixes installed and up to date
- The correct DLL for your version of SKSE; for 2.0.17-19, choose the None option in the installer
- controller CTD fix by Boulo_92 if you need that
- DDHOTFIX if you don't use HDT-SMP or have CTD problems
- The latest CBBE BodySlide files if you want to rebuild with those"

 

Because apparently it works so well that you have it work out of the box on vortex, not even needing all of this or to run Fnis ... >.<

 

Be serious, this mod is a nightmare to install, i remember it was already a mess in 2012 on Skyrim LE and it's even worst now, things go out of control without even knowing why, and uninstalling it completely before reinstalling leads nowhere as it seem it leaves files somewhere to corrupt the new fresh install. Feels like the driver issue on windows 98 when you had to format your drive if you installed a wrong driver cause you could never remove it ...

 

That's nice they made a all in one pack, that's one step to make it easier to use, but sadly most of the issues remains. And as we are talking about how it works or not. You have lot of tricky choices in the installer. Like offering to installe CBBE, CBBE SE or UNP for the bodies. As we are on SSE only CBBE SE will work right? Why offer a choice like this then? Are there more traps in this installer? At this point i'm really wondering what is going wrong on the process.

Link to post
3 hours ago, Shalassan said:

Oh yes you are right, it do not works cause i'm too stupid to install SSE version that are on this thread but used the oldrim ones ...

Come on ... What i mean is currently all my mods works perfectly even some that i ported myself. All except SSE version of Devious Device. But if it works for you then i guess it's fine, too bad for those that are not so lucky.

And i guess the conversion track thread is wrong too when they say

"📝Notes for Devious Devices SE:

Devious Devices is a bit tricky to work with. Make sure you have:
-  SSE Engine Fixes installed and up to date
- The correct DLL for your version of SKSE; for 2.0.17-19, choose the None option in the installer
- controller CTD fix by Boulo_92 if you need that
- DDHOTFIX if you don't use HDT-SMP or have CTD problems
- The latest CBBE BodySlide files if you want to rebuild with those"

 

Because apparently it works so well that you have it work out of the box on vortex, not even needing all of this or to run Fnis ... >.<

 

Be serious, this mod is a nightmare to install, i remember it was already a mess in 2012 on Skyrim LE and it's even worst now, things go out of control without even knowing why, and uninstalling it completely before reinstalling leads nowhere as it seem it leaves files somewhere to corrupt the new fresh install. Feels like the driver issue on windows 98 when you had to format your drive if you installed a wrong driver cause you could never remove it ...

 

That's nice they made a all in one pack, that's one step to make it easier to use, but sadly most of the issues remains. And as we are talking about how it works or not. You have lot of tricky choices in the installer. Like offering to installe CBBE, CBBE SE or UNP for the bodies. As we are on SSE only CBBE SE will work right? Why offer a choice like this then? Are there more traps in this installer? At this point i'm really wondering what is going wrong on the process.

There are several gotchas that can break DD. The conversion tracking post has the fixes for most common issues

Unfortunately, I can't see the error in your screenshot, because it didn't come through in your previous post. Could you please type out your error, try attaching it again, or try linking your image instead?

 

This is what I see:

Spoiler

image.png.8a7502d9c1a8b3653113f0558cfcf508.png

 

Since I still don't know exactly what issue you are seeing, please start here:

New troubleshooting post, including conflicts and bodyslides

https://www.loverslab.com/topic/99700-devious-devices-se-43/?do=findComment&comment=3077930

 

The one comment on SD+ equipping/unequipping devices, that is likely coming from SD+, not DD.  I haven't seen that issue in the SD+ SE version myself when I was enslaved, so it may very well be something specific to your install. DD is only involved because it has the scripts and other assets, but it will not do anything on it's own (it's a framework). It needs another mod (such as SD+ or DCL) to call those scripts. What is possibly happening here is a timing issue, there's nothing we can do for that that I know of. Some mods (I don't know if SD+ is one) will remove equipped items to add its own items, as long as the items aren't registered as quest items.

 

For the questions on bodies, we have CBBE and CBBE SE because originally people were using the LE CBBE still - all you had to do was optimize the meshes for SE. Then CBBE SE was released, and it was a complete rebuild of the body, not a port. So the CBBE and  CBBE SE bodyslides are not compatible. Which one you use depends on if you download CBBE from the SE downloads on the Nexus (this is CBBE SE) , or if you self converted CBBE from the LE side of the Nexus (this is CBBE). Both 'work', you'll just have clipping if you choose the wrong one.

 

Summary:

  • Some things, like the chains or outright incompatibility with some mods can't be completely fixed by us.
  • What we can fix has been done on an ad hoc basis after the AIO installer was released, so those patches are still loose.
  • There are literally 3 bodies to choose from since it is possible to use LE CBBE with SE. Bodyslides for additional bodies (3BBB and BHUNP) are not yet included. This may change if they become more popular.
  • Chains - they should have physics, but because of how HDT SMP works most will not 'connect'. Ankle chains are the exception, but won't 'connect' until you save, exit the game, and reload. So what you're looking for is simply do they conform to the body when applicable, and are they moving? If they're stiff, it's either an issue with HDT SMP or you need the DD/DCL/ZAZ patches I linked in the post above.
  • If you don't install HDT SMP, then you must install DDHotfix, or you will experience CTDs with some chains. This will replace the models that cause  CTDs with a different model that will not cause a crash.

If you are able to wait longer, a lot of the loose fixes should be integrated into DD 5.0 when it comes out of beta. DD 5.0 will require a new game, or a game where DD has not yet been installed. But it is also adding a lot more content, so there maybe other bugs that aren't caught in the beta.

Link to post
2 hours ago, GGQWPP said:

Hello, i am vortex user and i found an error shown as below:

image.png.3807dbe32df4d7d31040ac7e16afe1e4.png

And i am always resulting CTD recently, i dont know if this cause the problem. Can someone help?

When you installed the DD AIO from the download page, did you select 'none' in the installer? This will install a 2.00.17+ compatible DLL

If you installed DDa, DDi, or DDx separately, remove them. The SE download contains all three mods, so separate mods are LE versions.

 

When are you getting a CTD?

If it's when chains are equipped, is HDT SMP installed?

If it's on launch, it's likely not this mod. Have you installed a LE mod recently that has a BSA?

Link to post

Oh god, you don't see the pic >.<

 

https://i.imgur.com/IA9eM3A.jpg here it is.

 

I got this message from time to time, and it may be related to my save. Cause i was curious and started a new game and didn't get this one. (At least not for the few minutes i tried) But this message is a bit tricky to display as it happens really randomly, sometime i don't have it for hours of play and sometime it pops 3 times in a row ...

 

I did try to reinstall it from scratch, even using the "repair" feature of SL but it's even worst, preventing my game from loading if i do that.

Link to post
7 minutes ago, Shalassan said:

Oh god, you don't see the pic >.<

 

https://i.imgur.com/IA9eM3A.jpg here it is.

 

I got this message from time to time, and it may be related to my save. Cause i was curious and started a new game and didn't get this one. (At least not for the few minutes i tried) But this message is a bit tricky to display as it happens really randomly, sometime i don't have it for hours of play and sometime it pops 3 times in a row ...

 

I did try to reinstall it from scratch, even using the "repair" feature of SL but it's even worst, preventing my game from loading if i do that.

I  actually haven't seen that before. It looks like it will just be that save, based on what I found here:
https://www.loverslab.com/topic/43953-devious-devices-error-help-please/

 

If you want to try rescuing that save, I'd recommend uninstalling again, then load your save game. Wait a bit for everything to settle after the load, then save again.

Load that new save with DD uninstalled in ReSaver / Fallrim Tools and search for Devious Devices - [Assets | Integration | Expansion] and remove the scripts, unattached instances, and undefined elements. Close out of Resaver and save when prompted.

This should now be the newest save when you start the game again. I like to go to my save folder and put the unmodified  save into a temp folder to be sure since they have the same name in game.

In game, load the modified save (this should work unless removing DD was too destructive), wait for everything to settle, then save again. This should be a clean save without DD.

Add DD back to the mods, then try loading the cleaned save and see if it's working now.

 

If it's still not working, then you will likely need to wait until you're ready to start a new game to try playing with DD.

 

Link to post
11 hours ago, Elsidia said:

If you are in straitjacket similar outfits in that version is DCL animation filter bug - NPC not do sex with you. (from DCL) If you use no DCL - have no clue.

The outfits it happens is in any outfit that binds my hands. Behind, neck-level, in front, any animation that binds hands(couldn't test leg bindings yet) cause animations to not work. It's the only reason why I am confused

 

Also what's a DCL? You mean DLC?

Link to post
32 minutes ago, LazyVegetable said:

no way for those animations to work unless I disable something?

As i just now test for DCL is you are locked in cuffs, consensual animations is blocked. But still work DCL rape, solicitation, sex work animations. If you want just test sex animations then in zaz 8 animation system turn off sex animation filter and you can see any animation. As for other mods animations can't say how it works. Also can try turn off DD animation filter for other mods - then it uses any animation even it's looks silly into cuffs.

 

UPD: DD animation filter works only for other mods (if it works). DCL uses own animation filter build into DCL and ignore DD animation filter settings.

UPD2: Also DCL animation filter works ONLY on animations what is started by DCL mod. Other mods animations not use this filter.

Link to post

Well i gave a try to resave and don't know if it will work but doing as you said i had something strange.

 

https://cdn.discordapp.com/attachments/506563931704393728/763131751240957982/resave.jpg

 

The only objects related to DD are those and i can't seem to remove them, cause they are apparently not unattached or undefined. That would mean there is still a mod around that use these internally? And that could be the main issue?

Link to post
6 hours ago, Shalassan said:

Well i gave a try to resave and don't know if it will work but doing as you said i had something strange.

 

https://cdn.discordapp.com/attachments/506563931704393728/763131751240957982/resave.jpg

 

The only objects related to DD are those and i can't seem to remove them, cause they are apparently not unattached or undefined. That would mean there is still a mod around that use these internally? And that could be the main issue?

Yeah, I think those are the issue. I don't have any of the strings under "0" on a working save so I'm don't know where it came from. But this is also a new game with nothing running yet.

Spoiler

image.thumb.png.018bd2e019a2eb8d5d69950108940eb9.png

 

If you right click on the strings, do you get an option to delete? I'm guessing not? Seems to be pretty hit or miss on if you can.

 

Found another suggestion to wait at least 15 real time minutes in game before saving with the mod uninstalled. It also suggested the load/wait/save be repeated at least 3 times to make sure skyrim had a chance to terminate the threads themselves. If they're still there after all that, then those strings are baked in and we won't be able to remove them.

 

Link to post
17 hours ago, zarantha said:

When you installed the DD AIO from the download page, did you select 'none' in the installer? This will install a 2.00.17+ compatible DLL

If you installed DDa, DDi, or DDx separately, remove them. The SE download contains all three mods, so separate mods are LE versions.

 

When are you getting a CTD?

If it's when chains are equipped, is HDT SMP installed?

If it's on launch, it's likely not this mod. Have you installed a LE mod recently that has a BSA?

I just see the problems of the error. As you suggested, I have installed the 2.00.16 compatible DLL and I now selected the none option. Now the error disappeared. Thanks a lot!

Link to post

Guys, i need your help.

I have the issue that restrictive boots, pony boots and so on, from devious device didnt work anymore.

After i made a new game the message that the devices couldnt be euqipped during game because of missing netimmerseoverride appears.

 

worked with my old gameplay which i erased sadly. I have Racemenu, racemenu patch and racemenu highheel fixes. In the MCM of RMHH is netimmerseoverride listed, but i dont know why devious devices dont find it. 

as i said, it worked with previous gameplay. cant figure out why it isnt working anymore. 

 

hope you can help me

 
  •  
Link to post

Is there a version of the Iron Collar (Short/Medium/Lengthy/Long Chain) (the ones that look like stereotypical prisoner/slave manacles) without the chains? I love that look.

 

What the game labels as the plain Iron Collar / Rusty Iron Collar seems to use a different model (sort of a thin donut shape).

 

Sorry if it's obvious, I can't seem to find it. Thanks.

Link to post

 have an odd question. since 5.0 is on Beta on LE right now (for obvious reasons), will the SE users get a chance to have an SE beta as well, so we can also participate and help out iron out issues (which could be helpful to both SE and LE imo) ? or is the beta only to the privilege of LE users ?

 

will any of the changes / updates between 4.3 and 5.0 be posted here ahead time, so that users can comment on the changes at least in this thread ? i know that there are some changes i suggested many moons ago  for both DD and DCL (minor of course) and suggestions from other users, that i would love to know if they are incorporated or not, as well as any changes to the Device Hiding system (or if it is more intuitive than it currently is right now).

 

thanks

Link to post
4 hours ago, Buridan said:

Is there a version of the Iron Collar (Short/Medium/Lengthy/Long Chain) (the ones that look like stereotypical prisoner/slave manacles) without the chains? I love that look.

 

What the game labels as the plain Iron Collar / Rusty Iron Collar seems to use a different model (sort of a thin donut shape).

 

Sorry if it's obvious, I can't seem to find it. Thanks.

i know i love the Iron Collar's thin design, as it is simple and elegant in its own way, but i definitely agree that there should be a normal version of the collar with the chain lengths, just without the chain length, or even with maybe 2 or 3 dangling links only. if only there was a way to have the chain length provide some type of functionality or interaction. would be fun if it could be used by others in some way lol

Link to post
7 hours ago, YojimboRatchet said:

 have an odd question. since 5.0 is on Beta on LE

As a scripter, but not into DD, DCL team i can say: it's complicated. While 1 team works on LE, fixes small bugs, SE team need recompile all mod to get worked. And when LE team makes small fixes, SE team will need recompile all SE version again. It's Sisyphus work for SE team. Also in recompile process will be added SE version new bugs.

 

Link to post
17 hours ago, adle said:

Guys, i need your help.

I have the issue that restrictive boots, pony boots and so on, from devious device didnt work anymore.

After i made a new game the message that the devices couldnt be euqipped during game because of missing netimmerseoverride appears.

 

worked with my old gameplay which i erased sadly. I have Racemenu, racemenu patch and racemenu highheel fixes. In the MCM of RMHH is netimmerseoverride listed, but i dont know why devious devices dont find it. 

as i said, it worked with previous gameplay. cant figure out why it isnt working anymore. 

 

hope you can help me

 
  •  
  •  

Sounds like you've got LE versions overwriting  the SE versions. All you should have is the DD SE AIO installed, if you downloaded LE versions of those mods, uninstall them.

The DD SE version has script fixes for the nio messages for boots.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...