Jump to content

Recommended Posts

4 hours ago, Dude2000 said:

I just started the mod midwood isle: https://www.nexusmods.com/skyrimspecialedition/mods/28120

which seems to be very interesting and of high quality. It apparently defines a new race which unfortunately does not get schlongs assigned. Is there an easy method to assign schlongs to a new race of a mod or could someone skilled enough provide a patch or something?

 

Thanks in advance!

I've never tried this, and I'm only basing this on what I can see inside the plugin file.  You'd need to create a patch or edit the SOS addon you want to use.

1. Add Armor Addon entry to define the race and mesh model it will use for the genitals

2. Edit the single Armor entry for Genitals and add an Armature entry that points to the Armor Addon created in step 1.

3. Edit the "CompatibleRaces" FormID to include an entry for the new race

4. Add a Texture Set entry to point to the textures to be used for the genitals.

Share this post


Link to post
17 hours ago, 4nk8r said:

I've never tried this, and I'm only basing this on what I can see inside the plugin file.  You'd need to create a patch or edit the SOS addon you want to use.

1. Add Armor Addon entry to define the race and mesh model it will use for the genitals

2. Edit the single Armor entry for Genitals and add an Armature entry that points to the Armor Addon created in step 1.

3. Edit the "CompatibleRaces" FormID to include an entry for the new race

4. Add a Texture Set entry to point to the textures to be used for the genitals.

Wow, is it that involved? I should add that it is actually possible to successfully assign schlongs ingame to targeted NPC of that race. Therefore, I was hoping there is some way to tell SOS to include this race for automatic equipping.

Share this post


Link to post
4 hours ago, mastert3318 said:

Is there a patch to make SoS work with SAM Light? I swear I've seen one mentioned somewhere before.

If you want to use that male replacer I posted a bit earlier, it is based on SAM but adjusted to use SOS.

 

Check vectorplexus.com for SAM Light patches for SOS SE.

Share this post


Link to post
2 hours ago, Dude2000 said:

Wow, is it that involved? I should add that it is actually possible to successfully assign schlongs ingame to targeted NPC of that race. Therefore, I was hoping there is some way to tell SOS to include this race for automatic equipping.

That was the "automatic" way, meaning the game has the info (in the plugin) ahead of time so you don't have to be involved (in game).  You might be able to use something like SIGE or similar to insert the race into the FormID list stored in your game data for the addon you want used by that race?  My understanding of this falls apart at this point, so I'll let others step in and correct me.

Share this post


Link to post

I have HDT-SMP, do I need both the original mod + the HDT-SMP one? Confused because they both let me choose options and then file conflicts arrive, but I think I need both bc the original has more like the SOS shop and the hair options and is a larger file size.

 

Wording is confusing, I currently have both installed and then just chose to load the SOS HDT_SMP accessory after the SOS and then the skeleton after that.

Share this post


Link to post

I need assistance. Using the mod organizer, I install the sos se first and then the tempered skin se full. But in the game when I take out my clothese games frezzes, crash and kick me out. I try so much things, for example: change the load order (putting the sos before the xmp eskeleton but the game crash at the begging. The only thing that work was not using the SOS only the tempered skin but that is not what I wanted. Anyway if you know any ideas I will be grateful.

Share this post


Link to post
2 hours ago, Kamuitat said:

I need assistance. Using the mod organizer, I install the sos se first and then the tempered skin se full. But in the game when I take out my clothese games frezzes, crash and kick me out. I try so much things, for example: change the load order (putting the sos before the xmp eskeleton but the game crash at the begging. The only thing that work was not using the SOS only the tempered skin but that is not what I wanted. Anyway if you know any ideas I will be grateful.

I already told you in the thread you made the other day.

On 10/15/2020 at 11:38 AM, Just Don't said:

Sexlab, SOS and Tempered skin for SOS are totally compatible, as long as you install the version made for SE. And you need to install/give priority to Tempered skin over SOS (otherwise you won't get the tempered skin textures as your game will use the default SOS ones).

 

Your issue seems to be the skeleton. SOS comes with some humanoid skeletons (used by the game to animate the actors), but the SOS skeletons are famously outdated. You should use XPMSSE as your skeleton mod (at least for the humanoid actors). So install XPMSSE and make sure no other mod is overwriting it (only exception is MNC if you use creature mods as MNC will provide better skeletons for creature actors).

 

Your issue is likely the skeleton. Don't use the one from SOS, disable that setting during install. And then make sure XPMSSE is below SOS in the left panel of MO (changing the loadorder won't solve the fact that SOS is overwriting XPMSSE in the left panel, where the game assets like the skeleton files are).

 

Share this post


Link to post
10 hours ago, Just Don't said:

I already told you in the thread you made the other day.

 

Your issue is likely the skeleton. Don't use the one from SOS, disable that setting during install. And then make sure XPMSSE is below SOS in the left panel of MO (changing the loadorder won't solve the fact that SOS is overwriting XPMSSE in the left panel, where the game assets like the skeleton files are).

 

Thank you a lot

 

Share this post


Link to post

Having this issue according to NetImmersiveFramework log.

[18 Oct 2020 21:18:51.482] Unhandled native exception occurred at 0x7FFC9C9FF1F9 (SchlongsOfSkyrim.dll+F1F9) on thread 2924!

The only mods I have overwriting XPMSE are MNC and ABC (which has to overwrite them). This Literally randomly started occuring AGAIN when I was configuring my SMP 3BBB body. Just all the sudden, Poof. My save stops working. I disabled the SOS skeletons, and enabled the XPMSE SOS patch on their respective FOMODS. Reinstalling XPMSE fixed this last time, but now, it's been to no avail. I get a crash on my load screens everytime. Any help would be appreciated. If I need to provide a crash log, I can.

 

EDIT: Literally randomly fixed itself for the time being

 

Nice while it lasted.

 

Managed to get it working. Not sure what exactly was causing the issue, just glad it's seems stable now.

 

Share this post


Link to post

Does the HDT patch only apply to the balls? I heard that the file path was wrong, I moved the xml into 3BBB's plugins folder and added MaleSchlong to defaultbbp (since 3bbb is loaded after), but I'm still not seeing any change in physics whatsoever

Share this post


Link to post
On 10/17/2020 at 8:23 PM, Just Don't said:

I already told you in the thread you made the other day.

 

Your issue is likely the skeleton. Don't use the one from SOS, disable that setting during install. And then make sure XPMSSE is below SOS in the left panel of MO (changing the loadorder won't solve the fact that SOS is overwriting XPMSSE in the left panel, where the game assets like the skeleton files are).

 

I have the same problem but the difference is I have done everything way you said it should be yet it still CTD's.

Share this post


Link to post
56 minutes ago, allenson321 said:

I have the same problem but the difference is I have done everything way you said it should be yet it still CTD's.

Doing everything as I said is very vague here. I'm just referring to two mods (SOS and XPMSSE) in a particular setup (using MO as mod manager). I don't know if you're also using MO or if you have other mods providing other obsolete humanoid skeletons (or if you're using NPCs with unique body/skeletons). I'm not even sure if your CTD is exactly the same as the other user. So as I lack all that information, I won't guess what's the exact problem here or how to fix it. If you want to solve it check the mods you have installed, verify the humanoid skeletons from XPMSSE are the ones used in game and if you keep crashing try to isolate the problem by testing in a new game with fewer mods.

Share this post


Link to post
2 hours ago, Just Don't said:

Doing everything as I said is very vague here. I'm just referring to two mods (SOS and XPMSSE) in a particular setup (using MO as mod manager). I don't know if you're also using MO or if you have other mods providing other obsolete humanoid skeletons (or if you're using NPCs with unique body/skeletons). I'm not even sure if your CTD is exactly the same as the other user. So as I lack all that information, I won't guess what's the exact problem here or how to fix it. If you want to solve it check the mods you have installed, verify the humanoid skeletons from XPMSSE are the ones used in game and if you keep crashing try to isolate the problem by testing in a new game with fewer mods.

Thanks alot, what you said gave me an idea, turns out sos does not like realistic ragdolls and force very much or at least the way I had it installed.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...