Jump to content
tasairis

SE Compatibility Tracking (Jan 18 #5998)

Recommended Posts

15 hours ago, tasairis said:

Besides what I have listed, this and this are the only two lists I know of.

Thanks, those both list Nexus mods. I'm looking for a list of LL or non-nexus mods, that are dependent on SKSE64 and must be updated every time SKSE64 is updated. DDi for example, requires a new DLL every time SKSE64 updates. I thought you made a list like that after the last Bethesda update but I'm not seeing it, or I'm blind and overlooking it, or maybe it was someone else. 

edit; I went through my mods one by one. Done.

Link to post
On 2/19/2018 at 6:35 PM, tasairis said:

☑️ Simple Slavery (non-DD version)
🔍 Simple Slavery Plus - ported but may not be working properly; ☑️ Oldrim version 6.02+ can be converted (steps by Roggvir)

Any idea why Simple Slavery (regular version) doesn't have porting issues whiles Simple Slavery Plus does?

 

Or is it just that no one looked at SS closely like Roggvir did for SS+?

 

 

On 7/30/2018 at 10:53 PM, Roggvir said:

Regarding Simple Slavery Plus...

I confirm the version 6.02 works for me, after i:
(unlocalized plugins both with and without DF, but i had the DF checkbox unchecked, so i cannot confirm if the traveling part works)

 

  • Moved script sources into correct SSE folder "source/scripts"
  • Recompiled all used scripts
  • Fixed the tints on Margaret Garner NPC
    (she doesn't seem to be used anywhere anyway, but i don't like to keep errors i can fix)
  • Fixed broken property bindings on some Topic Infos by clearing the values.
    (the "Could not be resolved" errors in xEdit - again, those topics were unused leftovers, but i prefer no errors)
  • Resaved the Unlocalized plugins in 64bit CK
    (i never did any localizations before, so i do not know how to handle the "localized" plugins - when i resave them in CK, xEdit finds tons of errors, so i dont resave those for now).
  • Optimized meshes using SSE NIF Optimizer v3.0.6
    (not the facegen heads, obviously)
  • Regenerated facegen head meshes and tints from CK
  • Fixed dimensions of cwmapredone1.dds and cwmapredone2.dds
  • Regenerated the SEQ file
    (someone pls tell me if this is neccessary, i don't know, so i keep doing it)

 

...and now i see SS+has been updated to 6.03, time to do everything all over again i guess :)

EDIT: 6.03 is just a patch fixing SSLV_MainScr.psc script source file - if you figured out how to fix it in 6.02, or you do not recompile the scripts, you don't need to worry about the patch 6.03.

Seems pretty complicated for conversion... Do you plan to post your conversion?

Link to post
1 hour ago, nanashi50 said:

Seems pretty complicated for conversion... Do you plan to post your conversion?

Well, i do some stuff that isn't really necessary, like regenerating that SEQ file purely out of ignorance, because i do not know whether it is really unnecessary, but i do know it cannot hurt.

However, i do believe i have legitimate reasons for doing all the rest.

For example, most ppl dont bother recompiling scripts - i do that to make sure there wont be some kind of incompatibility with any 3rd party script the mod MAY depend on, because any of those 3rd party scripts could be a different version in SSE, or somehow altered in order to work correctly in SSE or to take advantage of some new feature (be it a feature of SSE, or feature of SKSE, or any SKSE plugins), and recompiling the scripts would provide indication in form of errors.

That being said, i dont recall ever encountering such cases, but i keep doing it - just in case, you never know when it may save you some headaches.

 

And if you want my conversion, yes, i recently posted the version 6.04:

 

Link to post
On 4/21/2019 at 8:52 PM, McLude said:

Thanks, those both list Nexus mods. I'm looking for a list of LL or non-nexus mods, that are dependent on SKSE64 and must be updated every time SKSE64 is updated. DDi for example, requires a new DLL every time SKSE64 updates. I thought you made a list like that after the last Bethesda update but I'm not seeing it, or I'm blind and overlooking it, or maybe it was someone else. 

edit; I went through my mods one by one. Done.

That one table I had of everything showing whether it updated? That was only while mods were still being updated, but now nearly everything is updated so there's no need.

 

Everything in my list that requires SKSE, which is what would be in that table, says "SKSE <version>". But the easiest way to see what mods you have to update will be looking at your SKSE\Plugins directory - with one or two exceptions, the DLL filenames tend to be pretty obvious about which mods provide them. (Of course, if you use MO2 then the Data tab explicitly tells you the mod.)

Link to post
19 hours ago, nanashi50 said:

Any idea why Simple Slavery (regular version) doesn't have porting issues whiles Simple Slavery Plus does?

Note that the link goes to the Plus SE page. Apparently I forgot to update the name, and based on the "ported but" apparently there may have been issues I heard about. I don't know. I'll fix the name and mark it green with the next update.

Link to post
15 hours ago, tasairis said:

That one table I had of everything showing whether it updated? That was only while mods were still being updated, but now nearly everything is updated so there's no need.

 

Everything in my list that requires SKSE, which is what would be in that table, says "SKSE <version>". But the easiest way to see what mods you have to update will be looking at your SKSE\Plugins directory - with one or two exceptions, the DLL filenames tend to be pretty obvious about which mods provide them. (Of course, if you use MO2 then the Data tab explicitly tells you the mod.)

Thanks for the pointer, I'll look into it.

Link to post

Okay so, I'm pretty good at reading instructions, but when things are out of order I get confused and basically what I'm asking is: is there a step-by-step guide or install kit (a la Bounce and Jiggles or All-In-One Animated Pussy) for installing HDT-SMP for boob, butt, and belly? I see the links to the Chinese website and I think I found a install guide for just the framework, but of course that itself won't make the parts bounce. Thanks in advance.

Link to post
1 hour ago, genderneutralnoun said:

Okay so, I'm pretty good at reading instructions, but when things are out of order I get confused and basically what I'm asking is: is there a step-by-step guide or install kit (a la Bounce and Jiggles or All-In-One Animated Pussy) for installing HDT-SMP for boob, butt, and belly? I see the links to the Chinese website and I think I found a install guide for just the framework, but of course that itself won't make the parts bounce. Thanks in advance.

Might be more info in the HDT-SMP thread.

Link to post
On 4/27/2019 at 1:12 PM, Kain82 said:

Yes, can you please?

 

On 4/27/2019 at 12:38 PM, Nepro said:

Can you post link to your port please? I look for Radiant Prostitution SSE and can't find it anywhere.

 

I don't know if I can. Anyway, all I did was re-save the .esp in the CK. 

Link to post
4 hours ago, Devorax said:

 

 

I don't know if I can. Anyway, all I did was re-save the .esp in the CK. 

Did that work?  And if so does that mod come with an MCM menu, and if so did the options work?

Link to post
On 4/29/2019 at 1:17 AM, Devorax said:

 

 

I don't know if I can. Anyway, all I did was re-save the .esp in the CK. 

I did the same with Radiant Prostitution_Gigolo 3.7.4. The mod works partially. NPCs don't approach the wenches and player don't get approached by client as well even if I set all approach options 100%. Asking wench for service works.

 

Converted it second time. This time it seems to work one client approached Susana the Wicked.

Link to post
On 2/20/2018 at 8:35 AM, tasairis said:

Hello,

 

Can anyone confirm whether latest SLSO SE v 1.5.9 (Mar. 19, 2019) is really compatible with the latest Sexlab v 1.63 b6 (Mar. 19, 2019), as stated in OP?  

I got CTD with the combination between these two builds and I cannot find any certain conformation in the former's forum on this matter (v 1.5.9 is supposedly released for SSL 163 b5). 

Link to post
1 hour ago, y_sengaku said:

Hello,

 

Can anyone confirm whether latest SLSO SE v 1.5.9 (Mar. 19, 2019) is really compatible with the latest Sexlab v 1.63 b6 (Mar. 19, 2019), as stated in OP?  

I got CTD with the combination between these two builds and I cannot find any certain conformation in the former's forum on this matter (v 1.5.9 is supposedly released for SSL 163 b5). 

Have had no problems at all. Also have it running with Spank that Ass.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...