Jump to content
Toronam

[mod] Stellaris Sexy Xenos and more (SSX) 1.11.8

Recommended Posts

For starters, I'ma have to optionally suggest a version where Elves(and Egyptians I guess) have no male portaits (futa elves can stay, because why wouldn't we have a futa elf God-Emperor)
Serious opinions to follow:

Next, I hope you placed ai_weight = 0 on the Chosen One Trait
Edit: Eh, random = no sounds good enough. I think?


Reading the code, there's a 50/50 chance Adorably Innocent pops will convert other non-adorable species to their own or get converted to the other species? That's potentially dangerous for the latter if you are unlucky enough...? And it partially overlaps with other similarly-concept parts of MASSA and Sexual Gameplay(with add-on), but that's not a bad thing. Would probably need an explicit warning not to use Adorable Innocent with MASSA's Aggressive Adaptive Organs and Sexual Gameplay's Need to Breed.

The 

mean_time_to_happen = {
        months = 2000
    }

is probably a good thing for people who don't want the event.

Any bugs I'll get back here after 150 years of gameplay
 

Link to post

Hey!
First, thank you very much for this awesome Mod! Its the reason i subscribed to this side!
Not only because the pictures but also that you did add some really cool traits.
I am looking forward to updates for this mod, especially the wolf pictures.

So, thank you for creating this mod and working on it! :smile:

Link to post

Hm I know this is not much info, but I had that glitch that when I run the nation creation it would show only one category, and the names of the category would be SSX, SSX_1, SSX_2 and something like that! I haven't used other mods that change portraits, but there may be a conflict with something else, or it's just not updated to the latest version? Does this mod work well with sexual gameplay?

Link to post

Recycled answer.

 

On 2/24/2018 at 12:55 PM, JesusKreist said:

None.

 

You get access to two extra species looks when you have Synthetic Dawn but both are extra, heavy WIP and honestly mediocre in my eyes.

 

At your problem: it isn't one.

Only SSX is a category with the new races. SSX with a number attached are for citygraphics and have no races in them.

Stellaris always needs a category for city and ship graphics, it is how the game is coded and not an error.

 

Link to post

A last update is planned for the far futur, modding is time expansive, actually i want to spend my free time for myself.

Since the last update i have added 128 new portraits for the manga girls and... that all. :blush:

Link to post

Maybe I'm wrong , since I copied the files in the "mod folder", when I start the game I can use only six organic races and two robotic, but in the description I saw that there are more, I perhaps have copied the wrong file?

Link to post

It's mystical, if you delete the old folder, and place the new one. You have all portraits.

You have a very old ssx_species_classes file.

 

I think i understand, in the 1.4 or 1.5 upgrade, i have renamed somes files, and you have directly merged the content of the new folder with the old.

Link to post
12 minutes ago, snarfies said:

Looks like 1.5.2 does not work with Stellaris 2.1.0 - it seems to bomb on city appearance.  The game keels over when either attempting to edit city appearance, or on starting a new game.

It's working fine on my end with 2.1. Do you have any other mods active that might conflict with SSX/2.1?

Link to post

 

12 minutes ago, Pravus said:

It's working fine on my end with 2.1. Do you have any other mods active that might conflict with SSX/2.1?

I have the same mods active that I had active for 2.0.x, so I'm going to say "no."

 

I narrowed it down to SSX by disabling all mods except for the loverslab mods - game bombed.  SSX was the first mod I disabled after that, as it affects city backgrounds, and when I did that, the game no longer bombed.

Link to post

As darkspleen said the last update broke a lot of mods. Most of them even.

Until the mods are updated simply do not use the outdated mods or downgrade stellaris to 2.0.5 or even 2.0.2 in the steam properties betas tab.

Link to post

My modlist is extensive with more than one red exclamation mark i.e. mod not made for that version of stellaris.

Despite numerous tests the simple clicking on a city appearance does not "bomb" the game. A gamestart with one of the "faulty" city appearances did nothing either.

 

I suggest both of you @snarfies and @Daronir try to redownload the mod and repair stellaris via steam. Something might have gone wrong with the update on your side. Or it might be another mod for city appearance which worked together with this mod in 2.0.x but causes problems in conjunction with 2.1.x.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...