Jump to content
TwilightStorm

Passion [Requires patch level 1.63+]

Recommended Posts

14 minutes ago, EvilMantiss said:

if the mod is reading

It isn't just the mod, and it isn't just the animations being read. Several factors go into how fast things work on your machine, including how fast your machine is, and how much are you asking it to do at any given second.

Link to post
24 minutes ago, LadySmoks said:

It isn't just the mod, and it isn't just the animations being read. Several factors go into how fast things work on your machine, including how fast your machine is, and how much are you asking it to do at any given second.

My machine is fast and I'm only asking it to switch the position in the game so...ūüôÉ.

Link to post
2 hours ago, EvilMantiss said:

My machine is fast

"Fast" is a relative term. To a snail, a person walking is fast. To a cheetah, he is lunch. ))) 

 

Understanding TS3 and how it works (and doesn't work) usually lowers a person's expectations of what a poorly built 32 bit game is capable of. You can be running a system that makes NORAD look like a gameboy, but as TS3 is what it is, and you are loading it with mods, the game itself simply has a speed limit.

 

There are many posts concerning slow TS3 games, and how to speed them up. Personally, my game lags a bit... but I also have nearly 10GB of CC, several downloaded worlds, several EP's and SP's and other junk running that EA says you shouldn't. 

Link to post
9 hours ago, EvilMantiss said:

My machine is fast and I'm only asking it to switch the position in the game so...

I guess you mean to switch the actors during an animation, right ?

If so, it can take a while the mod can do that. Think the earliest time to switch an actor is on the end of the respective animation clip and before the animation will repeated or changed to another one.

Actors can not switch during a running clip and the XML of the animation pack must allow the genders for that positon.

Mean, if you want to switch an actor - let say a female shall take the position with a male - if this possibility is not foreseen in the animation xml, then it simply does not work. That is how I understand this. But think only TwilightStorm can answer this correctly.....

Link to post
17 hours ago, EvilMantiss said:

But if the mod is reading the animation file okay, why would it be delayed? Also, any idea how far back that page is?

 

@LadySmoks, @Clydie Thanks any one here that tried at least to give an answer on this!

 

Actor/Partner switch was made long ago for AW animations that had no Gender.

Player 1 could be what ever gender as much as player 2.

The XML structure of AW animations was "confusing" the mods that they used them.

In the past the "male act" could be to any active sim even if this sim was a female one.

Oniki Kay changed that in a new type of animations that support the gender of any sim that is an actor or a partner.

These are the animations for Kinky World.

 

If you have an autonomous change of animations in passion and you clicked to switch the Actor/Partner, 

Passion gets that for the next animation. If the next animation has different gender tags, passion will follow them and no Actor/Partner  change will happen.

 

If you play the same animation in a loop, over and over again, yes you will see what you wish to see.

Another option is to edit the XML of the animations that you want to see the Actor/Partner switch, yourself....  

See : https://www.loverslab.com/topic/82485-passion-requires-patch-level-163/?do=findComment&comment=1971844

The last part of it...

Link to post
3 hours ago, shiftdelete99 said:

Hey i know it says required but would it be ok if i don't install "cummask" and "condom" packages? I don't really want or need them 

 

it seems to be working without them but just checking 

What ever says that is REQUIRED is required. Maybe your game works fine with out them and maybe starts crashing  after sometime.

Don't blame me for that.

Link to post
4 hours ago, Soulbringer1 said:

dO YOU KNOW WHY THE "REVEAL HIDDEN INFO", BUTTONS HAVE NOT WORKED FOR THE LAST FEW DAY? LIKE FOR THE ANIMS FOR YOUR MOD. I CANT REVEAL THE INFO FOR THEM. Sorry for the caps lock. im always hitting it. 

It must be something in your browser.

They work for me.

I suppose that you click on the word Reveal hidden and not anywhere else...

Link to post
17 hours ago, TwilightStorm said:

What ever says that is REQUIRED is required. Maybe your game works fine with out them and maybe starts crashing  after sometime.

Don't blame me for that.

Oh well i remember i dowloaded the mod and wasn't interested because of the required module that bothered me for my gameplay... And kinky world is a heavier mod than passion xd

Link to post

Beloved Storm! Thank you so much for this new update,.

Have been busy packing the Xmas away, and have still more tidying up to do ;)

But as a lover of the holliday even though we didn't have snow until january only frost the decorations made me smile and add beauty to the celebrations. 

We didn't escape death this hooliday either, lost my mothers brother in the end of Yule ( lasts im this family till  janyary 13, day 20 reckoning from the desember 25). He was very ill and frail but it still came a a shock. With corona risk no more than 20 can attend the funural so i¨ll stay home ;(

We are a large loving family with lots of aunts and uncles and even larger number cousins so we'll probably have a gathering when it is safe for all the relations, eating and dring and remeber the good old days :/¬† ‚̧ԳŹ

Take care, stay safe, let hope fill your heart for this new year and lots of corona free hugs and kisses ‚̧ԳŹ

Link to post

This is driving me insane and i dont know how updated is this thread. But I have been trying to download the mods i had years ago and followed every step by downloading KinkyWorld, Lady666, and Mike24's mods for the animation and manually added the mod names to the position lists and NONE OF THEM IS SHOWING UP ON THE LISTS! 

 

Is it because those are outdated mods with the 1.69 ver of sims 3??? I am really  not sure what is it that i am doing wrong :( do i have to download this Passion mod for it to run? and get rid of everything else? Plz plz help 

Link to post
7 hours ago, Dallia Vincent said:

Is it because those are outdated mods with the 1.69 ver of sims 3???

NO, Passion register animations automatically if correct installed in the mod folder...

 

So, I repeat my post from the previous page :

 

Did you extract the ZIP ?

Do you have the setup of your MOD folder on the right place ?

Both yes :

A screen shoot of your mod folder would help to help !

No : look the first two threads in the technical help section of SIMS3 here at LL.

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

√ó
√ó
  • Create New...