Jump to content

NOTICE: The new site is now moved to the original www.loverslab.com URL. The site may be up and down during this transition and there is still some tweaks and setup going on, so you may experience the occasional broken link, visual oddity, and other such errors. 

If you notice anything any particular that's broken or have any suggestions or comments, please post them in the following thread: http://www.loverslab.com/topic/87535-new-site-questions-comments-and-suggestions/

The old site will remain accessible for the next week via the URL http://old.loverslab.com

Sign in to follow this  
The Master

How To: Animated Woohoo - A complete Step-for-Step Walkthrough

Recommended Posts

have you turned the clips into package files in s3pe

I've turned the male and female saved clips (A and B etc) as separate package files. I then saved those two package files as one package called streakersanimations.package before starting on the XML part. Is that right?

Share this post


Link to post

I got them into game! Hurray! It was something tiny; I didn't remove the brackets when inputting my hash data etc onto the name of the XML file... I think I just misunderstood the instructions (quite often actually!) or it wasn't really specified. The animation is in game, but my male sim is about a tile and a half further up on the X Axis than he ought to be? Most likely something I did wrong in blender than in the export tbh... Thank you anyway!

Share this post


Link to post

I got them into game! Hurray! It was something tiny; I didn't remove the brackets when inputting my hash data etc onto the name of the XML file... I think I just misunderstood the instructions (quite often actually!) or it wasn't really specified. The animation is in game, but my male sim is about a tile and a half further up on the X Axis than he ought to be? Most likely something I did wrong in blender than in the export tbh... Thank you anyway!

 

Congrats, hey small victories. I've yet to talk trying to make animations yet but I might.

 

Share this post


Link to post

Hi !

 

Thanks for the tutorial.

 

My animation is in the game.

 

Any quick advise on how to align the sims the same way they do in blender ?

- In blender, they face each other

- In the game, they are clipped one in the other, looking in the same direction

 

Furthermore, to give it a try, I just did a hand waving animation, and curiously in game the hand is not moving the same way :

- In blender, hand is waving towards the other sims

- In the game, hand is waving towards the right

It looks like the forearm rotation is missing :/

 

Any help ? :)

 

Red

Share this post


Link to post

I solved my 2 issues.

 

For those who might have the same :

 

To get the sims facing each other :

  1. I selected one sims
  2. Selected "Object mode" instead of "Pose mode"
  3. Made them superimposed
  4. Switch to "Pose mode"
  5. Selected all nodes of the sims I moved (select one node and press "a")
  6. Move the sims back by pressing "g"
  7. And then press "i" then "LocRot" at the beginning of the sequence to fix the sims at this place

Regarding my issue with the waving hand, it was simply because my animation was too short.

When it comes near the end of the animation, it comes back to the beginning so in game it was like It looped between the beginning and the middle of the animation.

 

Red

Share this post


Link to post

Okay now I'm struggling with 2 new things :

 

There are 2 rigs in your tutorial :

- Animated Woohoo Base Rig

- Animated Woohoo Base Rig ALTERNATIVE

 

I though they were no differences but in the ALTERNATIVE one we can't move the breasts.

 

So, I would like to work on Animated Woohoo Base Rig but for some reasons the "Pose mode" is not available for the male sims in this rig (while it is available in the ALTERNATIVE one), so I can't animate him.

Any idea ?

 

Second, I found out that SM animations uses a PSTAR package.

I like his animations because it also animates the penis.

 

Any idea how I could import it in blender ?

 

As you may tell yourself I'm really new to all this stuff (first time using blender and so on).

I hope this tutorial and thread will help newbies like me to get started with animating ! :)

 

Red

Share this post


Link to post

Good day people,

 

I tried creating my animations and has successfully imported them into the game.

 

However, right now I am stuck with not been able to access the grid to insert sound events.

I tried using Master's S3PE out of the box and opening my package files. However, I was met with a warning sign stating "Some resource names may not be displayed".

 

Despite stating that warning only, I still cannot click on the grid.

 

Some help please ?

Share this post


Link to post

Great tutorial.  Good job explaining all the steps with notes on the potential pitfalls, and explaining why you're doing whatever you're doing.  I'm still working on my animation, so I haven't tried to get one into the game yet.  But I had a couple questions...

 

How do you attach an object to the animation?  To make the animation happen on a bed or in a chair, etc.  Can you attach it to cc objects?

 

Can you start with existing animations from the game or cc and just make adjustments/modifications in Blender?

 

Thanks for all the great work.  Getting newbs like me believing.

 

Share this post


Link to post

@Redfaction:

 

I though they were no differences but in the ALTERNATIVE one we can't move the breasts.

I didn't check that out if breasts were animatable in the first place tbh. Back then when I wrote the Tutorial I was using the base rig anyway due to better performance in blender for me. I included it anyway since some may prefer just another rig.

I am using it to "test" my animations and see if everything is "in place" if you know what i mean...

 

 

Second, I found out that SM animations uses a PSTAR package.

I like his animations because it also animates the penis.

 

Any idea how I could import it in blender ?

As far as I am aware you won't be able to retrieve the Rig from just the clips, since they only store the bone movement information which will be mapped to the corresponding vanilla rigs made by Maxis. You'd be most likely required to contact SM and ask him for the blender files, as I see no other way round.

 

@Raydark:

 

 

I tried creating my animations and has successfully imported them into the game.

Well done! We need more people like ya'all here ^^.

 

 

However, right now I am stuck with not been able to access the grid to insert sound events.

I tried using Master's S3PE out of the box and opening my package files. However, I was met with a warning sign stating "Some resource names may not be displayed".

I am not sure but I'd assume that you might miss the latest .NET runtime libraries. It's been some time now that I was fiddling with getting S3PE to work as I wanted it to. I can remember reading somewhere that the Grid required some .NET frameworks to be present on the computer. Just goggle .NET framework and get the most actual one. Hope that helps fixing your issue

 

@shrike60:

 

Great tutorial.  Good job explaining all the steps with notes on the potential pitfalls, and explaining why you're doing whatever you're doing.

Thanks! Very appreciated ^^.

 

 

How do you attach an object to the animation?  To make the animation happen on a bed or in a chair, etc.  Can you attach it to cc objects?

 

Can you start with existing animations from the game or cc and just make adjustments/modifications in Blender?

You don't attach the sims directly to it. What you do instead is importing "dummy" props from the game into blender and using them as a reference for your animation alignment. You'll need an additional tool for it called S3OC in order to extract the necessary meshes.

What I did was extracting one "example" mesh from every object which is woohooable from the game into a dedicated folder, so when I need it I just browse for the needed prop and load it in blender to align my sims to it!

Share this post


Link to post

Great Tutorial! I've managed to try out making some animations, but I'm also having trouble with the sound part. After googling around, it seems we may have to install s3piwrappers to be able to add sounds. I'm not quite sure how to install it though.

 

Share this post


Link to post

I am actually quite sure that i've included the S3PIwrappers already in the out-of-the-box version used in my Starter Pack. But I think that i've read somewhere that these wrappers require the latest .NET frameworks. My mind could still play games on me though but maybe you should give it a try getting the latest .NET Framework from the Microsoft page and retry using the S3PE i've provided within my Starter Package. It's possible that this might activate the Data Grid feature for you.

 

Tell me if that fixed your issue.

Share this post


Link to post

I am actually quite sure that i've included the S3PIwrappers already in the out-of-the-box version used in my Starter Pack. But I think that i've read somewhere that these wrappers require the latest .NET frameworks. My mind could still play games on me though but maybe you should give it a try getting the latest .NET Framework from the Microsoft page and retry using the S3PE i've provided within my Starter Package. It's possible that this might activate the Data Grid feature for you.

 

Tell me if that fixed your issue.

 

Ah. Interesting I've been using a different version of S3PE it seems. 

I tried using the one out of the box from your tutorial, but the following error shows up on the preview.

I tried to update Microsoft .NET Framework on my computer (Running Windows 8.1 Pro), but it says that I've got the most up to date version.

This is the error I get:

 

Error reading resource 0x6B20C4F3-0x00000000-0x46EAD952FB115C01
Front-end Distribution: 14-0222-1852
Library Distribution: 14-0222-1852
 
Source: s3pi.WrapperDealer
Assembly: s3pi.WrapperDealer, Version=1402.22.1843.33692, Culture=neutral, PublicKeyToken=null
Could not find a resource handler
----
Stack trace:
   at s3pi.WrapperDealer.WrapperDealer.WrapperForType(String type, Int32 APIversion, Stream s)
   at S3PIDemoFE.MainForm.browserWidget1_SelectedResourceChanged(Object sender, ResourceChangedEventArgs e)
----
 
 
On the bright side, I have a laptop with windows 7 installed. I used the stuff straight out of the box and the grid option appears! Hurray.
I'm still not sure what the problem is though it might be an OS compatibility issue.

Share this post


Link to post

Glad that you could at least use the Grid on your laptop eventhough it's probably not the workspace you was looking for in the first place.

I am personally using Windows 8.1 myself (Not the fancy Pro version though) and had no problems.

Share this post


Link to post

Great job, indeed, thank you very much.

I wander is there possibility to create three, four... (you name it :))-some animations this way? 

Share this post


Link to post

I wanted this mod for my Sims, but I've got stuck on patch 1.42, I can't update any more, can someone tell me if it's possible to make it compatible with my game, please? :o

I can't register at "Hall of Torque" so I can post and ask there, I tried but the registration doesn't work (maybe later)!

Share this post


Link to post

Hello Master. First thank you so much for all your hard work on your animations and on this animation package. I am having some problems with getting s3pe to do anything with my exported animations it refuses to recognize them and I get a crapload of wrapper errors and the like. ( i would attach screen shots but the site will not allow me too.) I have downloaded your animation packages and have tried it with blender versions 2.67b and 2.75a and no luck. Using windows 7, 64 bit, .net framework 4.5. Any help would be greatly appreciated, I really, really, really want to get these animations out of blender and in game!!!!! Thank you again.

Share this post


Link to post

Do you mean blender version 2.67b ? and the io_s3py_ animation zip? Have those per the download given by master,  O.K my problem was a bad s3pe download, thanks !

 

Share this post


Link to post

gave it a test last night... got rig in blender, but as I tried to ad base game object in... error and nothing... got to try again with more time to spare, but I'm going to make at least one...

got to thou surf a lot more to find out and sort all ideas I got in my kinky mind...

Share this post


Link to post

gave it a test last night... got rig in blender, but as I tried to ad base game object in... error and nothing... got to try again with more time to spare, but I'm going to make at least one...

got to thou surf a lot more to find out and sort all ideas I got in my kinky mind...

 

Depending on what version you're using you'll get this problem importing an object. I had it happen on 2.67a and 2.67b but I dropped down to version 2.67 and all was fine. I'm still a noob but I'm learning some things.

Share this post


Link to post

2.73a, This was actually my first ever try-out to do something into sims, so I'm glad I got the masters Rigs opened...

Share this post


Link to post

2.73a, This was actually my first ever try-out to do something into sims, so I'm glad I got the masters Rigs opened...

 

You have to figure out what version works best for you but so far 2.67 works for me with no problems yet. The good thing about Blender is most older versions are available for download.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×