Jump to content

Recommended Posts

I was hoping this version did not require Death Alternative - Your Money or Your Life but after getting everything installed i noticed SD Patches 077 wants that ESM loaded so what makes this version stand out over the other version since they pretty much require the same mods in order to work?

Link to post

Would it be possible for you to make Sanguine's Debauchery enforce sexual preferrences as far as the animations go.
It enforces it to the extent that it only allows females to capture my male character, but then they just use male animations on him.
Sexlab Defeat fixes that and restricts the animations to their appropriate gender roles. (I just don't particularly like watching my male character get fisted by a female bandit.)
Can you create a fix for this?
Thanks

Link to post

What exactly is SD+ 2044?

I've seen it mentioned, but I'm not sure what it is.

 

Also, why are the patches only for SD+ 2044?

Why are they not compatible with the current version of SD+?

SD+ 2.044 is the version before SD+ 3.

I am patching @skyrimll's main scripts, and those have changed for SD+ 3.

Link to post

Ah. Thanks for clearing that up.

I'm partially interested in your patches, is it still possible to get SD+ 2.044?

 

Edit:
It also seems like your patches utilize DD items.

For whatever reason, in the current version of SD+, the Devices don't show up that much.

Link to post

Ah. Thanks for clearing that up.

I'm partially interested in your patches, is it still possible to get SD+ 2.044?

 

Edit:

It also seems like your patches utilize DD items.

For whatever reason, in the current version of SD+, the Devices don't show up that much.

 

One of the main reason for the patches is the DD usage. The 0.79 update (not posted) you can choose which DD's get equipped -- random, auto (every enslavement gets you the next DD set in the list, there are 11 sets of different DD outfits, my favorite is the shiny white and the falmer ( looks like USAF camo)) or you can choose a specific DD set. :P   

The SD+ 2.044 is on the patches download page.

 

Link to post

Thanks for these awesome fixes! Especially the lockpicking/pickpocketing. Being able to do that drove me insane! I'm so glad to have that fixed.

 

I do have one slight problem which I'm hoping you might be able to assist me with. When captured by Falmer, I was equipped with the SD Falmer Collar (Posture) (Steel) and the rest of the things in this picture: 

57b03c7df0be500dcac54a9f8832d09b.png

 

 

And the outfit looks AWESOME. (2E is the SDpatch - Fixes.esp Mod Index). But when this outfit was put on, I received this error:

 

 

0b34d658a4a2b03b62e5c3fc72735db5.png

 

Now that's interesting, I thought. So I researched the issue, and found this past problem. Looking at his issue and mine, it's clear to me that what was fixed was changing the 0 after the F into a ). Simple typo! But there's more of a problem here! There isn't an item with the id of xx00CAEF, unless I personally screwed up. I pulled up console and used, "help armbinder 4" and got these results:

 

be8fb78d5fd296d3ed5433e2baec228f.png

 

My guess is it was supposed to be xx01926E which would match the rest of the "SD Falmer Ebonite" set, but the closest ID is xx00CAEE. Have I made a mistake somewhere? Can I fix this myself? If not, to whom do I need to contact to get this fixed?

Thank you so much!
bayace92

Link to post

These patches are old. Majority of fixes was integrated with SD+ and using patches with current version is not recommended. They will conflict.

 

They have? I'll have to check that out.

 

Link to post

Thanks for these awesome fixes! Especially the lockpicking/pickpocketing. Being able to do that drove me insane! I'm so glad to have that fixed.

 

I do have one slight problem which I'm hoping you might be able to assist me with. When captured by Falmer, I was equipped with the SD Falmer Collar (Posture) (Steel) and the rest of the things in this picture: 

57b03c7df0be500dcac54a9f8832d09b.png

 

 

And the outfit looks AWESOME. (2E is the SDpatch - Fixes.esp Mod Index). But when this outfit was put on, I received this error:

 

 

0b34d658a4a2b03b62e5c3fc72735db5.png

 

Now that's interesting, I thought. So I researched the issue, and found this past problem. Looking at his issue and mine, it's clear to me that what was fixed was changing the 0 after the F into a ). Simple typo! But there's more of a problem here! There isn't an item with the id of xx00CAEF, unless I personally screwed up. I pulled up console and used, "help armbinder 4" and got these results:

 

be8fb78d5fd296d3ed5433e2baec228f.png

 

My guess is it was supposed to be xx01926E which would match the rest of the "SD Falmer Ebonite" set, but the closest ID is xx00CAEE. Have I made a mistake somewhere? Can I fix this myself? If not, to whom do I need to contact to get this fixed?

 

Thank you so much!

bayace92

 

The new version of DDi is checking everything you equip/un-equip against a list of known keywords and if the DD device keyword is not on that list you get that error. I have brought this up with @Min among many others, but my inquiry was ignored. The keyword I am using is a custom keyword not a bad one. Using a custom keyword helps me differentiate these DDs from regular ones.   

 

Link to post

 

These patches are old. Majority of fixes was integrated with SD+ and using patches with current version is not recommended. They will conflict.

 

They have? I'll have to check that out.

 

 

Have I misunderstood?

If so, I apologize. :blush:

Link to post

 

 

These patches are old. Majority of fixes was integrated with SD+ and using patches with current version is not recommended. They will conflict.

 

They have? I'll have to check that out.

 

Have I misunderstood?

If so, I apologize. :blush:

 

 

The last version of SD+ 3.something I tested none of the patches were implemented. You could slide around on the floor while bound, (what is up with that), you could just take the Master's key while he/she was starring straight at you, a lot of "your owner" did this/that, I prefer "Master"; I am more into BD- Slave-Master rather than owning people, kneeling loop, etc.

 

This was back in January, IDK is it better now?

Link to post

 

The last version of SD+ 3.something I tested none of the patches were implemented. You could slide around on the floor while bound, (what is up with that), you could just take the Master's key while he/she was starring straight at you, a lot of "your owner" did this/that, I prefer "Master"; I am more into BD- Slave-Master rather than owning people, kneeling loop, etc.

 

This was back in January, IDK is it better now?

 

 

Now that I read Skyrimll's release notes again, the patches were added up to version 0.7.

I indeed made a mistake. I did not realize that patches are now up to 0.77. I should have recheck the release notes, before commenting to this thread.

 

Sorry. :)

Link to post

I incorporated some ideas from SD Patches into SD+ 3.0 and above... I also ignored some as a matter of preference and there are a few ideas I still have to bring over (like the solution for stealing keys).

 

The main problem is that SD Patches were built with SD 2.0 scripts as a base and some of these scripts changed significantly in SD+ 3.0.

 

So, if you install SD Patches loose files on top of SD + 3.0 bsa file, you end up with a mix of versions that do not work together any more.

 

That is why I cannot recommend using SD Patches on top of SD+ 3.0

 

The solution would be to either, for me to finish importing missing patches into SD+ or for Inte to rewrite SD Patches on top of SD+ 3.0 base files.

Link to post

 

 

The last version of SD+ 3.something I tested none of the patches were implemented. You could slide around on the floor while bound, (what is up with that), you could just take the Master's key while he/she was starring straight at you, a lot of "your owner" did this/that, I prefer "Master"; I am more into BD- Slave-Master rather than owning people, kneeling loop, etc.

 

This was back in January, IDK is it better now?

 

 

Now that I read Skyrimll's release notes again, the patches were added up to version 0.7.

I indeed made a mistake. I did not realize that patches are now up to 0.77. I should have recheck the release notes, before commenting to this thread.

 

Sorry. :)

 

 

Please, don't feel like you need to apologize. :blush: 

 

Link to post

Still doing tests. This time, I'm enslaved by bandits rather than Falmer. Got the same message. BUT this time, the armbinder was equipped. Last time, the Falmer armbinder was NOT equipped.

 

----
I put this in the SD+ help feed, but maybe someone here may be able to help. When being enslaved by said bandits, the non-owner still attacks me. This happens with and without SDpatches installed.

 

Thanks again!

 

Edit: apparently I should definitely not use this with SD+ 3.0. I suppose I'll wait for the next update. :(

Link to post

I am confused. I have the same error message  "_SD_device"...

 

So, do I need to use SD patch with SD+3.0 ?

 

You most definitely should NOT use the SD Patches with SD+ 3.0 

 

Link to post

I get a lot of PM's for an update to these patches. Since I am not using SD+ 3 not sure when that will happen, but for those of you still using SD+ 2.044 like I am, here is patch 0.80.
As far as the keyword error I fixed it in my copy of zadLibs which is part of DDi, by commenting out the message, everything still works like before, except for the keyword error message.

 

 

string Function LookupDeviceType(keyword kwd)
	if kwd == zad_DeviousPlug
		return "Plug"
	ElseIf kwd == zad_DeviousBelt
		return "Belt" 
	ElseIf kwd == zad_DeviousBra
		return "Bra"  
	ElseIf kwd == zad_DeviousCollar
		return "Collar"  
	ElseIf kwd == zad_DeviousArmCuffs
		return "ArmCuffs"  
	ElseIf kwd == zad_DeviousLegCuffs
		return "LegCuffs"  
	ElseIf kwd == zad_DeviousArmbinder
		return "Armbinder"  
	ElseIf kwd == zad_DeviousYoke
		return "Yoke"  
	ElseIf kwd == zad_DeviousCorset
		return "Corset"  
	ElseIf kwd == zad_DeviousClamps
		return "Clamps"  
	ElseIf kwd == zad_DeviousGloves
		return "Gloves"  
	ElseIf kwd == zad_DeviousHood
		return "Hood"  
	ElseIf kwd == zad_DeviousSuit
		return "Suit"  
	ElseIf kwd == zad_DeviousGag
		return "Gag"  
	ElseIf kwd == zad_DeviousGagPanel
		return "GagPanel"  
	ElseIf kwd == zad_DeviousPlugVaginal
		return "PlugVaginal"  
	ElseIf kwd == zad_DeviousPlugAnal
		return "PlugAnal"  
	ElseIf kwd == zad_DeviousHarness
		return "Harness"  
	ElseIf kwd == zad_DeviousBlindfold
		return "Blindfold"  
	ElseIf kwd == zad_DeviousBoots
		return "Boots"  
	ElseIf kwd == zad_DeviousPiercingsNipple
		return "PiercingsNipple"  
	ElseIf kwd == zad_DeviousPiercingsVaginal
		return "PiercingsVaginal" 
	EndIf
	;Error("LookupDeviceType received invalid keyword " + kwd)
EndFunction

 

 

SD Patches 080.7z

Link to post

I get a lot of PM's for an update to these patches. Since I am not using SD+ 3 not sure when that will happen, but for those of you still using SD+ 2.044 like I am, here is patch 0.80.

As far as the keyword error I fixed it in my copy of zadLibs which is part of DDi, by commenting out the message, everything still works like before, except for the keyword error message.

 

 

string Function LookupDeviceType(keyword kwd)
	if kwd == zad_DeviousPlug
		return "Plug"
	ElseIf kwd == zad_DeviousBelt
		return "Belt" 
	ElseIf kwd == zad_DeviousBra
		return "Bra"  
	ElseIf kwd == zad_DeviousCollar
		return "Collar"  
	ElseIf kwd == zad_DeviousArmCuffs
		return "ArmCuffs"  
	ElseIf kwd == zad_DeviousLegCuffs
		return "LegCuffs"  
	ElseIf kwd == zad_DeviousArmbinder
		return "Armbinder"  
	ElseIf kwd == zad_DeviousYoke
		return "Yoke"  
	ElseIf kwd == zad_DeviousCorset
		return "Corset"  
	ElseIf kwd == zad_DeviousClamps
		return "Clamps"  
	ElseIf kwd == zad_DeviousGloves
		return "Gloves"  
	ElseIf kwd == zad_DeviousHood
		return "Hood"  
	ElseIf kwd == zad_DeviousSuit
		return "Suit"  
	ElseIf kwd == zad_DeviousGag
		return "Gag"  
	ElseIf kwd == zad_DeviousGagPanel
		return "GagPanel"  
	ElseIf kwd == zad_DeviousPlugVaginal
		return "PlugVaginal"  
	ElseIf kwd == zad_DeviousPlugAnal
		return "PlugAnal"  
	ElseIf kwd == zad_DeviousHarness
		return "Harness"  
	ElseIf kwd == zad_DeviousBlindfold
		return "Blindfold"  
	ElseIf kwd == zad_DeviousBoots
		return "Boots"  
	ElseIf kwd == zad_DeviousPiercingsNipple
		return "PiercingsNipple"  
	ElseIf kwd == zad_DeviousPiercingsVaginal
		return "PiercingsVaginal" 
	EndIf
	;Error("LookupDeviceType received invalid keyword " + kwd)
EndFunction

Why not put this on the main page?

Link to post

 

I get a lot of PM's for an update to these patches. Since I am not using SD+ 3 not sure when that will happen, but for those of you still using SD+ 2.044 like I am, here is patch 0.80.

As far as the keyword error I fixed it in my copy of zadLibs which is part of DDi, by commenting out the message, everything still works like before, except for the keyword error message.

 

 

string Function LookupDeviceType(keyword kwd)
	if kwd == zad_DeviousPlug
		return "Plug"
	ElseIf kwd == zad_DeviousBelt
		return "Belt" 
	ElseIf kwd == zad_DeviousBra
		return "Bra"  
	ElseIf kwd == zad_DeviousCollar
		return "Collar"  
	ElseIf kwd == zad_DeviousArmCuffs
		return "ArmCuffs"  
	ElseIf kwd == zad_DeviousLegCuffs
		return "LegCuffs"  
	ElseIf kwd == zad_DeviousArmbinder
		return "Armbinder"  
	ElseIf kwd == zad_DeviousYoke
		return "Yoke"  
	ElseIf kwd == zad_DeviousCorset
		return "Corset"  
	ElseIf kwd == zad_DeviousClamps
		return "Clamps"  
	ElseIf kwd == zad_DeviousGloves
		return "Gloves"  
	ElseIf kwd == zad_DeviousHood
		return "Hood"  
	ElseIf kwd == zad_DeviousSuit
		return "Suit"  
	ElseIf kwd == zad_DeviousGag
		return "Gag"  
	ElseIf kwd == zad_DeviousGagPanel
		return "GagPanel"  
	ElseIf kwd == zad_DeviousPlugVaginal
		return "PlugVaginal"  
	ElseIf kwd == zad_DeviousPlugAnal
		return "PlugAnal"  
	ElseIf kwd == zad_DeviousHarness
		return "Harness"  
	ElseIf kwd == zad_DeviousBlindfold
		return "Blindfold"  
	ElseIf kwd == zad_DeviousBoots
		return "Boots"  
	ElseIf kwd == zad_DeviousPiercingsNipple
		return "PiercingsNipple"  
	ElseIf kwd == zad_DeviousPiercingsVaginal
		return "PiercingsVaginal" 
	EndIf
	;Error("LookupDeviceType received invalid keyword " + kwd)
EndFunction

Why not put this on the main page?

 

 

I was trying not to confuse SD+ 3.x users.

But now that I think about it, I will post it on the main page. 

 

Link to post

Hello @ll!

 

Sorry for my bad english, i have a little problem with this mod... i always get a error message like Armbinder not found and or Punishing Plug not found... can anyone help me pls?

 

An error hat ocurred with you installation of Devious Devices Error Text: LookupDeviceType received invalid Keyword <_SD_DeviousArmbinder 3400CAEF_>

 

 

 

PS: i dont like http://www.loverslab.com/topic/24042-sd-sanguine-debauchery-enhanced-2016-04-18/ 

 

this one here will be perfect, but sure without the errors..

 

 

Greetings

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...