Jump to content
Ashal

SexLab Framework Development

Recommended Posts

 

 

Those checks in the menu for FNIS stuff are all based off animation variables, which can be pretty unreliable as it seems like they cant be retrieved properly if the player hasn't scrolled out to 3rd person at least once since load or are currently in 1st person, not to sure as to the specifics that cause it, but it results in the animation variables being irretrievable (as seen in your debug log) which results in those checks then failing.

 

The is generated and main FNIS version checks themselves are based on hard coded script provided by FNIS. So for those to fail, you either have outdated FNIS scripts or if your using MO (and don't have outdated FNIS scripts overwriting newer ones, such as in your overwrite folder) than in my experience FNIS seems to be kinda hit or miss about being able to update the FNISVersion and FNISGenerated scripts, make sure no FNIS files are in your overwrite folder, and if so move them to a separate FNIS Output mod folder. Running MO as administrator or not seems to have some effect as well.

 

 

That said though, the current Git development version is pretty close to what I plan on releasing as the first 1.60 beta in the next week or so, so let me know if you run into any animation issues while using it.

 

It also has a mostly-finished, and mostly untested, separate orgasms feature that I'm not sure I'll keep or not. It's currently always on in the Git build, but will be toggled in any beta/final release if I do keep it. So if you notice any oddities with orgasms, that's why.

 

Thanks Ashal for your reply. I did uninstall FNIS to check for an orphan script that might account for a possible overwrite. There was indeed a compiled script left behind (FNISVersionGenerated.pex). However, after purging this and re-installing I still get the error in "System Requirements". Oh and I use NMM and not MO.

 

I did comparison of the uncompile scripts for version information.

 

The PapyrusUtils

; Get version of papyrus library. For version 2.8 will be returned 28.
int function GetVersion() global native

and the check in sslSystemConfig.psc

	elseIf CheckSystem == "PapyrusUtil"
		return PapyrusUtil.GetVersion() < 28

now for FNIS in FNISVersionGenerated.psc

Scriptname FNISVersionGenerated Hidden
String Function Get() global

	String Version = "V05.04.02.0" 

	Return Version

EndFunction

but in sslSystemConfig.psc

	elseIf CheckSystem == "FNIS"
		return FNIS.VersionCompare(5, 4, 2) >= 0

would the leading zeros in the string from the FNISVersionGenerated.psc script agree with that comparison in sslSystemConfig.psc? Just a thought.

 

 

 

Update your build to the newest one on git (I literally just pushed it). I stupidly had some bool checks backwards and forgot to update the sexlab behavior files with the animvar. Rerun FNISforUsers after updating.

Link to post

Hello there. I just have a little newbie question :blush: After attempting for a while and not getting any progress even on fresh game and attempting to reinstall all mods in question I've decided to come and Q_Q
 
I upgraded recently from 1.59c to current version on github and noticed none of dlc creatures are available for ummm.. walks on the beach.

 

Is that due to a screw up I did or it simply isn't currently working in this version? Considering its probably my ignorance I've attempted to post a bit of papyrus log down under, perhaps one of you lovely gents can push me in the right direction :angel:

Everything else works.

 

Thanks in advance
 
 

stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [sexLabThread00 (0B061EEF)].sslthreadcontroller.FATAL() - "sslThreadModel.psc" Line 1098
    [sexLabThread00 (0B061EEF)].sslthreadcontroller.StartThread() - "sslThreadModel.psc" Line ?
    [sexLabQuestFramework (0B000D62)].sexlabframework.StartSex() - "SexLabFramework.psc" Line 1228
    [HentaiCreaturesQuest (290012C4)].hentaicreaturesquest.TRAIN() - "HentaiCreaturesQuest.psc" Line 357
    [ (FF000E67)].HentaiCreaturesActor.TRAIN() - "HentaiCreaturesActor.psc" Line 123
    [ (FF000E67)].HentaiCreaturesActor.onBeginState() - "HentaiCreaturesActor.psc" Line 149
    [ (FF000E67)].HentaiCreaturesActor.GotoState() - "Form.psc" Line ?
    [ (FF000E67)].HentaiCreaturesActor.OnActivate() - "HentaiCreaturesActor.psc" Line 47
[06/23/2015 - 09:39:56PM] SEXLAB - ActorAlias[Hentai Seeker] ClearAlias([HentaiCreaturesActor < (FF000E67)>] / [sslActorAlias <alias ActorAlias004 on quest SexLabThread00 (0B061EEF)>]) - Actor present during alias clear! This is usually harmless as the alias and actor will correct itself, but is usually a sign that a thread did not close cleanly.
[06/23/2015 - 09:39:57PM] [CF][Creature Apply] Failure on ["Hentai Seeker" [HentaiCreaturesActor < (FF000E69)>]]; creature isn't registered; race=["HMDaedra" [Race <DLC2SeekerRace (0701DCB9)>]] skin=["HMDaedra" [Armor < (0701DCB7)>]]
[06/23/2015 - 09:39:57PM] SEXLAB - ActorAlias[stormcloak Soldier] ClearAlias([Actor < (FF000CF0)>] / [sslActorAlias <alias ActorAlias003 on quest SexLabThread00 (0B061EEF)>]) - Actor present during alias clear! This is usually harmless as the alias and actor will correct itself, but is usually a sign that a thread did not close cleanly.
[06/23/2015 - 09:39:59PM] SEXLAB - NOTICE: ValidateActor(Hentai Seeker) -- TRUE -- MISS
[06/23/2015 - 09:40:02PM] SEXLAB - [1058.307983]: TIMER BEGIN
[06/23/2015 - 09:40:02PM] SEXLAB - Thread[0]  - Entering Making State
[06/23/2015 - 09:40:02PM] SEXLAB - [0.031982]: Register Events
[06/23/2015 - 09:40:02PM] SEXLAB - ActorAlias[Hentai Seeker] SetActor([HentaiCreaturesActor < (FF000E67)>]) - [sslActorAlias <alias ActorAlias004 on quest SexLabThread00 (0B061EEF)>]
[06/23/2015 - 09:40:03PM] [DCUR] Mod functionality has been shut down. Periodic events cancelled.
[06/23/2015 - 09:40:03PM] SEXLAB - ActorAlias[stormcloak Soldier] SetActor([Actor < (FF000CF0)>]) - [sslActorAlias <alias ActorAlias003 on quest SexLabThread00 (0B061EEF)>]
[06/23/2015 - 09:40:03PM] SEXLAB - [1.045044]: StartThread - Begin
[06/23/2015 - 09:40:03PM] SEXLAB - [0.036011]: StartThread - Validate
[06/23/2015 - 09:40:03PM] SEXLAB - [0.418945]: StartThread - Locate Center
[06/23/2015 - 09:40:03PM] SEXLAB - Thread[0]  - Selecting new creature animations - []
[06/23/2015 - 09:40:03PM] SEXLAB - Thread[0]  - Creature Genders: [0, 1, 1, 0]
[06/23/2015 - 09:40:03PM] Info: SEXLAB - FATAL - Thread[0]  - Failed to find valid creature animations.
stack:
    <unknown self>.Debug.TraceStack() - "<native>" Line ?
    [sexLabThread00 (0B061EEF)].sslthreadcontroller.FATAL() - "sslThreadModel.psc" Line 1098
    [sexLabThread00 (0B061EEF)].sslthreadcontroller.StartThread() - "sslThreadModel.psc" Line ?
    [sexLabQuestFramework (0B000D62)].sexlabframework.StartSex() - "SexLabFramework.psc" Line 1228
    [HentaiCreaturesQuest (290012C4)].hentaicreaturesquest.TRAIN() - "HentaiCreaturesQuest.psc" Line 357
    [ (FF000E67)].HentaiCreaturesActor.TRAIN() - "HentaiCreaturesActor.psc" Line 123
    [ (FF000E67)].HentaiCreaturesActor.onBeginState() - "HentaiCreaturesActor.psc" Line 149
    [ (FF000E67)].HentaiCreaturesActor.GotoState() - "Form.psc" Line ?
    [ (FF000E67)].HentaiCreaturesActor.OnActivate() - "HentaiCreaturesActor.psc" Line 47
[06/23/2015 - 09:40:04PM] SEXLAB - ActorAlias[Hentai Seeker] ClearAlias([HentaiCreaturesActor < (FF000E67)>] / [sslActorAlias <alias ActorAlias004 on quest SexLabThread00 (0B061EEF)>]) - Actor present during alias clear! This is usually harmless as the alias and actor will correct itself, but is usually a sign that a thread did not close cleanly.
[06/23/2015 - 09:40:05PM] SEXLAB - NOTICE: ValidateActor(Lurker) -- FALSE -- They are a creature that is currently not supported (DLC2LurkerRace)

 

 

(in this case I attempted to start action via hentai creature training, I've also attempted with sexlab defeat and matchmaker but to no avail. I am also rather certain that animations are there since they're listed and worked until... I messed something up :lol: )

Link to post

 

 

...

 

[06/23/2015 - 09:40:02PM] SEXLAB - ActorAlias[Hentai Seeker] SetActor([HentaiCreaturesActor < (FF000E67)>]) - [sslActorAlias <alias ActorAlias004 on quest SexLabThread00 (0B061EEF)>]

...

[06/23/2015 - 09:40:03PM] Info: SEXLAB - FATAL - Thread[0]  - Failed to find valid creature animations.

...

 

 

It seems that you have no valid registered creature animation that supports the "Seeker" creature.

Link to post

Yeah, or ash spawn and other dlc creatures. But I have newest versions of everything, ran fnis, and animations for seeker, ash spawn, lurker...  under sexlab mcm/are listed (creature animations enabled, non dlc all work).

So latest, skse, latest sexlab, latest nasty critters, nude creatures, CF, fnis, skeletons. The whole shabbang.

 

Looks like I might have to reinstall everything 

Not smart enough to find whats causing it :dodgy:

 

And here I hoped I've found more work for Ashal :D:P

Link to post

Hello Ashal. Small request to support complex mods.

 

Can you add to the main framework quest script (SexLabFramework) a conditional variable that is set to the number of animations playing?

This will make way more easy to other mods to understand by conditions when an animation (or at least all of them) ended.

 

 

Something like:

scriptname SexLabFramework extends Quest Conditional

Int Property numberOfSexLanRunningAnimations Auto Conditional

And then maybe in the sslTreadController, adding some

Sexlab.numberOfSexLanRunningAnimations += 1 ; "When the playing starts"

Sexlab.numberOfSexLanRunningAnimations -= 1 ; "When the playing ends"

Of course with some safety checking to don't go below zero or to reset it if you stop all the animations together.

 

 

Thank you.

Link to post

Okay so instead of reinstalling everything I've attempted to downgrade Sexlab to 1.59c and I can confirm that all animations work.

Afterwards I've attempted it once again with version from github and encountered same errors.

 

Is there perhaps a different way that 1.60 alpha registers creature animations?

 

 

Update: Tinkering a bit, I've attempted to put sslCreatureAnimationDefaults.pex from 1.59c. Of creatures that previously didn't work Ash spawn, seeker and chaurus work again. Lurker does not.

Link to post

Hello Ashal. Small request to support complex mods.

 

Can you add to the main framework quest script (SexLabFramework) a conditional variable that is set to the number of animations playing?

This will make way more easy to other mods to understand by conditions when an animation (or at least all of them) ended.

 

Of course with some safety checking to don't go below zero or to reset it if you stop all the animations together.

 

 

Thank you.

 

I've added an int property called ActiveAnimations in the newest version on Git.

 

 

Okay so instead of reinstalling everything I've attempted to downgrade Sexlab to 1.59c and I can confirm that all animations work.

Afterwards I've attempted it once again with version from github and encountered same errors.

 

Is there perhaps a different way that 1.60 alpha registers creature animations?

 

 

Update: Tinkering a bit, I've attempted to put sslCreatureAnimationDefaults.pex from 1.59c. Of creatures that previously didn't work Ash spawn, seeker and chaurus work again. Lurker does not.

 

 

You have to re-run FNIS for Users after updating to 1.60's latest version on git, otherwise it can't detect the creature pack. And if your version is more than 3-4 days old, it's not up to date enough as creature detection was broken before then.

Link to post

 

Hello Ashal. Small request to support complex mods.

 

Can you add to the main framework quest script (SexLabFramework) a conditional variable that is set to the number of animations playing?

This will make way more easy to other mods to understand by conditions when an animation (or at least all of them) ended.

 

Of course with some safety checking to don't go below zero or to reset it if you stop all the animations together.

 

 

Thank you.

 

I've added an int property called ActiveAnimations in the newest version on Git.

 

 

Thank you, Ashal.

Appreciated.

Link to post

 

You have to re-run FNIS for Users after updating to 1.60's latest version on git, otherwise it can't detect the creature pack. And if your version is more than 3-4 days old, it's not up to date enough as creature detection was broken before then.

 

 

I have, and I've had latest version at the time that had fixed creature install check. My skyrim folder is messy atm though and would probably require clean install before I could be viable person to shout for possible bugs :blush:

 

I'll give this another go once I can be arsed to do a fresh install of the game :D

 

Thanks both to CPU and Ashal for replies.

Link to post

so no animations are showing in the list or any voices, when i try to start animation i get errors, i have installed all necessary components, i dont know what can be causing it.

[06/25/2015 - 05:55:15PM] SexLab MCM Loaded CurrentVerison: 15913 / 15913

 

You aren't running a proper install of the SexLab 1.60 alpha, this line indicates a 1.59c install, read the pinned threads in the tech support section if you need assistance with 1.59c or older, this thread is for testing newer versions only. 

 

 

 

 

EDIT: Sorry, nevermind that. Been awhile since I've looked at 1.59c's source code, which is 15903, not 15913 as I quickly assumed. Regardless, further investigation of your papyrus log indicates you likely have a bad install of PapyrusUtil, as indicated by the repeated similar errors such as:

 

[06/25/2015 - 05:55:33PM] ERROR: Static function ClearNone not found on object PapyrusUtil. Aborting call and returning None

Link to post

 

You have to re-run FNIS for Users after updating to 1.60's latest version on git, otherwise it can't detect the creature pack. And if your version is more than 3-4 days old, it's not up to date enough as creature detection was broken before then.

 

I have, and I've had latest version at the time that had fixed creature install check. My skyrim folder is messy atm though and would probably require clean install before I could be viable person to shout for possible bugs :blush:

 

I'll give this another go once I can be arsed to do a fresh install of the game :D

 

Thanks both to CPU and Ashal for replies.

 

You need to use Mod Organizer, it keeps the Data and subsequent folders clean so you don't have to go back and clean up after each experiment and you never accidentally miss a file with it because it doesn't install files there in the first place even though it makes the game think it did.

Link to post

So far so good with the new version. Busy testing it on all the various mods I use and so far (once the PapyrusUtil issue was fixed) no issues.

Ashal, is there any chance you could include in the framework a standard function to assign, and store, a sexual preference to an NPC that doesn't have on by default(hetrosexual, bisexual, homosexual)?

There are a few mods starting to use sexual preferences of NPC's and at the moment each has to solve the issue itself, resulting in a different sexuality for the same NPC depending on which mod is being used. Ideally something with an MCN slider so players can control the balance?

Link to post

Ashal was wondering i tried the latest sexlab from the git site but now i get allot of error from fnis stating duplicate anim event from mod nonsexlab animations. does this mean that the latest git from sexlab has the animation from mod nonsexlabAnimation already in it ??

 

 

 

btw what does this papyrus error means ??

 

 

[06/27/2015 - 02:20:11PM] SEXLAB -- sslUtility.PushForm -- DEVELOPMENT DEPRECATION, MOTHER FUCKER - Check PapyrusUtil.psc alternative.

[06/27/2015 - 02:20:11PM] SEXLAB -- sslUtility.PushForm -- DEVELOPMENT DEPRECATION, MOTHER FUCKER - Check PapyrusUtil.psc alternative.
[06/27/2015 - 02:20:11PM] SEXLAB -- sslUtility.PushForm -- DEVELOPMENT DEPRECATION, MOTHER FUCKER - Check PapyrusUtil.psc alternative.
[06/27/2015 - 02:20:11PM] SEXLAB -- sslUtility.PushForm -- DEVELOPMENT DEPRECATION, MOTHER FUCKER - Check PapyrusUtil.psc alternative.

[06/27/2015 - 02:20:11PM] SEXLAB -- sslUtility.PushForm -- DEVELOPMENT DEPRECATION, MOTHER FUCKER - Check PapyrusUtil.psc alternative.

 

Link to post

 

I'm having an issue and have not found anything similar in searching this thread or all the googles.  Anyway, my "toggle animations" menu in the MCM for sexlab is blank.  SKSE 1.7.3 is installed, Sexlab 1.60 alpha3 with patch is installed, and I am using mod organizer.  Any thoughts?  Also, do you need any more relivant data I can provide?  Thanks.  

 

Run the rebuild/reinstall function from the last page of the MCM. If it still doesn't show anything in the list after that, post your debug log from after doing the rebuild/reinstall.

 

Sorry for the late reply, I was at residency and mostly away from LL.  Anyway, here's a screengrab for reference:

 

 

https://www.dropbox.com/s/l4c1boqcanp9qi7/download.jpg?dl=0

 

Attempted the rebuild/reinstall function, though it had no effect.  

 

Finally, I have been having trouble getting any papyrus logging at all.  I have followed numerous guides, but nothing logs; I have also confirmed the integrity of skyrim's files and this is a chronic problem, ranging from multiple installs.  I assume these settings are correct:

 

https://www.dropbox.com/s/wkn0erqxnhclj01/Screenshot%202015-06-28%2012.40.59.png?dl=0

 

Perhaps you can point me in the right direction. 

Link to post

Hey Ashal,

 

Getting ready to test this against my normal mod load. So far, so good. Except :)

 

While looking over the MCM help text (I'm one of those anal "read the docs" guys) I noticed that the help text for 'Player Gender' gets cut off - the last bit of text is 'matches the player g' . 

Link to post

Hi Ashal
Just switched over to 1.6 beta from alpha. It seems the jump button is enabled during animation play, pressing space to advance stage will lead to the player jumping and remain suspended mid air in the falling animation. Changing the advance animation key to something other than space fixes the problem

Link to post

Hello, I'm seeing an issue with animation registrations, be it NSAP or ZAZ, it looks like a given animation will spam all of the available slots. did the registration for NSAP some 10 times each time leaving out the spamming animation and each time another one took its place, removed NSAP and then tried to register ZAZ animations and again, the slots were filled with a single animation.

 

 

Switched to a testing MO profile, basic, vanilla as possible, loaded vanilla save, same result.

 

Also, and maybe not related but while MCM menus were being registered (Sexlab was not activated yet) this popped up in the console:

 

Error: Newanimation (DDYokeSolo) - Failed to create animation - unable to find an animation slot

 

 

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...