Jump to content
IGNORED

Paradise Halls - Diary Of Mine [WIP]


Recommended Posts

1 hour ago, TrollAutokill said:

Version 1.8.0 is out. Try it out to test the new notification system using Gooser's Apropos2 text widgets.

 

Turn on notification in widgets in the MCM menu, it is off by default. If you have Apropos2 installed the DoM widgets will be on the right side on the screen, otherwise they use the left side. There are 8 widgets and slaves will try to reuse the same widget, unless you have more than 8 slaves around.

 

Tried 1.8.0 with the apropos widget and it works for the first slave i have but doesn't work for the second

 

On load it is putting the slave i have in slot 1 into the widget but not the slave i have in slot 2

 


Load.jpg.0c08a5ec10bf5e04a22e9bc9f6b7e381.jpg
 

 

Glathel (slot 1 slave) shows in the widget (strip, praise etc)

 


WorkingSlot1.jpg.dba20d2fda4d14cb19ee4f5a47bcbeaa.jpg
 

 

Tried moving the other one into HSH and then back to see if it would refresh but nothing i tried loads that slave into the slave 2 widget, turning the apropos widget off and going back to the old notifications i do get them for the slot 2 slave (obeying strip, praise etc)

 

When you have lots of slave, some with you and some not how is it determining who to display?

 


List.jpg.f7358a2063aa49695271c6b5a60c7bc7.jpg
 

 

Ones i have with me are Glathel (working in slot 1) and Fentula (not working in slot 2-7) the rest are all tied up in a cell somewhere

Edited by pinky6225
Link to comment
6 minutes ago, pinky6225 said:

 

Tried 1.8.0 with the apropos widget and it works for the first slave i have but doesn't work for the second

 

On load it is putting the slave i have in slot 1 into the widget but not the slave i have in slot 2

  Hide contents


Load.jpg.0c08a5ec10bf5e04a22e9bc9f6b7e381.jpg
 

 

Glathel (slot 1 slave) shows in the widget (strip, praise etc)

  Reveal hidden contents


WorkingSlot1.jpg.dba20d2fda4d14cb19ee4f5a47bcbeaa.jpg
 

 

Tried moving the other one into HSH and then back to see if it would refresh but nothing i tried loads that slave into the slave 2 widget, turning the apropos widget off and going back to the old notifications i do get them for the slot 2 slave (obeying strip, praise etc)

 

When you have lots of slave, some with you and some not how is it determining who to display?

  Reveal hidden contents


List.jpg.f7358a2063aa49695271c6b5a60c7bc7.jpg
 

 

Ones i have with me are Glathel (working in slot 1) and Fentula (not working in slot 2-7) the rest are all tied up in a cell somewhere

Did you try to hit Fentula to trigger a message ? Only the slaves having notifications (around the player) should have a widget allocated to them. if a lsave is next to you and has no notifications they will not have a widget allocated. So try to hit them or praise them to get a message to display.

Edited by TrollAutokill
Link to comment
40 minutes ago, TrollAutokill said:

Did you try to hit Fentula to trigger a message ? Only the slaves having notifications (around the player) should have a widget allocated to them. if a lsave is next to you and has no notifications they will not have a widget allocated. So try to hit them or praise them to get a message to display.

 

Yes i used the enjoying your life, slave? dialogue and then praise on Fentula but nothing showed up, the option did disappear from enjoying your life, slave? so it did go through but no notification

 

Not sure how much these help since running the apropos widget test doesn't trigger the DoM ones (same with widget controls like text size far as i could work out) although i know they are working as i can see them for the first slave

 

Apropos2.0.log

Papyrus.0.log

 

Loaded in, waited for the PAH message about number of slaves, PAHCore Loaded and then praised Fentula and warned her for respect and promised to be gentle (which should all make notifications) and then praised Glathel and told her to strip a couple of times which all did appear in the Apropos widget

 

Also ran the apropos widget test and tried changing down the font size as i only have slave widget 1 to 7, can't see an 8th one you mentioned so was wondering if it was off the screen due to font size/spacing but amending the settings in apropos didn't seem to do anything to the DoM widgets

 

 

Edited by pinky6225
Link to comment
1 hour ago, pinky6225 said:

 

Yes i used the enjoying your life, slave? dialogue and then praise on Fentula but nothing showed up, the option did disappear from enjoying your life, slave? so it did go through but no notification

 

Not sure how much these help since running the apropos widget test doesn't trigger the DoM ones (same with widget controls like text size far as i could work out) although i know they are working as i can see them for the first slave

 

Apropos2.0.log 7.03 kB · 0 downloads

Papyrus.0.log 393.61 kB · 0 downloads

 

Loaded in, waited for the PAH message about number of slaves, PAHCore Loaded and then praised Fentula and warned her for respect and promised to be gentle (which should all make notifications) and then praised Glathel and told her to strip a couple of times which all did appear in the Apropos widget

 

Also ran the apropos widget test and tried changing down the font size as i only have slave widget 1 to 7, can't see an 8th one you mentioned so was wondering if it was off the screen due to font size/spacing but amending the settings in apropos didn't seem to do anything to the DoM widgets

 

 

Ok, I need to make a version with more output.

 

Try this version of the script to have more output.

 

Also you have an error message from SKYUI which could explain why your widgets stop working after a while,

 

WidgetError: [slac_staminawidgetpc <slac_StaminaMeterPC (4706472A)>]: WidgetLoadFailure

 

It seem to come from SLAC stamina meter.

 

 

DOM_Core.pex

Link to comment
38 minutes ago, TrollAutokill said:

Ok, I need to make a version with more output.

 

Try this version of the script to have more output.

 

Also you have an error message from SKYUI which could explain why your widgets stop working after a while,

 

WidgetError: [slac_staminawidgetpc <slac_StaminaMeterPC (4706472A)>]: WidgetLoadFailure

 

It seem to come from SLAC stamina meter.

 

 

DOM_Core.pex 56.78 kB · 2 downloads

 

That shouldn't be active, believe its from sexlab aroused creatures which i have to only go for female NPC's so my male PC should never get an encounter to have that stamina meter appear

 

Tried the new .pex and didn't work for the slave i had with me but when i went and got a new slave out of molags temple and timed it right that then went into slave widget 2

 



Widget2.jpg.efc97b9ec67497c40fa98ad2dce06177.jpg

 

Re-loading after doing that the slave seems to have reserved that slot



LoadWith2Slot.jpg.93254195f16deabf1a0f477ec5d6b33e.jpg

 

What is the expected result if you have slave 1 (Glathel) in widget 1, no message present and then you do something to another slave? Should that load into widget 1 (replacing Glathel) or load into its own slave widget (widget 2 in this case)?

Link to comment
13 minutes ago, pinky6225 said:

 

That shouldn't be active, believe its from sexlab aroused creatures which i have to only go for female NPC's so my male PC should never get an encounter to have that stamina meter appear

 

Tried the new .pex and didn't work for the slave i had with me but when i went and got a new slave out of molags temple and timed it right that then went into slave widget 2

 

 

  Reveal hidden contents

 

 


Widget2.jpg.efc97b9ec67497c40fa98ad2dce06177.jpg
 

 

 

 

Re-loading after doing that the slave seems to have reserved that slot

 

  Hide contents

 

 


LoadWith2Slot.jpg.93254195f16deabf1a0f477ec5d6b33e.jpg
 

 

 

 

What is the expected result if you have slave 1 (Glathel) in widget 1, no message present and then you do something to another slave? Should that load into widget 1 (replacing Glathel) or load into its own slave widget (widget 2 in this case)?

Once a widget is allocated the slave will always use the same until another slave claims it. And that will happen if all 8 widgets are already taken.

 

The PEX file I gave you is to make another log with more output. Try to make slave do notifications and if nothing appears in any widget post the log here.

Link to comment
21 minutes ago, TrollAutokill said:

Once a widget is allocated the slave will always use the same until another slave claims it. And that will happen if all 8 widgets are already taken.

 

The PEX file I gave you is to make another log with more output. Try to make slave do notifications and if nothing appears in any widget post the log here.

Papyrus.0.log

 

Is with the two original slaves i had, Glathel in slot 1 - widget showing, Fentula - not appearing in widget 2

 

Tried changing cell without Fentula thinking that might be why the new slave i fetched worked but same result

 

Also noticed minor issue, when the message is long like - "Start punishment of a loving Glathel with Pain for no reason" its only just fitting, the n is at the edge of the screen so anything longer is going to go off screen unless its set to wrap

 

Edit: Looking at the log

 

Might be off track but noticed for Fentula i have - DOMMessageWidget0 (3F033230)> and Glathel - <DOMMessageWidget1 (3F1CF282)> so assuming DOMMessageWidget is the one it should use its trying to use widget 0 rather than widget 2

Edited by pinky6225
Link to comment
4 hours ago, pinky6225 said:

Papyrus.0.log 435.47 kB · 0 downloads

 

Is with the two original slaves i had, Glathel in slot 1 - widget showing, Fentula - not appearing in widget 2

 

Tried changing cell without Fentula thinking that might be why the new slave i fetched worked but same result

 

Also noticed minor issue, when the message is long like - "Start punishment of a loving Glathel with Pain for no reason" its only just fitting, the n is at the edge of the screen so anything longer is going to go off screen unless its set to wrap

 

Edit: Looking at the log

 

Might be off track but noticed for Fentula i have - DOMMessageWidget0 (3F033230)> and Glathel - <DOMMessageWidget1 (3F1CF282)> so assuming DOMMessageWidget is the one it should use its trying to use widget 0 rather than widget 2

According to your log, Fentual uses widget0 and Glathel widget1.

 

So you should see Glathel's messages appear below Fentula's.

 

It seems your widget0 is not showing up. Could be related to displaying them on the right side.

 

Try disabling Apropos2 and see if you can get Fentual's notifications when widgets are on the left.

Edited by TrollAutokill
Link to comment
1 hour ago, TrollAutokill said:

According to your log, Fentual uses widget0 and Glathel widget1.

 

So you should see Glathel's messages appear below Fentula's.

 

It seems your widget0 is not showing up. Could be related to displaying them on the right side.

 

Try disabling Apropos2 and see if you can get Fentual's notifications when widgets are on the left.

 

Gave that a try but no still not widget 0 as it starts at 1 and shows to 7



Widget1to7.jpg.08267cb85e63186c55de4383efbe8a37.jpg

 

Tried on a save where i don't have any slaves with me and also just shows slave 1 to 7



empty1to7.jpg.e882e72b6d5697765f4bb7b4e7e9f24f.jpg

 

From the spacing widget 0 should be just below where its saying Using Paradise Halls with Diary of Mine so tried turning off sexlab arousal widget monitor (https://www.loverslab.com/files/file/11466-sexlab-aroused-monitor-widget-se/)in case that was interfering but same result, no widget/slave 0 on load

 

Link to comment
9 hours ago, pinky6225 said:

 

Gave that a try but no still not widget 0 as it starts at 1 and shows to 7

 

  Reveal hidden contents

 

 


Widget1to7.jpg.08267cb85e63186c55de4383efbe8a37.jpg
 

 

 

 

Tried on a save where i don't have any slaves with me and also just shows slave 1 to 7

 

  Reveal hidden contents

 

 


empty1to7.jpg.e882e72b6d5697765f4bb7b4e7e9f24f.jpg
 

 

 

 

From the spacing widget 0 should be just below where its saying Using Paradise Halls with Diary of Mine so tried turning off sexlab arousal widget monitor (https://www.loverslab.com/files/file/11466-sexlab-aroused-monitor-widget-se/)in case that was interfering but same result, no widget/slave 0 on load

 

Hmm. We have to keep searching, so we can detect the mod using that space and turn off widget 0.

 

Try a new game "coc riverwood" in the console when you are at the main menu. Check if problem is still present (use the Dom hotkey to quick capture slaves).

 

Do the same with as little mods as possible (sexlab, pahe, aroused and Dom).

Edited by TrollAutokill
Link to comment
7 hours ago, TrollAutokill said:

Hmm. We have to keep searching, so we can detect the mod using that space and turn off widget 0.

 

Try a new game "coc riverwood" in the console when you are at the main menu. Check if problem is still present (use the Dom hotkey to quick capture slaves).

 

Do the same with as little mods as possible (sexlab, pahe, aroused and Dom).

 

New game does show widget 0, tried new game and then starting apropos and DoM in the live another life starter cell then saving and loading to see what appears and there i have the widget

 


NewGame.jpg.1b06e30b57f80ceb95dac50a7c48590c.jpg
 

 

Starting a new game moving from 1.7.4 to 1.8.0 if you want to use the slave widgets rather than debug notifications seems the way to go

 

EDIT: Weirdly if i go back a couple of hundred saves (i make a lot of saves) then it displays all of them on that character

 


PreBlackThornAndHelgen.jpg.10a8ae560f4c6b79f6d4c33dfd115731.jpg
 

Only thing i really did was add in blackthorn manor and helgen reborn although neither of those have widgets i'm aware of so can't think why that would bother it, might be something else i did on that character that upset it

 

Disabling those made no difference so it seems if it goes wrong on the initial load it stays wrong but if you get all of them on the first load of that save then your fine

 

 

Edited by pinky6225
Link to comment
On 9/10/2021 at 9:30 AM, TrollAutokill said:

Ok, I see the error from your logfile is coming because the LE plugin is missing the trait-generation quest. And you are using PAHE 7.5.9wip.

 

Could you try again with 1.8.0 ? And if still does not work, without PAHE-wip ?

 

 

Updated to 1.8.0 and tried again, no real change. Only noticeable difference was that the responses from enslaved NPCs didn't change to that overly verbose form after rebooting PAHE this time.

 

I don't have a copy of PAHE 7.5.8 LE handy, as I've been busy with other stuff for a while and hadn't updated that mod since 7.3.9. I'm a bit leery of rolling a mod back that far mid-game, so instead I tried starting a whole new game to see if that would get this trait quest un-stuck. And it did! A quick test gave me a bunch of properly varied responses from different NPCs. But having to abandon the game I've spent the last month on is a less than ideal solution to this issue, so I decided to see if I could manually reboot DoM by disabling it, making a save with it turned off, cleaning that save and then loading it with DoM turned back on. That seems to have worked, as I've got varied responses back in my current game, although they are of course noticeably not the same personalities the actors had before.

 

Spoiler

485958743_ScreenShot09-11-21at10_07AM.jpg.f4d80b37a6b74797dc04c54f34044fd6.jpg200789330_ScreenShot09-11-21at10.07AM001.jpg.54c41758a87797329a3b4efe296c3657.jpg222875570_ScreenShot09-11-21at10_08AM.jpg.7736461eedfd0a102fc5a7135768f6b9.jpg

Current responses

 

443269246_ScreenShot08-03-21at10_49AM.jpg.45d08a68f93707584d0b1d7b2dcdc17c.jpg372763726_ScreenShot08-10-21at08_49AM.jpg.267c694ea7d268754d8a5974d4f4964f.jpg

Previous responses

 

Interestingly, it does seem to have maintained the stats for the enslaved NPCs, as they appear to still have the same numerical ratings, emotional states, and even friends as from before the 'reboot'. I guess those are stored somewhere and it regenerated that information from there? 

 

Spoiler

1131437151_ScreenShot09-11-21at10.07AM002.jpg.cf5fb0e97dfea7ee9788ced3559cd9c7.jpg

 

So that solved the immediate issue, but I'm still not sure what caused the trait quest to get stuck. The only proximate event that I can think of was simply updating the mod. This manual 'reboot' seems to have worked, but it remains to be seen if it will result in any new issues going forward. Perhaps an in-game reboot function similar to the one PAHE has would be a useful addition to the mod, in the event that someone else runs into a similar problem with functions going awry? 

 

 

Link to comment
49 minutes ago, AVS said:

Interestingly, it does seem to have maintained the stats for the enslaved NPCs, as they appear to still have the same numerical ratings, emotional states, and even friends as from before the 'reboot'. I guess those are stored somewhere and it regenerated that information from there? 

i can't speak for the friends or other seeds like personality, but most other stats are stored by pahe while reinstaling dom.

53 minutes ago, AVS said:

So that solved the immediate issue, but I'm still not sure what caused the trait quest to get stuck. The only proximate event that I can think of was simply updating the mod. This manual 'reboot' seems to have worked, but it remains to be seen if it will result in any new issues going forward. Perhaps an in-game reboot function similar to the one PAHE has would be a useful addition to the mod, in the event that someone else runs into a similar problem with functions going awry? 

there's a quest portion in pahe that reboots all the quests when reboot is chosen

Link to comment
2 hours ago, pinky6225 said:

 

New game does show widget 0, tried new game and then starting apropos and DoM in the live another life starter cell then saving and loading to see what appears and there i have the widget

  Hide contents


NewGame.jpg.1b06e30b57f80ceb95dac50a7c48590c.jpg
 

 

Starting a new game moving from 1.7.4 to 1.8.0 if you want to use the slave widgets rather than debug notifications seems the way to go

 

EDIT: Weirdly if i go back a couple of hundred saves (i make a lot of saves) then it displays all of them on that character

  Reveal hidden contents


PreBlackThornAndHelgen.jpg.10a8ae560f4c6b79f6d4c33dfd115731.jpg
 

Only thing i really did was add in blackthorn manor and helgen reborn although neither of those have widgets i'm aware of so can't think why that would bother it, might be something else i did on that character that upset it

 

Disabling those made no difference so it seems if it goes wrong on the initial load it stays wrong but if you get all of them on the first load of that save then your fine

 

 

Maybe try resaver and look for dommessage in your save game. Remove all reference to dommessage and save on another name. It could be some old lost reference from a previous try

Link to comment
1 hour ago, AVS said:

 

Updated to 1.8.0 and tried again, no real change. Only noticeable difference was that the responses from enslaved NPCs didn't change to that overly verbose form after rebooting PAHE this time.

 

I don't have a copy of PAHE 7.5.8 LE handy, as I've been busy with other stuff for a while and hadn't updated that mod since 7.3.9. I'm a bit leery of rolling a mod back that far mid-game, so instead I tried starting a whole new game to see if that would get this trait quest un-stuck. And it did! A quick test gave me a bunch of properly varied responses from different NPCs. But having to abandon the game I've spent the last month on is a less than ideal solution to this issue, so I decided to see if I could manually reboot DoM by disabling it, making a save with it turned off, cleaning that save and then loading it with DoM turned back on. That seems to have worked, as I've got varied responses back in my current game, although they are of course noticeably not the same personalities the actors had before.

 

  Reveal hidden contents

485958743_ScreenShot09-11-21at10_07AM.jpg.f4d80b37a6b74797dc04c54f34044fd6.jpg200789330_ScreenShot09-11-21at10.07AM001.jpg.54c41758a87797329a3b4efe296c3657.jpg222875570_ScreenShot09-11-21at10_08AM.jpg.7736461eedfd0a102fc5a7135768f6b9.jpg

Current responses

 

443269246_ScreenShot08-03-21at10_49AM.jpg.45d08a68f93707584d0b1d7b2dcdc17c.jpg372763726_ScreenShot08-10-21at08_49AM.jpg.267c694ea7d268754d8a5974d4f4964f.jpg

Previous responses

 

Interestingly, it does seem to have maintained the stats for the enslaved NPCs, as they appear to still have the same numerical ratings, emotional states, and even friends as from before the 'reboot'. I guess those are stored somewhere and it regenerated that information from there? 

 

  Reveal hidden contents

1131437151_ScreenShot09-11-21at10.07AM002.jpg.cf5fb0e97dfea7ee9788ced3559cd9c7.jpg

 

So that solved the immediate issue, but I'm still not sure what caused the trait quest to get stuck. The only proximate event that I can think of was simply updating the mod. This manual 'reboot' seems to have worked, but it remains to be seen if it will result in any new issues going forward. Perhaps an in-game reboot function similar to the one PAHE has would be a useful addition to the mod, in the event that someone else runs into a similar problem with functions going awry? 

 

 

Stats, traits and 12 modifiers are saved in factions for slaves, old slaves (the first time they are enslaved) and lovers (the first time you ask them their traits). Then any change is saved in the factions. For other NPC the DoMgenerator quest create them on the fly.

 

It seems the Dom generator quest was not properly started for you. Restarting DoM did the trick.

Link to comment
24 minutes ago, CliftonJD said:

i can't speak for the friends or other seeds like personality, but most other stats are stored by pahe while reinstaling dom.

Friends and traits are stored in the Pahe structure, that's why.

24 minutes ago, CliftonJD said:

there's a quest portion in pahe that reboots all the quests when reboot is chosen

By the way it seems Pahcore is initialized with OnGameLoad, but not with OnInit. That might explain some glitches I have seen, like the need to save a new game and reload for Pahe to work.

 

I added an OnInit event to pahcore in 1.8.0, maybe you want to do that in Pahe also.

Edited by TrollAutokill
Link to comment
2 hours ago, TrollAutokill said:

Maybe try resaver and look for dommessage in your save game. Remove all reference to dommessage and save on another name. It could be some old lost reference from a previous try

 

Thanks for the hint, i think i worked out why i can't see it as the X placement is 1285 when a working one is 985

 

The WidgetName_Var was also different to the value i have on a working save

 

image.png.96c770a8003fcbb3c554291e8e5936c6.png

 

Sadly updating the _x in the script instance doesn't seem to take as it gets overwritten back to 1285 when i tried setting it to 985 and adjusting the _y of the remaining ones

Link to comment
2 hours ago, TrollAutokill said:

Friends and traits are stored in the Pahe structure, that's why.

By the way it seems Pahcore is initialized with OnGameLoad, but not with OnInit. That might explain some glitches I have seen, like the need to save a new game and reload for Pahe to work.

 

I added an OnInit event to pahcore in 1.8.0, maybe you want to do that in Pahe also.

that should be handled in the boot:

Spoiler

Function Boot()
    bool isActive
    PAH.modStatus = "restarting"
    Debug.Notification("Paradise Halls: Testing System")
    TestSKSE()
    If PAH.IsRunning()
        isActive = PAH.isActive()
        Debug.Notification("Paradise Halls: Restarting Quest")
        RestartQuests()
    else
        Debug.Notification("Paradise Halls: Starting Quest")
    EndIf
    EnsureStartedUp()
    Debug.Notification("Paradise Halls: Setting Properties")
    SetProperties()
    Debug.Notification("Paradise Halls: Finalizing Slaves")
    SendBootstrapEvents()

 

 

Spoiler

Event OnBootstrap()
    RegisterForSingleUpdate(0.5)
    SetObjectiveDisplayed(0)
    OnPlayerLoadGame()
EndEvent

 

during the final boot stages, you should reach this event and receive a notice pahcore loaded

Link to comment
10 hours ago, CliftonJD said:

that should be handled in the boot:

  Reveal hidden contents

Function Boot()
    bool isActive
    PAH.modStatus = "restarting"
    Debug.Notification("Paradise Halls: Testing System")
    TestSKSE()
    If PAH.IsRunning()
        isActive = PAH.isActive()
        Debug.Notification("Paradise Halls: Restarting Quest")
        RestartQuests()
    else
        Debug.Notification("Paradise Halls: Starting Quest")
    EndIf
    EnsureStartedUp()
    Debug.Notification("Paradise Halls: Setting Properties")
    SetProperties()
    Debug.Notification("Paradise Halls: Finalizing Slaves")
    SendBootstrapEvents()

 

 

  Reveal hidden contents

Event OnBootstrap()
    RegisterForSingleUpdate(0.5)
    SetObjectiveDisplayed(0)
    OnPlayerLoadGame()
EndEvent

 

during the final boot stages, you should reach this event and receive a notice pahcore loaded

Last time I tried a new game this was never called...

Edited by TrollAutokill
Link to comment
8 hours ago, CliftonJD said:

hmm, strange indeed. will run some tests with extra logging enabled and try out the OnInit event for next update

With my test the logfile never mentioned anything about Pahe starting and all factions were screwed. DoM did start correctly though... And yes, I waited like 5 minutes for all the mods to start. But I started the new game with "coc riverwood", so that might be a bit harsh.

 

The OnInit solution might result in calling the initialize part twice in some cases. But it should not be a problem. The question is: does this problem happen often, or is it just my configuration triggering it?

Edited by TrollAutokill
Link to comment
1 hour ago, seathblack said:

Can someone help me? What all do I download? just the one file? The game keeps CTD only with this mod. Thanks!

Hi, first are you using LE or SE?

On the mod page there are requirements for this mod: Pahe 7.5.8 (not tested with 7.5.9 nor 8.0, try at your own risk), Slavetats, Sexlab, zaz pack and sexlab aroused. FNIS is also needed for all animations to work.

 

Edited by TrollAutokill
Link to comment

An idea I thought of today. If kill a Dragon or Giant in front of a slave, raising their respect and/or fear might be interesting. The thought is that, "If this person can do that to a dragon, what chance do I stand."  Since it is not that frequent, generally, it should add something interesting with out overpowering anything.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...