Jump to content
IGNORED

Demonic Creatures - Current version V1.5 LE & SE


Recommended Posts

I ran into a problem in Angarvunde that this mod might have caused, but I'm not sure.  You're supposed to kill three Draugr that are wandering around in the central area.  When I arrived, there were only two, one of which was a replacement from this mod.  The other was a regular Draugr.  I checked SQV dunAngarvundeQST (which is the quest that runs this dungeon) and one of the three draugr variables was empty.  I don't know if that was a screw up in my game, or if this mod replaced two with one...  To get past it all I had to do was SQV dunAngarvundeQST 20.

Link to comment
8 hours ago, Naps-On-Dirt said:

I ran into a problem in Angarvunde that this mod might have caused, but I'm not sure.  You're supposed to kill three Draugr that are wandering around in the central area.  When I arrived, there were only two, one of which was a replacement from this mod.  The other was a regular Draugr.  I checked SQV dunAngarvundeQST (which is the quest that runs this dungeon) and one of the three draugr variables was empty.  I don't know if that was a screw up in my game, or if this mod replaced two with one...  To get past it all I had to do was SQV dunAngarvundeQST 20.

Gonna check it. Central area, is that the area you first arrive in or is it in the end?

 

EDITED: I ran through it. I got 3 actors show up where two of the actors was from Demonic. One draugr brute and one human skeleton. I killed all three and got quest marker completed and ran back to medresi and she gave me the key to open the doors.

 

Do you have a save from that quest stage? Can you use aurora whisper or anything and check if there is a third lifeform present that you maybe did not see?

I'm suscpecting that it might be an invisible actor I've used to increase randomness in spawns that might have been your third actor in this case. It spawns through a LCHARDaedra list. I have removed it in v1.5. But it would sure be nice to know for sure that it was it. It's very small, but it will be located in the same spot where the draugr would have been placed.

 

I should probably mention on front page, that if one of those  human adventurers/hunters/bandits/vigilants or whatever spawns in a place like this, they will fill the role of one of these three quest actors and actually needs to be killed regardless of their hostility. Otherwise the quest won't progress.

 

ScreenShot998.png

ScreenShot999.png

ScreenShot1000.png

Edited by Thor2000
Link to comment
5 hours ago, Thor2000 said:

Do you have a save from that quest stage? Can you use aurora whisper or anything and check if there is a third lifeform present that you maybe did not see?

 

I don't anymore, sorry I should have thought to make a save.  I think then that this was just Skyrim screwing up in my game, failing to load one of the three mobs.  I didn't check with Aura Whisper, but like I mentioned in my post, I looked at SQV and one of the three variables was unset, so there was no third mob to kill.  I'm getting close to the time to start a new playthrough, I'll go here early in my game to see if I have this problem again.  Thanks for looking into it!  :)

 

Link to comment

Feedback:

 

Companions quest  Proving Honor. The final coffin-door can't open after the battle. because the Dragur behind the door is unable to push it out.

 

But it can be dealt with by the command tcl. You can tcl behind the door to kill it and run foward. It won't make the mission freeze.

 

Over.

Link to comment
47 minutes ago, RebyaAs said:

Feedback:

 

Companions quest  Proving Honor. The final coffin-door can't open after the battle. because the Dragur behind the door is unable to push it out.

 

But it can be dealt with by the command tcl. You can tcl behind the door to kill it and run foward. It won't make the mission freeze.

 

Over.

What type of draugr was inside? Looking at inside CK now. There is only vanilla draugr and a couple of draugrrace creatures from this mod present. Strange that it didn't open.

Link to comment

Very interesting mod, would like to play it one day. Too tired of restarting skyrim atm.

 

Check out: https://www.nexusmods.com/skyrimspecialedition/mods/25504

 

That mod places exploding spiders to create mobs. You can place whatever explosion animations, like spider eggs breaking etc.

 

I was able to copy it to summon a hoard of female undeads from FEMALE https://www.nexusmods.com/skyrimspecialedition/mods/17089

Link to comment
2 hours ago, ssskn said:

Also is there an easy way to see which monsters are rigged to which creature skeletons? Preferably in xEdit or in nif meshes.

You can check the list of creatures (ods file) located in the "dinofree free version & document" download. Most of the creatures are listed with its race.

 

Thanks for the mod suggestion btw... It might be a good way to spawn a zombie hord too ?

Edited by Thor2000
Link to comment
9 hours ago, Thor2000 said:

You can check the list of creatures (ods file) located in the "dinofree free version & document" download. Most of the creatures are listed with its race.

 

Thanks for the mod suggestion btw... It might be a good way to spawn a zombie hord too ?

For sure, you can hand place exploding spiders like other NPCs or add them into LL as well. I added the FEMALE undead spider NPC into LCharAmbiantCreatures, so it can summon a hoard instead of just 1 undead. The spider NPC will self-destruct with an explosion and that explosion will contain the NPCs you want. 

 

Anyways I like most of the monsters in your mod, but some I would like to replace with different models -once its finished.

And earlier I was able to rig these two with dicks. Tested and worked in game too. Not sure if you want them or if I can even share, permissions are annoying.

Any idea how I can give KS hair to giant? I tried but no go.

 

Spoiler

cd1.PNG.c6d8baa34e8f2c3244741fdf92147941.PNG

cd2.PNG.07d5c86cb9dd22527a5347ae72ef1f26.PNG

 

Link to comment
On 8/20/2021 at 8:51 PM, Thor2000 said:

I need to check this, but I'd expect to find separate colored triggerboxes in front of each "scene" makes the event start once you enter it. Not sure how its connected to creature spawns.

 

I've done this quest maybe three times with the mod installed.  I had one issue at the final end which I now know is caused by wrong creatures in coffins. Will check it once I get time ?.

 

Zombies: There's not many 3d models around that's free to use.

 

These oblivion zombies seems interesting. Only concern would be texture quality. They are even marked as modders resource.

https://www.nexusmods.com/oblivion/mods/49941?tab=description

https://www.nexusmods.com/oblivion/mods/19017?tab=description

 

Also considering some variants from the skyrim creepy zombie mod. They need some love and care though.

 

 

 

 

 

The isssue with the Potema quest involves Data\meshes\clothes\yarlclothes03. If it is modified it messes up the quest. If you rename this folder for the duration of the quest it appears to work ok. Once the quest is done just put the name back.

Edited by chimchimny
Link to comment

Does anyone know a guide or tell how to add schlongs to new creatures?
 

there was a forum I seen before that had some support and adding new creatures with schlongs But I cant find that forum so am asking on here
 

Edited by wabble07875
Link to comment
41 minutes ago, wabble07875 said:

Does anyone know a guide or tell how to add schlongs to new creatures?
 

there was a forum I seen before that had some support and adding new creatures with schlongs But I cant find that forum so am asking on here
 

you can check madman for his tutorial,
 

 

Link to comment
15 hours ago, ssskn said:

Anyways I like most of the monsters in your mod, but some I would like to replace with different models -once its finished.

And earlier I was able to rig these two with dicks. Tested and worked in game too. Not sure if you want them or if I can even share, permissions are annoying.

Any idea how I can give KS hair to giant? I tried but no go.

 

  Reveal hidden contents

cd1.PNG.c6d8baa34e8f2c3244741fdf92147941.PNG

cd2.PNG.07d5c86cb9dd22527a5347ae72ef1f26.PNG

Where is the female giant from? Beast of Tamriel? I think they have open resource on the creatures that they themselves rigged. To get KS hair:

 

This will give the best result if excisting hair is a separate submesh. Otherwise you either need to delete those vertices after you have attacked the new hair.

 

Open desired KS hair in nifscope, select nitrishape, export as obj.

Open your female giant in Otfitstudio . In OS settings, make sure you have the skeleton the giant uses. Default will be a female human skeleton. This is important.

Then -> Import file from obj, select ur hair obj

Then scale, move, rotate this new mesh so it fits the giants head

Then select the giant head/body/hair and set it as reference. Go to bone tab of this mesh and select all bones.

Go to your new hair mesh again, rightclick select copy selected weights. Increase those radius sliders a couple of notches up

Then export the whole thing to a new nif file. If unweighted vertices warning comes, you have to manually weightpaint the missing area of the hair that does not have weights attached.

Tip here is to inverse the mask (the mask will automatically cover the unweighted vertices, so therefore you invert the mask to cover the already weighted vertices

Make sure all weight colors align so it looks "nice" then export again. until the warning of unweghted vertices is gone.

Last, check the new exported nif inside nifscope. Check that all bone nodes are arranged the same way as they did before this operation. Sometimes things screw up.

I don't think OS is really meant for rigging 😁

7 hours ago, zarza said:

I do not remember if they are from this mod, but they are little devils, if someone has a photo or the code to be able to get them through the console could you give it to me?

That little reddish one? Type help "skeleton devil"

 

10 hours ago, chimchimny said:

The isssue with the Potema quest involves Data\meshes\clothes\yarlclothes03. If it is modified it messes up the quest. If you rename this folder for the duration of the quest it appears to work ok. Once the quest is done just put the name back.

Darn you are right. Seems to be a wellknown issue. I have replaced the outfits in yarlclothes03 folder myself, but demonic creatures doesn't alter that outfit though, but its good info. Demonic Creatures edits the LCHARwarlockMale which Potema uses factions and AI data from. It might be that the creatures of this mod does not have the required factions and spells that Potema needs. In v1.5 I reverted her to use vanilla settings.

Link to comment

I'm sorry if I'm missing something really obvious, but I just installed this mod for the first time and started a new game to test it. :x

 

While I was watching the flood of notifications that always show up when I start a new game, I noticed a bunch of them that said something along the lines of "DemonicCreatures.json creature [number] missing race or name". I'm paraphrasing because I am super tired and didn't think of getting a screenshot until just this second. Is that normal? Could it be happening because I installed the "No Dino" version?

Edited by shar181
Link to comment
9 minutes ago, shar181 said:

 "No Dino" version?

 

If you did what i think you did, you just downloaded the no dino version and installed it right? The no Dino Version is not the entire mod. You need to install the "Normal" Version of demonic, then switch the esp with the one of the no dino version in your Data Folder.

Link to comment
1 minute ago, Gukahn said:

 

If you did what i think you did, you just downloaded the no dino version and installed it right? The no Dino Version is not the entire mod. You need to install the "Normal" Version of demonic, then switch the esp with the one of the no dino version in your Data Folder.

 

Oh, I definitely installed the main version as well! I installed the 'no dino" version afterwards.

 

Got a screenshot of the notifications:

Spoiler

ScreenShot240.png.40ad2d9178976dfadbbc92437ebd29e8.png

 

Link to comment
9 minutes ago, shar181 said:

 

Oh, I definitely installed the main version as well! I installed the 'no dino" version afterwards.

 

Got a screenshot of the notifications:

  Reveal hidden contents

ScreenShot240.png.40ad2d9178976dfadbbc92437ebd29e8.png

 

 

By installed you mean with your mod manager correct?
Try to just switch the esp of the main mod with the one of the no dino version. (After uninstalling it with the manager.)
If that doesn't do the trick.. Maybe reinstall the mod completly and try it without the noDino ver. first. :/ It sounds like the mod didn't got installed correctly.

 

Link to comment
9 minutes ago, Gukahn said:

 

By installed you mean with your mod manager correct?
Try to just switch the esp of the main mod with the one of the no dino version. (After uninstalling it with the manager.)
If that doesn't do the trick.. Maybe reinstall the mod completly and try it without the noDino ver. first. :/ It sounds like the mod didn't got installed correctly.

 

 

I'll do that as my next step if this turns out to be nothing, but I noticed something a little weird when I was checking the files inside the main Demonic Creatures archive.

 

Inside the Data folder, it contains the .esp and six subfolders; textures, sound, skse, scripts, meshes, and... "creatures.d".

 

That last one seems like a real weird way to name a folder. Is that ".d" a typo, by any chance? That folder happens to be the one which contains all of the .json files.

 

Edit: Replacing the .esp with the one from the main mod archive did not solve the problem.

Edited by shar181
Link to comment
5 minutes ago, shar181 said:

 

 

 

That last one seems like a real weird way to name a folder. Is that ".d" a typo, by any chance? That folder happens to be the one which contains all of the .json files.

Can't say and even if, the mod works for most of us :/ so it shouldn't be the cause of your issue right now. Of course i could be wrong, using the SE  Version of the mod. Which begs the question, you installed the right version for your game right? Sometimes it gets a little confusing and one does that without notice :)

Link to comment

Yeah, I have the right version. x3 "Demonic Creatures V1.4 Special Edition".

 

For the record, the name of that folder is definitely not a typo. Just to test it, I changed the name to "creatures". Completely broke the Creature Framework. I guess I'll try reinstalling it!

Link to comment
Just now, shar181 said:

Yeah, I have the right version. x3 "Demonic Creatures V1.4 Special Edition".

 

For the record, the name of that folder is definitely not a typo. Just to test it, I changed the name to "creatures". Completely broke the Creature Framework. I guess I'll try reinstalling it!

keep us updated if it works or don't work :)

Link to comment
44 minutes ago, Gukahn said:

keep us updated if it works or don't work :)

 

Well, I'm sorry I wasted your time with this issue. The problem has been resolved, but not because I reinstalled it: it turns out that the mod manager I use disabled the .esp after I installed the mod. It does this all the time, but I forgot to double check before I started up Skyrim. Enabling the .esp made the mod work; go figure. x.x

 

Edit: I just spawned in a few goblins for testing purposes, and this is now my new favorite mod! >:3

Edited by shar181
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...