Jump to content
Sign in to follow this  
Vandalarius

Kinky World Remove Problem

Recommended Posts

Hello, i have installed OKW but my game ended up running slow and i had to disable the mod. But before remove the mod, i saved and quit the game.

 

Then i deleted all KW animations and mod itself in the Electronic/Arts/TheSims3/Mods/Packages  folder without clicking "uninstall" section then restarted the game. Appearently all sims in the town are all disappeared. Now the town looks empty. How can i fix it or is it possible to fix? 

 

Please help me i don't want to lose my family where i spent my days for their progression. I don't want my hard works to go nowhere :(

20201119_164615.jpg

20201119_164558.jpg

Share this post


Link to post
4 hours ago, Vandalarius said:

But before remove the mod, i saved and quit the game.

 

Then i deleted all KW animations and mod itself in the Electronic/Arts/TheSims3/Mods/Packages  folder without clicking "uninstall" section then restarted the game. Appearently all sims in the town are all disappeared. Now the town looks empty. How can i fix it or is it possible to fix? 

The only way I see here is to re-setup the game as of the time you did the last save with KW (Animations are not necessary to reinstall). Load the game open the KW menu and click uninstall the mod (KW).

After that, do another renamed save. Then you remove KW and the related packages again and try to load the new save.

This is the only way I consider as maybe working to get rid of KW and keeping your world. Good Luck !

Share this post


Link to post
21 hours ago, Clydie said:

The only way I see here

Agreed! THIS should be #1 at the top of user instructions on the OP since most mod users aren't deep enough into mods to understand the intricacies of script use, save functions, and the concept of a mod which has it's own registration tool (this is a major give-away).

 

I recommend pausing the game and using reset world before un-registering as well, to keep the game from adding anything to the queue before removal and creating a new 'cleaned' save.

 

>This needs to be done on EVERY SAVE which had KW use if those saves are to be used in the future without KW. (This would take me several hours as I have just over 90 saves with KW). Out of the four 'auto saves' made with NRaas 'saver', I usually only keep the last two.

Share this post


Link to post
On 11/19/2020 at 8:58 AM, Vandalarius said:

i spent my days for their progression.

It may be two parts. I have had this problem. First, load a save BEFORE you removed KW. After everything loads, including KW, go to the menu and disable KW... do NOT uninstall yet... only select "disable" option. This will stop KW script interactions. Save your game using "Save As". Always use "Save As", as it creates a completely new file, and your original will remain safe. After you save the game, quit, and then restart with the new save that KW is disabled. Check that everything you want remains. Understand that ALL interactions, traits, moodlets, sexbot chips, anything that is part of KW will not be there... SHOULD NOT be there.

 

At this point, it is possible to play your game. If you still want to remove KW, now return to the KW menu and click "uninstall". Again use "Save As" to create a new save file, then quit without saving again. Now, restart and load that last save, and you should be okay.

 

Your original problem may be that your machine can not handle the extra load. There are links to info on this page that I posted...

 

https://www.loverslab.com/topic/156041-sims3wip-kinkyworld-v037-updated-may-3rd-2019-wikipage/

 

You may also need to begin "cleaning" your saves. I should probably add a link to Kuree's save cleaner.

 

 

Share this post


Link to post
1 hour ago, LadySmoks said:

At this point, it is possible to play your game

I've read that it's not wise to run the game with the Kinkyworld mod in the packages folder while not registered. I'm sure some tech person could explain why, but wanted to add this just in case.....

 

We know most mods don't require registration to work, we just drop them in the folder and clear caches. So the game WILL read the KW mod, even if not registered. I'm not sure what effect this has, but you know me - better safe than sorry.

Share this post


Link to post
22 minutes ago, landess said:

not wise to run the game with the Kinkyworld mod in the packages folder while not registered.

I haven't seen that. Not saying I have seen everything! We tend to only look when we have a particular problem, or sometimes stumble across info while searching for something else. ))) But, although the game may or may not read KW, the missing "everything" is restored by disabling it. I honestly don't know if leaving it in will affect game speed, as that wasn't the problem I was having. It was KW scripts taking over tooooooooooooooooooo much, so I shut it down for a while so I could do what I wanted to do in MY game, without KW telling my sim to take off her panties, or do a striptease, after I told her to play chess. I shut KW down all of the time because of the way it takes over.

Share this post


Link to post
18 minutes ago, LadySmoks said:

stumble across info while searching for something else

I'll admit this isn't the only place I've read about KW use and leave it at that. If OnikiKay had a dollar for everyone using the game mod, retirement would be a possibility.

Share this post


Link to post
2 hours ago, landess said:

this isn't the only place I've read about KW use

Same here. But other sites that I have looked at, very often tell people to ask at LL. That's why I have said it's such a joke that Oniki continues to "Thank" LL in her intro. But, I guess it does help people come here and find other mods and CC that we have here.

Share this post


Link to post
On 11/19/2020 at 9:34 PM, Clydie said:

 

On 11/19/2020 at 9:34 PM, Clydie said:

The only way I see here is to re-setup the game as of the time you did the last save with KW (Animations are not necessary to reinstall). Load the game open the KW menu and click uninstall the mod (KW).

After that, do another renamed save. Then you remove KW and the related packages again and try to load the new save.

This is the only way I consider as maybe working to get rid of KW and keeping your world. Good Luck !

Should i reinstall the KW (only the mod itself not animations first?) then uninstall it ? also Nraas mods giving Script error. I'm new for the both LL animations and KW. I'll try your suggestions thanks, that means a lot ❤️

 

On 11/20/2020 at 12:22 AM, landess said:

Agreed! THIS should be #1 at the top of user instructions on the OP since most mod users aren't deep enough into mods to understand the intricacies of script use, save functions, and the concept of a mod which has it's own registration tool (this is a major give-away).

 

I recommend pausing the game and using reset world before un-registering as well, to keep the game from adding anything to the queue before removal before creating a new 'cleaned' save.

 

>This needs to be done on EVERY SAVE which had KW use if those saves are to be used in the future without KW. (This would take me several hours as I have just over 90 saves with KW). Out of the four 'auto saves' made with NRaas 'saver', I usually only keep the last two.

 

The thing is the Nraas mods aren't working either and giving lots of script errors also when i try to save the game I'm getting error code 12 due to low RAM, hence i can't use Saver. T___T but thanks for the tips ❤️

 

21 hours ago, LadySmoks said:

It may be two parts. I have had this problem. First, load a save BEFORE you removed KW. After everything loads, including KW, go to the menu and disable KW... do NOT uninstall yet... only select "disable" option. This will stop KW script interactions. Save your game using "Save As". Always use "Save As", as it creates a completely new file, and your original will remain safe. After you save the game, quit, and then restart with the new save that KW is disabled. Check that everything you want remains. Understand that ALL interactions, traits, moodlets, sexbot chips, anything that is part of KW will not be there... SHOULD NOT be there.

 

At this point, it is possible to play your game. If you still want to remove KW, now return to the KW menu and click "uninstall". Again use "Save As" to create a new save file, then quit without saving again. Now, restart and load that last save, and you should be okay.

 

Your original problem may be that your machine can not handle the extra load. There are links to info on this page that I posted...

 

https://www.loverslab.com/topic/156041-sims3wip-kinkyworld-v037-updated-may-3rd-2019-wikipage/

 

You may also need to begin "cleaning" your saves. I should probably add a link to Kuree's save cleaner.

 

 

Umm yeah i have 3 GB RAM and i read that isn't enough for the minimum requirements. Will reinstalling KW rescue my latest save? 😞 Thanks I'll check out the link that you have posted. ^^

Share this post


Link to post
2 hours ago, Vandalarius said:

3 GB RAM

If that is your total, it is a little low, but without mods that expand RAM usage, Sims 3 has a built in limit that it will only use 2GB of RAM. Many, including me, turn on task manager to monitor what Sims 3 is doing.

 

If your machine only has 3GB RAM, it is probably not a very powerful laptop, which is what is needed for Sims 3 with expansion packs and other add ons.  Remember that "minimum" requirements means basically that you can run the base game, with absolutely no CC or mods added. Like carrying things. A person carries 5 kilos easily, but 20, 30, 100??????? You need more muscle!!! I started a page in the technical support section that has links to a few helpful sites and pages, including one with some computer specs.

 

As to reinstalling KW, yes. But to be safe, put everything back in, then restart your game. Everything should return. When KW finishes it's loading, go to settings and disable it. Use "Save As", and then quit without saving. Then, restart your game and see how it goes. At this point, you can continue to play, or uninstall KW. Landess said he has read that leaving it in can cause problems, but I do it all of the time, as sometimes, KW takes over too much, I shut it down so I can do things without KW autonomous interactions and then will just turn it on again.

 

I also have a decent Asus TUF gaming laptop. Not the greatest, but good enough to carry 99 kilos (maybe not 100). ))) So, that helps.

Share this post


Link to post

We can see the problem started long before KW was even installed. When basic PC program use was not understood, what followed is not surprising.

 

I spent MANY years running an average of 3-5 years behind the 'times'. Of course things 'have slowed' recently but no need for a long post on computer science is needed to simply say: Shit was a lot cheaper if one bought it 3-5 years after release. So systems, parts and games 'were' probably around 25-30% of their original cost. By not being 'first' I got the same experience as everyone else, I just got it later - a lot more of it for the same price, or the same amount for pennies on the dollar.

 

This meant I needed to understand the limits of my system and choose games accordingly. I remember one upgrade was because WIN95/98SE wasn't being supported on games, and my system wasn't a good choice for WIN XP.

 

This whole post reminds me of what happens when one uses the wrong tool for the job, and then asks for help fixing the mess made when shit inevitably goes sideways. Not understanding (being nice for the benefit of doubt) the basic problem and sharing that info first has many coming in trying to solve why the elevator won't go up because the users have exceeded it's weight limit.

 

More and more I see why consoles are needed.

Share this post


Link to post
1 hour ago, landess said:

won't go up because the users have exceeded it's weight limit.

I wish more people saw the page I started and took time to follow the link to realistic system requirements (among other things). The problem is that Sims 3 as a vanilla game runs fine on a $200.88 2001 Walmart blue light special with a 128 GB hard drive, single core processor designed for making shopping lists and storing photos, and has 2GB RAM with Windows XP. Then people think they can load up whatever they can download, and everything will be fine, since no one ever puts in the CC or mod description that their mod adds "X" load and will blow up your Walmart computer. Not that anyone takes time to read mod descriptions past the first sentence anyway...

 

And big numbers don't mean a thing, if they aren't the right numbers. 32 GB RAM upgrade won't help anyone with a maxed out hard drive, small, old, slow processor, integrated chip set video card, etc...

 

My new ASUS still has it's not so good moments, as I continually load more and more CC into it, and in not the most stable fashion. But, it's made to pull a good sized load. Now, I'm luckier than some, in that I can afford it, and not as lucky as those who can afford NASA surplus machines that can run more calculations per nano-second than most could imagine. So, I understand that money IS a factor, and people do need to better research what the game really needs to run, and not what EA said was minimum for a vanilla base game.

Share this post


Link to post
On 11/21/2020 at 5:56 PM, LadySmoks said:

If that is your total, it is a little low, but without mods that expand RAM usage, Sims 3 has a built in limit that it will only use 2GB of RAM. Many, including me, turn on task manager to monitor what Sims 3 is doing.

 

If your machine only has 3GB RAM, it is probably not a very powerful laptop, which is what is needed for Sims 3 with expansion packs and other add ons.  Remember that "minimum" requirements means basically that you can run the base game, with absolutely no CC or mods added. Like carrying things. A person carries 5 kilos easily, but 20, 30, 100??????? You need more muscle!!! I started a page in the technical support section that has links to a few helpful sites and pages, including one with some computer specs.

 

 

I also have a decent Asus TUF gaming laptop. Not the greatest, but good enough to carry 99 kilos (maybe not 100). ))) So, that helps.

You're absolutely right, Sims 3 is the only game that my pc is can run, once i had a 1 GB video card and it's broken a few years ago and i can't buy a new one because dollar is quite expensive in my country since they're imported from other countries. I'm using a desktop pc more than 10 years, i think i need to remove the expansion packs and mods first. Thank you so much for your sincere response. I'm so grateful 😃

 

20 hours ago, landess said:

We can see the problem started long before KW was even installed. When basic PC program use was not understood, what followed is not surprising.

 

I spent MANY years running an average of 3-5 years behind the 'times'. Of course things 'have slowed' recently but no need for a long post on computer science is needed to simply say: Shit was a lot cheaper if one bought it 3-5 years after release. So systems, parts and games 'were' probably around 25-30% of their original cost. By not being 'first' I got the same experience as everyone else, I just got it later - a lot more of it for the same price, or the same amount for pennies on the dollar.

 

This meant I needed to understand the limits of my system and choose games accordingly. I remember one upgrade was because WIN95/98SE wasn't being supported on games, and my system wasn't a good choice for WIN XP.

 

This whole post reminds me of what happens when one uses the wrong tool for the job, and then asks for help fixing the mess made when shit inevitably goes sideways. Not understanding (being nice for the benefit of doubt) the basic problem and sharing that info first has many coming in trying to solve why the elevator won't go up because the users have exceeded it's weight limit.

 

More and more I see why consoles are needed.

 

Actually Sims 3 worked perfectly with my previous system but as i said my video card is broken , now i'm getting errors and my game is constantly crashing (esp during CAS) I think there's no fix for that outside of improving the system. Anyway thanks for the help! Much appreciated.

Share this post


Link to post
1 hour ago, Vandalarius said:

i had a 1 GB video card

That is probably the problem. Yes, you will need to run fewer EPs on one game. Also, try merging packages to see if that helps. Run Kuree's Save Cleaner (if it works for you)... otherwise, you can use s3pe to clean the bloat of IMG and SNAP files in the save packages.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...