Jump to content
Sign in to follow this  
vinamael

Cloaks of Skyrim - Changing the slot

Recommended Posts

Short Description:

 

I am trying to change the slot for a cloak in the Cloaks of Skyrim mod.  The problem I am having is that, once in game, the cloak isn't visible.

 

Long Description:

 

I changed the Black Linen Cloak to slot 45(Cape) & 40(Tail) as that is suppose to be for cloaks/capes and left slot 40 in since it was already there.  I changed the slot for both the main mod and the smp patch in XEdit.  I then changed it in Nifscope.

 

Once I saw that the cloak wasn't visible, I went back to XEdit & Nifscope to remove the 40 slot.  Same issue; no showing of the cloak.

 

I then removed the body and feet in Nifscope, but the cloak was still not showing.

 

Finally, I changed the slots to 57(Shoulder) & 45(Cape), still the same issue.

 

Conclusion:

 

I am new to this and only did it with one other piece.  I made it so the Rektas's Thaler bra could be worn under SunJeong's Dibella Silks.  I followed Pork Type's Guide and with a little editing in Outfit Studio, it works perfectly.  I am not having the same success with Cloaks of Skyrim, however.  The reasoning for the change is, the cloak uses slot 46 and that is the slot I used for the thaler bra.

 

So, how am I screwing this up and how do I fix it? 

Share this post


Link to post

1) In Nifskope: NiTriShape -> right-click BSDismemberSkinInstance -> Block -> left-click Convert -> NiS... -> NiSkinInstance

 

Do this for every part of the cloak.  This turns off the slot masking for the item so you won't have to wonder if you missed something and will be free to change it to something else later.  BSDismemberSkinInstance is nearly useless in Skyrim, and you don't need it.  (It basically only functions for specific slots anyway.  30, 31, 32, 33, 34, 37, 38, 50 and 51 and a couple of hair slots.  Most of the time, these do nothing with the exception of 50 and 51 which involve decapitation events and bad items here can cause crashes.)

 

If your cloak has two models (_1.nif and _0.nif), make sure to do it for both.

 

2) In CK or xEdit -> Armor -> whatever the cloak you want is -> change the slot to 45.  Just 45, not a mixture.  Adding a bunch of slots to the armor just handicaps you later for no good reason.  It has to have one, but only needs one.

 

3) In CK or xEdit -> Armor Addon -> whatever the cloak links to -> change slot to 45.  Just 45 for now.  Add 40 later if you want it to hide tails.  The slots in the Armor Addon will control what is seen in the game when items with the same slots are equipped.  Set the priority on the cloak very high (say, 15 or 20) since it should never be hidden by clothing.  If the cloak has two models (_1.nif and _0.nif), make sure that enable weight slider is checked.  If it has only one model, make sure weight slider is unchecked.

 

If you did all that (and I didn't forget a step), it should work.

Share this post


Link to post
4 hours ago, Seijin8 said:

1) In Nifskope: NiTriShape -> right-click BSDismemberSkinInstance -> Block -> left-click Convert -> NiS... -> NiSkinInstance

 

Do this for every part of the cloak.  This turns off the slot masking for the item so you won't have to wonder if you missed something and will be free to change it to something else later.  BSDismemberSkinInstance is nearly useless in Skyrim, and you don't need it.  (It basically only functions for specific slots anyway.  30, 31, 32, 33, 34, 37, 38, 50 and 51 and a couple of hair slots.  Most of the time, these do nothing with the exception of 50 and 51 which involve decapitation events and bad items here can cause crashes.)

 

If your cloak has two models (_1.nif and _0.nif), make sure to do it for both.

 

2) In CK or xEdit -> Armor -> whatever the cloak you want is -> change the slot to 45.  Just 45, not a mixture.  Adding a bunch of slots to the armor just handicaps you later for no good reason.  It has to have one, but only needs one.

 

3) In CK or xEdit -> Armor Addon -> whatever the cloak links to -> change slot to 45.  Just 45 for now.  Add 40 later if you want it to hide tails.  The slots in the Armor Addon will control what is seen in the game when items with the same slots are equipped.  Set the priority on the cloak very high (say, 15 or 20) since it should never be hidden by clothing.  If the cloak has two models (_1.nif and _0.nif), make sure that enable weight slider is checked.  If it has only one model, make sure weight slider is unchecked.

 

If you did all that (and I didn't forget a step), it should work.

Thank you for your help.  Turns out part of the problem was me not paying attention to the file name.  Turns out I was changing the male cloak and not the female cloak.  

 

Goal achieved!

 

Spoiler

20200802011031_1.jpg.00732cf4045d099ab75f7926bff4a848.jpg

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...