Jump to content
Garblesnarf

FNIS Causes Frozen and T-Posing Creatures

Recommended Posts

I have a couple of creature animation mods installed, but when I load the game the affected creatures aren't animated and T-Pose without moving. They also stay still when they aggro. They go back to vanilla animations again when I De-Install Creatures, but then the mods are rendered pretty much useless. Anyone got any ideas?

 

FNIS Behavior V7.6 XXL   23.05.2020 02.40.35
Skyrim SE 64bit: 1.5.97.0 - E:\Steam\steamapps\common\Skyrim Special Edition\ (Steam)

Skeleton(hkx) female: XPMS2HDT (126 bones)   male: XPMS2HDT (126 bones)
Patch: "SKELETON Arm Fix"  

Reading 0Sex_0M2F_A V?.? ...     ChAnims:186     CTD:2,2%     pOpt:1,4%
Reading 0Sex_0MF_D V?.? ...     ChAnims:204     CTD:2,4%     pOpt:1,6%
Reading 0Sex_0MF_K V?.? ...     ChAnims:288     CTD:3,3%     pOpt:2,2%
Reading 0Sex_0MF_M V?.? ...     ChAnims:244     CTD:2,8%     pOpt:1,9%
Reading 0Sex_0MF_R V?.? ...     ChAnims:104     CTD:1,2%     pOpt:0,8%
Reading 0Sex_0MF_S V?.? ...     ChAnims:230     CTD:2,7%     pOpt:1,8%
Reading 0Sex_0MF_U V?.? ...     ChAnims:344     CTD:4,0%     pOpt:2,6%
Reading 0Sex_BB_A V?.? ...     ChAnims:92     CTD:1,1%     pOpt:0,7%
Reading 0Sex_BG_A V?.? ...     ChAnims:194     CTD:2,2%     pOpt:1,5%
Reading 0Sex_EMF_A V?.? ...     ChAnims:56     CTD:0,7%     pOpt:0,4%
Reading 0Sex_WZH0_A V?.? ...     ChAnims:62     CTD:0,7%     pOpt:0,5%
Reading Anubs Creature V1.0 ...     ChAnims:467     CTD:2,8%     pOpt:0,6%
Reading Anubs Futa V1.0 ...     ChAnims:46     CTD:0,6%     pOpt:0,4%
        NOTE: Anubs Futa has at least one identical -AV defined in both 's' and '+' line
Reading Anubs Human V1.0 ...     ChAnims:898     CTD:5,3%     pOpt:1,2%
Reading Defeat V5 ...     ChAnims:39     CTD:0,5%     pOpt:0,2%
Reading FNISBase V7.6 ...     ChAnims:0     CTD:0,0%     pOpt:0,0%
Reading FNISCreatureVersion V7.0 ...     ChAnims:0     CTD:0,0%     pOpt:0,0%
Reading Follow me for Sex V3.6 ...     ChAnims:88     CTD:0,9%     pOpt:0,5%
Reading MoreNastyCritters V1.0 ...     ChAnims:344     CTD:2,2%     pOpt:0,6%
Reading P1FlyingRing V?.? ...     ChAnims:39     CTD:0,2%     pOpt:0,0%
        NOTE: P1FlyingRing uses outdated behavior file (may invalidate CTD Load calculation)
Reading SexLab V1.63 ...     ChAnims:882     CTD:5,6%     pOpt:1,5%
Reading SexLabAP V1.63 ...     ChAnims:142     CTD:0,9%     pOpt:0,2%
Reading SexLabAroused V2.9 ...     ChAnims:5     CTD:0,1%     pOpt:0,0%
Reading SexLabCreature V1.63 ...     ChAnims:177     CTD:1,2%     pOpt:0,3%
Reading SRBCreatures V1.0 ...     ChAnims:23     CTD:0,2%     pOpt:0,0%
Reading XPMSE V7.2 ...     ChAnims:164(164)     CTD:2,2%     pOpt:0,0%
Reading _ESG_0ER_F V?.? ...     ChAnims:16     CTD:0,2%     pOpt:0,1%
Reading _ESG_0ER_M V?.? ...     ChAnims:7     CTD:0,1%     pOpt:0,1%

All Anim Lists scanned. Generating Behavior Files...
Alternate Animation mods: 1 sets: 16 total groups: 30 added file slots: 170 alternate files: 164

Create Creature Behaviors ...
Reading MoreNastyCritters V1.0 ...
Reading Anubs Creature V1.0 ...
Reading SexLabCreature V1.63 ...
Reading SRBCreatures V1.0 ...

 5341 animations for 28 mods successfully included (character)
ChAnims: 5341  CTD:46,9%  pOpt:21,1%  max: 11394  LC: 12264 (max. 26162)

 1592 animations for 4 mods and 39 creatures successfully included.
 

Share this post


Link to post
Quote

 

5. make sure you have "Allow Creature Animation" checked in SexLab's MCM settings.

 

6. turn off "Match Creature Gender" in sexlab's MCM settings, if this setting is enabled some animations won't play.

 

7. did you forget to install the FNIS Creature Pack? install it and rerun the GenerateFNISforUsers.exe, then do steps 5 & 8
NOTE: if you do have the Creature Pack but some creatures are just playing idle animations during sex try clicking on "De-Install Creatures" in FNIS, after it's done running click on "Update FNIS Behavior"
(doing this will delete all the creature behavior files generated by FNIS and remake new ones...that is assuming you DO have the FNIS Creature Pack installed)

 

8. you may need to reload the animations, go to the Animation Loader's MCM and then:
8.1. click on the "Disable All" button.
8.2. click on "Rebuild Animation Registry", then Wait for the message to pop up*.
8.3. click on "Reload JSON".
8.4. click on "Enable All".
8.5. click on "Count Animations" and make sure nothing is over 650, turn off some animations if they are.
8.6. click on "Register Animations", then Wait for the message to pop up*.
*if you like you can press "~" on your keyboard to open the console so you can watch it Register everything, just make sure you close it before you try to click on anything.

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...