Jump to content
IGNORED

[Rimworld 1.3] RJW Animation Framework


c0ffeeeee

Recommended Posts

hey there - I was hoping you could maybe help me out with something relating to animation filtering.

I noticed that some of the beast oral animations I created for the animal animations addon pack aren't triggering properly. when you choose an oral option via the rape menu, the animations are selected properly. however, when an oral interaction is selected randomly by the RJW "invite for breeding" option, the animations don't trigger properly. the animation framework reports that it is choosing a random animation via the debug log. this only happens when using the consensual "invite for breeding" menu, the rape menu selects the oral animations just fine. they also used to get selected just fine before RJW updated the bestiality menu to only include "invite for breeding".

any ideas on why this might be happening? any insight would be appreciated, I am still not super fluent in xml modding.

Edited by IriX640
Link to comment
On 9/22/2021 at 7:54 PM, IriX640 said:

hey there - I was hoping you could maybe help me out with something relating to animation filtering.

I noticed that some of the beast oral animations I created for the animal animations addon pack aren't triggering properly. when you choose an oral option via the rape menu, the animations are selected properly. however, when an oral interaction is selected randomly by the RJW "invite for breeding" option, the animations don't trigger properly. the animation framework reports that it is choosing a random animation via the debug log. this only happens when using the consensual "invite for breeding" menu, the rape menu selects the oral animations just fine. they also used to get selected just fine before RJW updated the bestiality menu to only include "invite for breeding".

any ideas on why this might be happening? any insight would be appreciated, I am still not super fluent in xml modding.

I left some debugging log info if you enable debug mode in the anim settings, try enabling it and seeing what it says regarding the types and races

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...